P: Sub-tool reverts back to primary tool in slot every time a new document is open

12 Votes
Explorer ,
Dec 03, 2015 Dec 03, 2015

Copy link to clipboard

Copied

Photoshop CC 2015.1 Release, Line tool (U) reverts back to Square tool everytime a new document is open. This used to remain on the previous selection (Line Tool). Very annoying with the latest release. Adobe please address.

Bug Fixed
TOPICS
macOS , Windows

Views

48

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 21, 2016 Jun 21, 2016

Votes

Translate

Translate
45 Comments
Adobe Employee ,
Dec 09, 2015 Dec 09, 2015

Copy link to clipboard

Copied

Hi Michael,

What OS are you running on?  Are you seeing this all the time?  I've tried Win8.1 and Mac 10.11 but cannot reproduce this.

We'd like to fix it, but will need some more information to do so.

Thanks,
David

Votes

Translate

Translate

Report

Report
Explorer ,
Dec 10, 2015 Dec 10, 2015

Copy link to clipboard

Copied

I am also having this problem, it seems to affect every tool that I use. The toolbar always reverts back to the first option for each tool, ie - Healing Brush (J) switches to Spot Healing Brush, Magic Wand (W) switches to Quick Selection tool, etc.

It happens whenever I open a new document, however it only affects tools that are not selected. Ie- if I change both the magic wand tool and the healing brush tool, and have the healing brush selected when I close my document, when I open the new document the healing brush will still be selected but the magic wand will have reverted back to the quick select tool.

I am using Photoshop 2015.1 on Mac OS X 10.10.5

Votes

Translate

Translate

Report

Report
New Here ,
Dec 12, 2015 Dec 12, 2015

Copy link to clipboard

Copied

Sames, Windows and Mac

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 14, 2015 Dec 14, 2015

Copy link to clipboard

Copied

We've figured out the trigger and are now looking into this issue.  Thank you for bringing it to our attention and sorry for the inconvenience.

David

Votes

Translate

Translate

Report

Report
Participant ,
Dec 14, 2015 Dec 14, 2015

Copy link to clipboard

Copied



The tools reset everytime, and not only that, as i've mentioned it in a previous post, the Tools windows disappears aaand you must re-enable 'em at Window->Workspace->Essentials/Your customized one

Even if you recover the Workspace, the tools are Reset

"Don't fix what's not broken" ? ^^;;;;;;

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Dec 15, 2015 Dec 15, 2015

Copy link to clipboard

Copied

As David states, engineering is looking into a fix. Workaround in the meantime: Uncheck "Show Start Workspace..." in Preferences>General... and restart Photoshop the problem won't occur after that.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 28, 2015 Dec 28, 2015

Copy link to clipboard

Copied

Any update on this? I have the same issue and was hoping it would be resolved with today's Photoshop CC update, but it doesn't appear it has been.

Votes

Translate

Translate

Report

Report
Participant ,
Dec 28, 2015 Dec 28, 2015

Copy link to clipboard

Copied

Wait, there's a photoshop update for today?.. I don't have it in my ACCloud menu

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 28, 2015 Dec 28, 2015

Copy link to clipboard

Copied

No, there hasn't been any update for Photoshop in the past few weeks.
Someone got a delayed notice, or confused updates.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 28, 2015 Dec 28, 2015

Copy link to clipboard

Copied

Hi all. I've same problem but it accurs when I use blur gallery.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 28, 2015 Dec 28, 2015

Copy link to clipboard

Copied

Hi all. I've same problem but it accurs when I use blur gallery.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 20, 2016 Jan 20, 2016

Copy link to clipboard

Copied

This should be solved in the 2015.1.2 update released today: http://blogs.adobe.com/crawlspace/201...

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
New Here ,
Jan 21, 2016 Jan 21, 2016

Copy link to clipboard

Copied

This isn't fixed for me. When I switch to the paint bucket tool, then close and reopen Photoshop and press G it goes back to the gradient tool.

Votes

Translate

Translate

Report

Report
Participant ,
Jan 21, 2016 Jan 21, 2016

Copy link to clipboard

Copied

FIXED FOR ME...for now....

Votes

Translate

Translate

Report

Report
Participant ,
Jan 23, 2016 Jan 23, 2016

Copy link to clipboard

Copied

I HAVE THE SAME PROBLEM BACK

Whenever i leave Photoshop with the Wand Tool and the Paint Bucket being there, i press the BRUSH tool just so photoshop remembers the last known tool used..

i close the program (via X or File->Exit) and once i open Photoshop via a PSD file, the tools are there correctly, yes...BUT if i press G or W (PB and MW respectively), THEY REVERT BACK TO THEIR DEFAULT TOOLS (Gradient and the other wand thingy)

THE PROBLEM IS NOT SOLVED!!

Need a video about it?

Votes

Translate

Translate

Report

Report
Engaged ,
Jan 23, 2016 Jan 23, 2016

Copy link to clipboard

Copied

DV2 The Fox,

did you see the post/video about the placement order of the tools in a custom Toolbar being directly linked with their default state yet?

--

Couple of issues I have with tools/Toolbar:

1. The Move Tool will not stay selected when quitting and restarting Photoshop. Instead the Rectangular Marquee Tool is always active by default. The majority of the time Move Tool is the first tool I use. Granted, this is very specific but surely it's not intentional on your part to force Move Tool to NOT be selected at launch.

2. Direct Select and Path Select will not remember my "All Layers" choice. Every time it sets them back to "Active Layers".

These kinds of "little" problems are really getting old and are just silly at this point. They're compounding and making Photoshop an irritation to use.

Votes

Translate

Translate

Report

Report
Participant ,
Jan 24, 2016 Jan 24, 2016

Copy link to clipboard

Copied

No, because i don't find it in this post nor any other.

Votes

Translate

Translate

Report

Report
Engaged ,
Jan 24, 2016 Jan 24, 2016

Copy link to clipboard

Copied

Ok, I'll try and find it for you. In the mean time you can try this; whatever tool you want it to default to, put it first (at the top) of the Toolbar subgrouping. For example, I like Healing Brush to be the default choice so it's at top.



Also, as glitchy as PS has become I avoid this altogether by not sharing shortcuts for tools. As you can see for example the "H" key is dedicated to one tool and not shared between them.

Here's a link that might help you out.

https://forums.adobe.com/thread/2051410

Votes

Translate

Translate

Report

Report
Participant ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Updated Photoshop to Today's (March 16th 2016) update... The issue remains...

Votes

Translate

Translate

Report

Report
New Here ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Yea still broken, but only when you close Photoshop and reopen. The new document part is fixed.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

Photoshop hasn't had an update since January, are you confusing the Camera Raw update with a Photoshop update?

Votes

Translate

Translate

Report

Report
Participant ,
Mar 16, 2016 Mar 16, 2016

Copy link to clipboard

Copied

No.

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 17, 2016 Mar 17, 2016

Copy link to clipboard

Copied

Again, Photoshop hasn't had any updates since January (16.1.2 update).

Votes

Translate

Translate

Report

Report
New Here ,
Mar 17, 2016 Mar 17, 2016

Copy link to clipboard

Copied

Is this a known issue, that's going to be fixed?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 17, 2016 Mar 17, 2016

Copy link to clipboard

Copied

I also still have the problem using PS 2015.1.2 on a Mac running OSX 10.9.5. Deselecting "Show Start Workspace..." in Preferences>General did not help for me.

Votes

Translate

Translate

Report

Report