P: Text on path not exported correctly to pdf PS 23.0.1

1 Vote
Community Beginner ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

I opened an existing PSD file, created a new path for a text layer. Put text on the path.

Exported it to PDF.

 

Expected: Text shows as on edit.

 

Result: Text shows as attached and breaking the orientation.

Existing paths do not have this problem though.

 

I have attached a JPG export as well so you can see that it exports correctly to JPG.

TEST PS BUG pdf Screenshot.png

Bug Started
TOPICS
macOS, Windows

Views

96

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Employee , Nov 15, 2021 Nov 15, 2021
A caution to the workaround above: It can be applied if the script is Latin or CJK. If you are using Middle East or North African scripts, you cannot use this workaround. Rasterize type if that is the case.

Votes

Translate

Translate
Adobe Employee , Nov 15, 2021 Nov 15, 2021
Thank you for reporting the issue. I was able to reproduce the issue. Dev will work on the fix.   In the meantime, as a workaround, please do the following steps. Select the type layer in Layers panel Open Paragraph panel and open the context menu Select "Latin and East Asian Layout" Subsequent creation of PDF should show correct output.  

Votes

Translate

Translate
Adobe Employee , Nov 15, 2021 Nov 15, 2021
Thanks. Running this by the engineering team.

Votes

Translate

Translate
8 Comments
Community Beginner ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Screenshot from expected result (from the export as JPG):

SupremeChaosRecords_0-1636722737435.png

 



Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Seems to work for me. I used the default PDF settings from Save a Copy > PDF. Anything special about your PDF export options?

JeffreyTranberry_0-1636733974382.png

 


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

Sorry, looked at your PSD and it's been rasterized. Can you post the PSD that has the text layers in it?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Sorry for the flattened PSD - my fault.

 

I use Save As and PDF/X-3:2002 but also tried others.

 

Enclosed a new PSD File, same result: https://shared-assets.adobe.com/link/c0dff00b-e9aa-48a7-69fb-3cb3a9a211d8 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Plus I am running on a Windows system. (Win 10 64bit, latest updates, PS 23.0.1 64bit, Acrobat DC Pro for viewing - but same result when viewed with crome for example).

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Thanks. Running this by the engineering team.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Thank you for reporting the issue.
I was able to reproduce the issue. Dev will work on the fix.
 
In the meantime, as a workaround, please do the following steps.
  1. Select the type layer in Layers panel
  2. Open Paragraph panel and open the context menu
  3. Select "Latin and East Asian Layout"
Subsequent creation of PDF should show correct output.
 
Paragraph Panel sm.png

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

LATEST
A caution to the workaround above: It can be applied if the script is Latin or CJK. If you are using Middle East or North African scripts, you cannot use this workaround. Rasterize type if that is the case.

Votes

Translate

Translate

Report

Report