Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop: Export As error: "An unknown error occurred"

9 Votes
Engaged ,
Nov 29, 2018 Nov 29, 2018

Copy link to clipboard

Copied

Bug Fixed
TOPICS
Desktop

Views

369

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 12, 2021 Jan 12, 2021
Thanks for reporting this issue. Please install 22.1.1 which was released late last night. It contains a fix for unknown errors in Export As.

Translate

Translate
42 Comments
Community Beginner ,
Jan 21, 2019 Jan 21, 2019

Copy link to clipboard

Copied

Guaranteed to get this error if anything is selected before doing Export As.  Even if nothing is selected, I have to wait after EVERY change to the configuration of the dialog to not get that Unknown Error.  Change from PNG to JPG, wait for the preview render.  Change from Quality 100% to 77%, wait for the preview render.  Change Width from native to 2048 (for exporting to social), wait for the preview to render.  Change the Embed Color Profile to be enabled, wait for the preview to render.  So long as I wait for the previews with every change, it works.

Windows 10 Pro, latest version of Ps in January 2019, video drivers fully updated (NVIDIA), 32GB of RAM.

Please, please. please just don't do the preview render!

Translate

Translate

Report

Report
Adobe Employee ,
Jan 23, 2019 Jan 23, 2019

Copy link to clipboard

Copied

Hi Richard, Jeff,

Sorry for the trouble we caused. We cannot reproduce this in house and like to investigate.
Could you send me your test files?

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

How would you like me to send you the file?  I have a PSB that demonstrates the problem pretty well. 

Though I have to say that I upgraded NVIDIA drivers just released here in January 2019 and from Ps 20.0.1 to 20.0.2 and now I can't make the issue happen if I have some kind of selection made causing Export As to fail.  But if I change values in the dialog box before letting the preview complete it gives me unknown error.

Translate

Translate

Report

Report
Community Beginner ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

I also have a PSD that causes the same issue.  If I don't wait after changing one of the configuration settings in the dialog box for the preview to build before changing another setting (like going from PNG to JPEG and then changing the JPEG quality from 100% to 77%) it fails with Unknown Error.  I see this happen more with large files where it takes more time to build the preview.

The thing I really would love is if Ps didn't rebuild the preview every time one of these configuration items is changed in the dialog box.  It doesn't happen on all of them (can add the copyright info without it causing the preview to update) but for most of them a change makes the preview rebuild and on these larger files that takes a long time.  I don't even use the preview for anything material.  Needs to not fail if you change something in the dialog box before the preview is done, but it would save me even more time if Ps wasn't working so hard to build a preview that I don't need.

Translate

Translate

Report

Report
Adobe Employee ,
Jan 24, 2019 Jan 24, 2019

Copy link to clipboard

Copied

Thanks Jeff for your detailed information!
So your issue is same as this?

Translate

Translate

Report

Report
Community Beginner ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

Yes, it looks a lot like that.

Translate

Translate

Report

Report
Adobe Employee ,
Jan 29, 2019 Jan 29, 2019

Copy link to clipboard

Copied

OK Thanks. This issue has been logged.

Translate

Translate

Report

Report
Engaged ,
May 07, 2019 May 07, 2019

Copy link to clipboard

Copied

I get the same issues. Is this resolved?

Translate

Translate

Report

Report
Engaged ,
Jun 24, 2019 Jun 24, 2019

Copy link to clipboard

Copied

"DISABLE EXPORT PREVIEW" THE settings option I've desired for over a decade.
What do we need to preview? not even sure why this isn't just a collapsible panel that uses the main dialog view.
Even when using slices.
Haven't found it useful once
100% waste of memory resources, at least start the previewer "fit to veiwer" 

Can take longer to preview than load PS and construct something new sometimes, we know what it looks like...

Translate

Translate

Report

Report
Engaged ,
Mar 10, 2020 Mar 10, 2020

Copy link to clipboard

Copied

Same issue since Update to 21.1 on macOS Catalina 10.15.3



Deinstalled and installed again. Did not solve it.

Update: tested in all available Versions back to 20.0.8
Issue exists in each.

Translate

Translate

Report

Report
Engaged ,
Apr 27, 2020 Apr 27, 2020

Copy link to clipboard

Copied

Im now having this/similar issue aswell. New PC, new, clean windows 10 pro 64bit system, everything up to date. I have observed even more weird things happening when i "export as" with multiple layers/artboards selected. Not sure if you would prefer me to re-write everything here, or just paste a link, but i think link to adobe forums is preferable: https://community.adobe.com/t5/photoshop/photoshop-cc-2020-quot-export-as-quot-multiple-layers-artbo...
An extract:
The "export as" window seems to be messed up for me. Some layers/artboards wont ever load, will keep loading till yellow mark with "unknown error". Whenever i use any options like "8bit png", "convert to srgb", change the format etc. the positions and their previews gets randomly messed up, changing previews even for what was previously properly displayed (like graphic "3" next to name of "e1" layer which should have "1" image preview):

Translate

Translate

Report

Report
Engaged ,
Apr 27, 2020 Apr 27, 2020

Copy link to clipboard

Copied

Translate

Translate

Report

Report
Engaged ,
Apr 27, 2020 Apr 27, 2020

Copy link to clipboard

Copied

Translate

Translate

Report

Report
New Here ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Ryzen 3700x. Same problem.

Translate

Translate

Report

Report
Community Beginner ,
Jun 30, 2020 Jun 30, 2020

Copy link to clipboard

Copied

Translate

Translate

Report

Report
Engaged ,
Sep 18, 2020 Sep 18, 2020

Copy link to clipboard

Copied

I get this error constantly on my PC 

 

Ryzen 5 2600X and a RTX 2070.

 

Meanwhile on my 11 year old Mac Pro I can export the same exact file without a single issue.

 

 

 

Translate

Translate

Report

Report
Engaged ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

When I try to export it, it would always say unknown error. When I try to save it, it always says program error

Translate

Translate

Report

Report
New Here ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

The issue is back, it was caused by the update in installed today. None of the usual fixes work. Quick export is also not working.

Translate

Translate

Report

Report
Adobe Employee ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Can you try this:

Go to Preferences > Technology Previews... and check "Enable optimized Export As" - Then restart Photoshop. Does it work after restart?

Senior Product Manager - Customer Advocacy - Digital Imaging

Translate

Translate

Report

Report
Engaged ,
Dec 15, 2020 Dec 15, 2020

Copy link to clipboard

Copied

Same problem here, I tried your solution but it dit not change anything. 

Translate

Translate

Report

Report
Engaged ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

I am also experiencing this issue on Photoshop 22.1.0 on an iMac Pro running Mac OS 10.15.7.

Translate

Translate

Report

Report
Engaged ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

I tired the Technology Previews - "Enable optimized export as" and the only improvement is that the quick export will create an empty (zero bytes) file but the Export As malfunction is the same as before.

Translate

Translate

Report

Report
Engaged ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

I am also having a problem when exporting, it informs that in the visualization an unknown error occurred and does not present the images to be exported. Also, I can't save the project. I have already tested other ADOBE programs and none of them showed errors, only photoshop. I have tried some methods, I have reinstalled the program and it remains.

Translate

Translate

Report

Report
New Here ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

Found the solution through adobe support, it's related to the new graphic card-based processing improvement in the program. Go to Edit>Preferences>Performance and uncheck the graphic processor option from there and relaunch the application. This will fix the problem with the heal brush as well.

Translate

Translate

Report

Report
Engaged ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

This isn’t a fix but if you need to get some files out, this worked for me so I hope it works for you too.

My Save As still works so here’s my workaround:

1. Save as 

-Format: PNG

-Save: As a copy (check)

[Save]
2. Import saved png file back into photoshop

*Export As functionality returns for png file*

3. Export As to export in different sizes. 

I hope this helps someone. 

Translate

Translate

Report

Report