Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


2 of 4 NTFS partitions available for scratch disk

Engaged ,
Dec 23, 2017 Dec 23, 2017

Copy link to clipboard

Copied

Do you know why it would be that I can only choose from 2 drive letters for scratch disk in Windows 10? If I press Ctrl+At during startup it lets me select from the other 2. But, once I open a project it tells my scratch disk is full and the other drives are not listed (all are NTFS partitions).

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Feb 25, 2018 Feb 25, 2018
It could be a permissions problem on your drives/partitions that is stopping Photoshop from recognizing it as a scratch disk.Second internal hard drive not visible as scratch disk option. Photoshop CC, OS XSee the procedure for Windows in message 13.

Likes

Translate

Translate
Adobe Community Professional ,
Dec 23, 2017 Dec 23, 2017

Copy link to clipboard

Copied

There are some help pages on 'Scratch disk is full' issue

Scratch disk full error in Photoshop

How to Fix Photoshop Scratch Disk Full Errors

I know that Photoshop has a habit of leaving orphaned temp files on your Scratch drive, and they can be substantial.

They look like this.  Any that don't have today's date on can be deleted.  They can easily get to tens of gigabytes and beyond.

I am sorry, but I don't know the physical requirements, but it might be worth checking Disk Management to see what the partition types are.  Look for the odd one out sort of thing.

We'd appreciate your feedback when you fix this so other folk can benefit down the road.

Good luck and have a great holiday.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

Start PS with no files or projects open. Go to Edit > Preferences > Scratch Disks and see what is listed. All internal drives and possibly some external drives, depending on the type of external drives, connected directly to your system should be listed.

You can select any from that list then use the arrows on the right to move them up or down. Select the one you want PS to use the most and click the arrow to move it to the top of the list. select the one you want to us as the second choice and move that just below the first.

Close the preferences dialog window and restart PS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

I guess my question is not direct enough. Do you know of a solution to there only being 2 of 4 drives listed as available to use as scratch disks? Note how the question remains after having selected a different scratch disk at startup by holding down Ctrl+Alt.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

cheyrn  wrote

I guess my question is not direct enough. Do you know of a solution to there only being 2 of 4 drives listed as available to use as scratch disks? Note how the question remains after having selected a different scratch disk at startup by holding down Ctrl+Alt.

Did you check the drives with Disk Manager?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 24, 2017 Dec 24, 2017

Copy link to clipboard

Copied

cheyrn  wrote

I guess my question is not direct enough. Do you know of a solution to there only being 2 of 4 drives listed as available to use as scratch disks? Note how the question remains after having selected a different scratch disk at startup by holding down Ctrl+Alt.

This is the dialog box I get with Ctrl + Alt.

Scratch Disk.PNG

This is what shows when I click any of the downward facing arrows.

Scratch Disk Drop Down.png

A full list of drives connected directly to my system.

The first 2 are the scratch disks I have selected in the program preference. Third and fourth show None because I haven't defined them in the preferences.

What do you see when doing that.

Please show a screen shot of the PS Preferences scratch Disk tab. Like this.

Scratch Disk Tab.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

The top is what I see when I start with Ctrl+Alt held down. It allows me to select from any of the 4 drives. Once photoshop is loaded, in preferences on 2 of the drives are available to select from:

scratch disks.png

A slight wrinkle to this is that at first I couldn't get into photoshop at all.I then made space on what I guessed were the drivesbeing used so that I could launch photoshop from there and then I would it would complain that the scratch disks are full.

At this point, I have made space so that it works, but I seem to be stuck with only being able to use those 2 drives.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

Are your F and G drives externals?

In the PS Preferences my T and U drives don't show and I think that is because they are external drive. Funny but the H drive does and that too is an external but it is a SSD external. The other 2 are normal rotating HDD.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 29, 2017 Dec 29, 2017

Copy link to clipboard

Copied

They are all partitions on internal drives. All 4 are primary partitions. The 2 that appear in preferences are on the disk that contains the boot partition. 😧 unfortunately, is the  system reserved drive that has a total of 100MB allocated. So, I really only have 1 drive available for scratch disk.

Disk manager says Healthy about all of the partitions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

Err. I don't know why an answer is marked correct. The problem is unresolved.

To quote my last post:

They are all partitions on internal drives. All 4 are primary partitions. The 2 that appear in preferences are on the disk that contains the boot partition. 😧 unfortunately, is the  system reserved drive that has a total of 100MB allocated. So, I really only have 1 drive available for scratch disk.

Disk manager says Healthy about all of the partitions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

What happens if you move E to the top of the list and don’t select D?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Tick the "active?" box. You have both disabled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Test Screen Name, the image in which  D and E are selected, is in your post. My screen shot is in the next message and there is no E to be moved anywhere.

D Fosse, the drives that I am saying are not available, are F and G. They don't appear in the list of scratch disks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Sorry, confused myself.

So, you say F and G *are* available if you select scratch disk during startup?

How much space is available on each of them?

Is there anything odd about the way either disk is setup?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

Yes, you can see F and G in the image that I posted. F currently only has 11 GB, but when I wrote the email it and G had more than 100GB each.

Also, in my posts it is mentioned that they are all primary partitions formatted as NTFS. F and G are on different drives than C and D. C is the boot partition and D is the system reserved partition that is 100 megabytes in size.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 25, 2018 Feb 25, 2018

Copy link to clipboard

Copied

It could be a permissions problem on your drives/partitions that is stopping Photoshop from recognizing it as a scratch disk.

Second internal hard drive not visible as scratch disk option. Photoshop CC, OS X

See the procedure for Windows in message 13.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

I think that you are right. But, I haven't figure out how to apply what you are suggesting.

Taking the suggestion of someone on the thread that you link to, I changed photoshop's executable to run as administrator, and with that change I have access to the other drives as scratch disks. So, I know you are right, but I don't know how yet. If I have time, I will figure it out and post details.

Thank you! If I were someone I would make your answer the correct answer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2018 Feb 26, 2018

Copy link to clipboard

Copied

LATEST

Well, you did credit my answer as "Helpful"and that's good enough. Anyway I'm happy that I can help someone out of a rut so that they can get their work done. I agree that an in-depth answer explaining how it works would be great, but that's not within my reach.

Running Photoshop as Administrator is a simple enough fix. Glad it worked.

Forum help is about basically getting a workable answer. I'm a Macbook owner and I don't have a full working knowledge of "permissions" in relation to Photoshop scratch disks under Windows, but I hope you can discuss that here or in the Microsoft forums to get the understanding you want.

Gene

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines