Action playback mode set to Accelerated, but play back Step By Step

Community Beginner ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

Starting a day ago, all my actions now play back in Step By Step mode even though the Playback Mode is set to Accelerated.  

 

How can I get my actions to return to playing back in Accelerated mode as they have been doing for years? 

 

RESOLUTION FAILURE: I quit Photoshop 2022, moved my "Adobe Photoshop 2022 Prefs.psp" file, restarted Photoshop 2022 but my Actions remained stuck in Step By Step playback mode.  (I've copied back my old "Adobe Photoshop 2022 Prefs.psp" after quitting Photoshop 2022.) 

TOPICS
Actions and scripting , macOS

Views

141

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Mar 23, 2022 Mar 23, 2022
Problem Resolved:  It turned out that when Actions' Show/Hide Dialog Box was set like this, it made the action run Step By Step.The Actions have returned to running in Accelerated Mode now that I've toggled Show/Hide to this:Thank you for your good attention to my problem!

Likes

Translate

Translate
Adobe Community Professional ,
Mar 22, 2022 Mar 22, 2022

Copy link to clipboard

Copied

@EricHeathJohnson 

This is more out of curiosity than anything, what happens if you use this script and change the referenced action/action set in lines 2 & 3?

 

acceleratedPlayback();
var actionName = "Molten Lead"; // Action to run
var actionSet = "Default Actions"; // Action set to run
app.doAction(actionName, actionSet);
function acceleratedPlayback() {
	var s2t = function (s) {
		return app.stringIDToTypeID(s);
	};
	var descriptor = new ActionDescriptor();
	var descriptor2 = new ActionDescriptor();
	var reference = new ActionReference();
	reference.putProperty( s2t( "property" ), s2t( "playbackOptions" ));
	reference.putEnumerated( s2t( "application" ), s2t( "ordinal" ), s2t( "targetEnum" ));
	descriptor.putReference( s2t( "null" ), reference );
	descriptor2.putEnumerated( s2t( "performance" ), s2t( "performance" ), s2t( "accelerated" ));
	descriptor.putObject( s2t( "to" ), s2t( "playbackOptions" ), descriptor2 );
	executeAction(s2t( "set" ), descriptor, DialogModes.NO);
}

 

https://prepression.blogspot.com/2017/11/downloading-and-installing-adobe-scripts.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

I cannot repro. Changing the setting in the actions panel, and restoring prefs, to set the playback options to accelerated. Do you by chance have have a step in the actions you're playing back that has Set Playback Options in it?

JeffreyTranberry_0-1648046242057.png

 


Senior Product Manager - Customer Advocacy - Digital Imaging

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Problem Resolved:  It turned out that when Actions' Show/Hide Dialog Box was set like this, it made the action run Step By Step.

Screen Shot 2022-03-23 at 10.41.22 AM.png

The Actions have returned to running in Accelerated Mode now that I've toggled Show/Hide to this:

Screen Shot 2022-03-23 at 10.42.11 AM.png

Thank you for your good attention to my problem!

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

In which Photoshop menu I can find item that produces Midtone Contrast in Action?

 

If I understand you it's still a bug, because this feature activates Step by Step mode?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

As seen above, the problem has been resolved by toggling the action's show/hide option.

 

The Midtone Contrast action was created by R. Mac Holbert, the father of fine art digital printing.  

 

https://www.youtube.com/watch?v=OvpDHkr9TuI

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Do you mean Midtone Contrast is produced by custom Action?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

Yes, the Midtone Contrast action does not come with Photoshop.  

 

You can create your own Midtone Contrast action using the steps that Andrew Rodney give here:

https://dgrin.com/discussion/comment/703882#Comment_703882

 

The effect can be increased by increasing the opacity of the Midtone Contrast layer created by the action.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

LATEST

He is Adobe Community Professional: thedigitaldog

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

If one did happen to need the modal toggle set to on, I would hope that adding a step afterward to set accelerated playback would overcome the issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines