• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Any way to disable double click to isolate layer?

New Here ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

Hi, I'm using the Direct Selection Tool a lot and often if I misclick a node and then follow up with another click it thinks I'm double clicking and turns on isolation mode. This is super annoying.

Is there any way to disable iolsation mode or at least the double click functionality?

Views

910

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 21, 2020 Jun 21, 2020

I tried that, and couldn't reproduce it. Did you reset your preferences? If you did, you might have to use the Creative cloud cleaner and reinstall PS.

Likes

Translate

Translate
Community Expert ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

I can't reproduce this. Have you tried resetting your preferences? What version of PS are you using?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

That feature doesn't seem to be in the new PS version. But if you have an older version, you should be able to turn in off in the general preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

I've updated to the latest version and the problem still exists. There is no option that I can find to disable it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

"it thinks I'm double clicking and turns on isolation mode"

 

Hi

How fast is your double-click speed, and what happens if you raise it? On a Mac, it's in Apple > System Preferences > Mouse. In Windows, I think it's in the Control panel. If it's set too low, then two single clicks is seen by the computer as a double-click.

jane-e_0-1592745180336.png

 

Also, I'm confused. Are you working in Photoshop or Illustrator? Photoshop does not have Isolation mode similar to Illustrator, afaik. I just tried double-clicking in PS with the Direct Selection tool and nothing happens.

 

~ Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

I'm using photoshop. My double click speed is the default and I don't really want to change that as it would affect other programs.

 

To reproduce this problem:

1. Create a few layers in photoshop (otherwise it's hard to see the effect if you only have one)

2. Use the pen tool to create a filled shape

3. Use the Direct Selection Tool to double click on the filled shape.

4. Observe the layer panel when you do: the little switch for isolation mode turns red and the other layers vanish.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 21, 2020 Jun 21, 2020

Copy link to clipboard

Copied

I tried that, and couldn't reproduce it. Did you reset your preferences? If you did, you might have to use the Creative cloud cleaner and reinstall PS.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 22, 2020 Jun 22, 2020

Copy link to clipboard

Copied

Oh wow resetting preferences did fix it. I have no idea how, I assume there's a setting in there somewhere.

Thanks for that

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

Can you please check your left top corner. There is a selection option.

There you can choose between "active layer" and "all layers". What is activated?

 

I often work with paths/outlines. So I create several "outline/path" layers. To manipulate the anchorpoints it's essential to use "direct selection" with "all layers" activated. By clicking and moving the paths the layer "isolation" switch activates. That's so annoying! 
The only solution is to change the selection to "active layer" but then the whole workflow is destroyed because then I only can select the active path layer and not the other ones.

I heard that it's possible to deactivate the isolation mode in Illustrator in your preferences. But there is no way to switch off that function Photoshop.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2022 Aug 13, 2022

Copy link to clipboard

Copied

Hello,

 

I just had this same issue and came here looking for an answer. 

 

Here is what worked for me:

 

In the Layers tab, there is a Magnifying Glass and drop down menu. My settings were set to Selected and I changed it to Kind - this fixed it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

YEESSS! That solved that annoying problem!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

LATEST

I don't know what happened but that solution doesn't work anymore!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines