• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
7

Black screen when editing text

New Here ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

I am running Photoshop 2022 on an M1 Max Macbook Pro (16", 2021). Photoshop is up to date as of 8/30/2022.

 

Whenever I go to type/change the text in a text box, the entire work area goes blank (everything inside and outside of canvas except for menus). I am able to enter and change the text successfully, but of course I can't see what I'm doing. It does not happen when I just select the text layer and change font, text size, edit layer styles, etc. This has only been an issue over the last week or few weeks at most - I think there was an auto-update in that time, but I'm not positive.

 

I have tried the Preferences > Performance > Graphics Processor Settings > uncheck Use Graphics Processor to no vail, and honestly, I don't think this would be a good long-term solution even if it did work given the processing capability of the M1 SoC that this would seemingly forego.

 

I'd appreciate any input on other workarounds. Otherwise, it seems like this is a bug that needs to be patched in a future update.

 

Thanks!

TOPICS
macOS

Views

3.6K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 31, 2022 Aug 31, 2022

Hi @defaultikvdcnsj3wj4 sorry to hear this.

 

Go to Preferences > Technology Previews... and check "Disable Native Canvas" - then restart Photoshop. Does the problem still occur? 

 

If not, iet's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder ba

...

Votes

Translate

Translate
Adobe
Adobe Employee ,
Aug 31, 2022 Aug 31, 2022

Copy link to clipboard

Copied

Hi @defaultikvdcnsj3wj4 sorry to hear this.

 

Go to Preferences > Technology Previews... and check "Disable Native Canvas" - then restart Photoshop. Does the problem still occur? 

 

If not, iet's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder back. 

 

 

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply.  

 

Thank you,

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2022 Oct 06, 2022

Copy link to clipboard

Copied

Thanks, work for me! 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

I had the exact same problem. I changed some options on preferences few weeks back and it started happening. 
so what i did to fix is ..
go to Preferences>Technology Previews

and UNCHECK both "Disable Native Canvas" and "Enable Native Canvas Rulers".

 

Let me know if it works for you! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 07, 2022 Sep 07, 2022

Copy link to clipboard

Copied

This worked, thanks! For me the setting was marked as PreferencesTechnology Previews Deactivate Native Canvas

 

So, similar but not exactly the same in case anyone else is confused by that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2022 Sep 08, 2022

Copy link to clipboard

Copied

Glad it helped 🙂

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 28, 2023 Apr 28, 2023

Copy link to clipboard

Copied

This happens about once a week, and there is no rhyme or reason to it.
I have a boss breathing down my neck and I can't even see the type I'm editing.

I am so sick of Adobe treating us like beta-testers. They keep rolling out random updates that are clearly not ready for primetime.

 

Adobe, at least be fair and pay us for our testing services.

 

- I have checked "Disable Native Canvas"

- More recently UNchecked "Deactivate Native Canvas"

- In desperation I have even trashed my preferences, as every brand new user thinks they're the first to suggest, followed by a half-hour of resetting key commands

 

Then suddenly I can edit type again without the image going black.

Then suddenly a couple days later, it goes black again.

 

Oh well, at least 2 things are certain:

1. fresh-faced users will always eagerly suggest we trash our preferences

2. angry Galadriel will always glare at us meaningfully because we're not doing enough for the planet

 

Seriously Adobe... fix your issues.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 02, 2023 May 02, 2023

Copy link to clipboard

Copied

LATEST

@Robert2807422137rd I'm no fresh-faced user, I've used PS since V5, but, anyway, I'll describe a process that may help, so many folk only partially reset the preferences - thus the process often seems ineffective

Perhaps try a thorough reset of Photoshop preferences? 

(read this entire post before acting please)

Resetting restores Photoshop's internal preferences, which are saved when Photoshop closes. 

If they become corrupt then various issues can occur.

 

Here’s some info on how to do that:

https://helpx.adobe.com/photoshop/using/preferences.html

Manually removing preferences files is the most complete method for restoring Photoshop to its default state: 

https://helpx.adobe.com/photoshop/using/preferences.html#Manually

 

Manually removing preferences files is the most complete method for restoring Photoshop to its default state. This method ensures all preferences and any user presets which may be causing a problem are not loaded.

  1. Quit Photoshop.

  2. Navigate to Photoshop's Preferences folder.
    macOS: Users/[user name]/Library/Preferences/Adobe Photoshop [version] Settings
    Windows: Users/[user name]/AppData/Roaming/Adobe/Adobe Photoshop [version]/Adobe Photoshop [version] Settings

     
    Note: The user Library folder is hidden by default on macOS. To access files in the hidden user Library folder, see How to access hidden user library files.
  3. Drag the entire Adobe Photoshop [Version] Settings folder to the desktop or somewhere safe for a back-up of your settings

  4. Open Photoshop.

     New preferences files will be created in their original location.

 

 

Note re macOS: The user Library folder is hidden by default.

To access files in the hidden user Library folder, see here for how to access hidden user library files. 

https://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html

 

Unexpected behaviour may indicate damaged preferences. Restoring preferences to their default settings is a good idea when trying to troubleshoot unexpected behaviours in Photoshop. check out the video

https://helpx.adobe.com/photoshop/using/preferences.html#reset_preferences

 

Learn how to access and modify Photoshop preferences and customise per your frequent workflows

https://helpx.adobe.com/photoshop/using/preferences.html

 

And here’s an earlier forum discussion as an aid to understanding

https://community.adobe.com/t5/photoshop-ecosystem-discussions/quick-tips-how-to-reset-photoshop-pre...

 

You may want to backup your settings and custom presets, brushes & actions before restoring Photoshop's preferences.

Here is general info about that:  https://helpx.adobe.com/photoshop/using/preferences.html#BackupPhotoshoppreferences

 

 

Before you reset your preferences

in case of future issues, I suggest you make a copy as Adobe may need one to check problematic references. 

Quit Photoshop.
Go to Photoshop's Preferences folder

Preferences file locations: https://helpx.adobe.com/photoshop/kb/preference-file-names-locations-photoshop.html\


  [on MacOS see: Users/[user name]/Library/Preferences/Adobe Photoshop [version] Settings

  Note for those on macOS: - be aware that the user Library folder is hidden by default on macOS. 

  https://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html

  In the Finder, open the “Go” menu whilst holding down the Option (Alt) key. 

  Library will now appear in the list - below the current user's “home” directory. ]

 

Now you can drag the entire Adobe Photoshop [Version] Settings folder to the desktop or somewhere safe as a back-up of your settings.

 

 

Note for those on macOS:

Preference preservation is affected by macOS permissions, 

you’ll need to allow Photoshop ‘Full Disk Access’ in your Mac OS Preferences/Security and Privacy

 

If that doesn't fix the issue:

Go to Preferences > Performance... and uncheck Multithreaded Compositing - and restart Photoshop.

Still hanging? 

Go to Preferences > Performance... click Advanced Settings... and uncheck "GPU Compositing" - then restart Photoshop. 

Still got problems?

 

 

 

It may even be time to reinstall Photoshop. 

 

It’s recommended that you use the Adobe CC cleaner tool to remove all traces first. 

(See above about preserving preferences though! It’s worth preserving them unless they are corrupted.)

 

https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html

Uninstall Photoshop BUT make sure to choose the option “Yes, remove app preference”.

 

Once that process finishes, start the installation process and look into the “Advanced Options”. Uncheck “Import previous settings and preferences” and choose to “Remove old versions”.

 

I hope this helps

neil barstow, colourmanagement net :: adobe forum volunteer

google me "neil barstow colourmanagement" for lots of free articles on colour management

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines