Brush/Erase tools are without colour when using 'Alt+right-click' then drag to vary size/hardness

Explorer ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

I use 'Alt + right-click' then drag to vary the size and/or hardness of the Brush and Erase tools—a lot. Typically, when using this feature, the round cursor instantly turns a (transparent) shade of red. However, since yesterday I notice that it has no colour. I inspected settings and preferences, and looked around here in the ASCommunity, but found no fix that would return the colour. I even changed myself (to purple) to see if that would clear the hiccup. Nothing, still no colour. I want colour. Red or purple. I'll take blue.
The following pics illustrate the issue:
Upon engaging 'Alt+right-click', the Brush (or Erase) tool's cursor temporarily changes colour (to one set by the user in Preferences > Cursors).

1.
The 'Alt+right-click then drag' allows to increase/decrease the size of the cursor and/or the hardness of the tool, either Brush or Erase. Been doing it since forever.
brush-erase_cursor-altrightclick_20220822.jpg

2. This is what's happening now... no colour. The function works properly but there is no colour.

brush-erase_cursor-altrightclick_20220822_2.jpg

My settings:
Also, I notice there is no difference between 'Normal Brush Tip' and 'Full Size Brush Tip' a sindicated by the settings window... they both appear exactly when in actaul use.

pscc-cursor-settings_2022-8-22.jpg

Is is possible that there is a ridiculously simple solution to this mystery, that I am overlooking because I'm overthinking this situation?
Enlighten me, please, ... cheers, thanks.

 

 

TOPICS
Windows

Views

33

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

Check Preferences > Performance and see if Use Graphics Proicessor is enabled.  If it is, open Advanced settings and make sure Open CL is checked.  If either option is greyeed out, then you need to look at your video card driver.

 

If you are using a laptop that has two GPUs, then you need to be using the Nvidia/AMD GPU, and not the onboard Intel GPU. 

image.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

Hello, Trevor;

Thanks for writing. I'm on PC & W10. I followed your steps but they do not work. I've checked/unchecked all possible combinations yet none provide resolution. Also reset preferences to default, and nothing... the problem still persists as of this writing.
And even tho' PsCC says GPU compatibility is ✔ ✔ ✔ ✔ (see attached screenshot), I am of the opinion that the problem lies withing the graphics card. I spoke with a friend who also has PsCC and compared our settings—both are the basically same yet he is not experiencing the issues I am. 

 

 

gpu-compatibilty-pscc-20220822.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

What do you see in Preferences > Performance?

Does it show your GTX 770?  I don't think you have told us whether you are using a laptop or desktop system.  If the latter then it can only be your GTX 770.  If laptop, it might show an Intel GPU.

image.png

This link shows which functions use the GPU.  Test them to see if they are working.  If you change the GPU settings, do you know that you have to restart Photoshop for the changes to work?

https://helpx.adobe.com/nz/photoshop/kb/photoshop-cc-gpu-card-faq.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

LATEST
Yes, I did mention that I'm on PC & W10 in my first reply. I (incorrectly?) assume that PC is a desktop. I always close/start PsCC after changes to any settings. FWIW, below is a screenshot of GPU settings.
 
gpu.jpg

Some of the features in the link you provided, that require GPU card, do not work (birds eye view; scrubby zoom, for example), even tho' I have GPU card enbled.

P.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines