Brush (Healing Tools) Lagging After Update?

Explorer ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Is anyone else experiencing brush lags in Ps after the update? Most specifically when using a tablet? I'm using the XP-Pen Star 05 but the tablet isn't the problem here, as it work everywhere and on everything else.

Views

4.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Hi JuanNavedo,

We're sorry to hear about the brush is lagging after update, could you please try deselecting "Use Graphics Processor" located in Photoshop's Preferences > Performance, then relaunch Photoshop and let us know if it helps?

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

This did not work. I can not use my tablet. The mouse works fine but I can not work with a mouse after I've found how much more speedy and efficient it is to work with a tablet. Theres got to be a solution for this as I have a lot of retouching projects to do this week. Had I known this, I would not have updated.

And I really hope this isn't due to support for my graphics card has ceased. I have the NVIDIA GeForce GTX 980 4GB graphics card.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Hi Juan,

Select the Brush tool and turn smoothing off (should be set @ 10% by default) in the tool options bar. Then quit and restart PS. Is the healing brush still lagging?

Also, your video card should work just fine with this (and previous versions) of Photoshop.

Thanks,

Adam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

That did not work either.

However, I have noticed that it only happens when I'm really zoomed in, as that's how I work when retouching. I tried zooming out just to see if it happens and it works just fine. Hopefully this revelation will lead to the solution because for retouching you HAVE to be zoomed in.

UPDATE: Experimenting further, it looks like the healing brush tool returns to normal at 50% zoomed out and below. It messes up at zoom levels above 50%.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Are there any other settings I can play with that might fix this issue of lagging Healing Brush tools at over 50% zoom?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Try playing with the Cache levels in performance preference settings. What are they set to now?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

SOLVED THE PROBLEM

It looks like Adobe, if I'm not mistaken, added a new option in the 2019 version and by default, it's on. What worked for me is turning off "Enable Preserve Details 2.0 Upscale" under the Technology Preview preference.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

Hi Juan,  Are you on Windows or Mac?  Also, can you tell me how big your file is (dimension and dpi) and how many layers you have?

Thanks!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 16, 2018 Oct 16, 2018

Copy link to clipboard

Copied

I solved the problem and it looks like it was a new setting in preferences; "Enabled Preserve Details 2.0 Upscale". I just shut that off and restarted. It solved the problem and now I can use healing tools at any zoom level.

However, if its a fluke, I have a Mac. The photo is 5304x6330, at 300 dpi.

But like I said, all is well now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 17, 2018 Oct 17, 2018

Copy link to clipboard

Copied

Thanks for the details.  I have a hunch it was the restart that cleared something that was off rather than the Preserve Details 2.0 pref because that only affects Image Resize and Transform.  It's a new interpolation method that was introduced in Photoshop CC 2017 released at MAX last year.  There are some known issues where zoom level can affect painting performance under some circumstances.  Regardless, I am glad all is working well for you now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

the same with me, though turning off Preserve Details doesn't work for me. Healing brush is lagging and it's very annoying and it doesn't give me an opportunity to work (I'm a retoucher and it's one of the most frequently used tools in my routines)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

by the way stamp and smudge tools are lagging too. Is there any way to solve this problem? I can't work!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Hi Tasha, What OS and hardware you're using? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Hi Chad!
It's Win10, core i7-8700, 64 RAM, NVIDIA GeForce GTX 1050Ti
Cache levels are at 8

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Thank you!  Can you also tell me what type(s) of files you are seeing this with?  I'm trying to reproduce the problem so an engineer can look at it.  What are the file dimensions, resolution, number and type of layers, bit depth (8, 16, or 32), what color mode/space?  If it's easier, you can just post a screenshot of your layers panel for the layer number & type question. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

it's about 20-25 layers
16bit, photograph with adjustment layers, one smart object, 5792*8688 px, 300 dpi, sRGB IEC61966-2.1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Also, are you using a Wacom or other tablet in conjunction with your Win10 machine?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

yep, I'm using wacom intuos pro

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Thank you.  This is great.  I can repro. Can you confirm that this only happens when you use the pen/wacom?  I'm not seeing it with normal mouse/trackpad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Sorry, I don't have trackpad or mouse on my system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Ok.  It also looks like zoom level affects how this bug reproduces.  If I'm zoomed to 100% or Fit (Ctrl+0) or different zoom levels does the lag go away?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

It seems like it starts working a bit faster, not as fast as usual.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Thank you very much for your help.  Now that we can repro the problem, a dev is looking into this!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 18, 2018 Oct 18, 2018

Copy link to clipboard

Copied

Yeah I spoke too soon. The problem is back. Its NOT the "Enabled Preserve Details 2.0 Upscale" option. I'm out of ideas. And yes, I too am using a tablet and from what I'm reading, it ONLY affects tablet users.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines