Can't find the version of photoshop I need

New Here ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

I need to be on photoshop 22.5.5, and I don't see that in this computers creative cloud. The versions available go from 22.4.2 to 23.0. Also my wacome tablet stopped working today and I have a feeling I need the proper version for my job to get that to work again. I have a mac pro on catalina and I'm using a wacom intous pro small. My tablet worked for a week, but I had to restart photoshop a bunch this morning to get it to use the proper tools, and thats no longer working. I am not able to update to version 23 with my job because of bugs. 

TOPICS
macOS

Views

58

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 04, 2022 Apr 04, 2022

Copy link to clipboard

Copied

It seems you have 22.4.2 installed on your machine. Have you tried to update installed version and get where you want to be?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 05, 2022 Apr 05, 2022

Copy link to clipboard

Copied

Scroll down in the CC app. It's there. Version 22 goes up to 22.5.6.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 05, 2022 Apr 05, 2022

Copy link to clipboard

Copied

LATEST

First make sure your CC Desktop app is up to date. Then you should see it in "other versions"

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines