• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Can't zoom in/out by dragging and can't rotate canvas in Photoshop CC 2018.

New Here ,
Jun 12, 2018 Jun 12, 2018

Copy link to clipboard

Copied

I took a break from using photoshop for a week, and I never shut down my Mac during this week, but when I started using my photoshop today I noticed I can't zoom in and out by pressing Z and drag to the right and left. It forces me to have that rectangular selection and enlarges that area, which I don't usually use. And I noticed another problem when I tried to rotate the canvas. It says "Could not complete your request because it only works with OpenGL enabled document windows."I'm not sure what does that mean cus I literally did nothing to my photoshop and my Mac this week. So I thought if I restart my Mac and everything will come back to normal, but it didn't. Please help

Views

38.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Jun 12, 2018 Jun 12, 2018

First, Make sure your graphic driver is on the most recent update,

From  Preferences menu (cmd+ K) -> Preferences

make sure Use graphic Processor is turned on

if that did not work, Reset the Preferences:

Preferences menu (cmd+ K) -> general

click on Reset preferences on quit, then  restart photoshop

let us know if that helps

Votes

Translate

Translate
Adobe
Community Expert ,
Jun 12, 2018 Jun 12, 2018

Copy link to clipboard

Copied

Those features need graphics acceleration to be turned on in Preferences > Performance.  It could be that a driver update has caused Photoshop to disable it.  If it is grey out, check for video card updates.  If it is not grey out, check it and all should be well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 12, 2018 Jun 12, 2018

Copy link to clipboard

Copied

First, Make sure your graphic driver is on the most recent update,

From  Preferences menu (cmd+ K) -> Preferences

make sure Use graphic Processor is turned on

if that did not work, Reset the Preferences:

Preferences menu (cmd+ K) -> general

click on Reset preferences on quit, then  restart photoshop

let us know if that helps

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Thanks a lot. I "reset preferences" and restart photoshop again, and it works again.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2024 Jan 10, 2024

Copy link to clipboard

Copied

Mine is the most up-to-date version of photoshop and I am having the same problem, I want to be able to use the zoom tool (pressing z on my keyboard for the magnifying glass icon to appear) then dragging the icon left or right on the screen. This is how I've always done it. I've 'ticked box' and 'unticked box' all the options provided and it still wants to scroll across teh screen. I've checked the Graphic Driver and restarted pshop. Still can't get it working. Any ideas??

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 10, 2024 Jan 10, 2024

Copy link to clipboard

Copied

LATEST

I have found it. When selecting the zoom tool, bottom left, another tool bar appears along the top and the 'scrubby' option needs to be unchecked. This option does not appear in the Preferences menu.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines