• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Color Efex Pro4 changes are not saving in PS

New Here ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Hello.  After I select a filter in Color Efex Pro4 and save it, my changes are not saving on my PS layer.  Any recommendations.  I have shut down PS and tried it again with no change.  I did have luck shutting it down and retrying it yesterday.

The DXO Nik collection all show up under filters, they open the image fine, allow me to make changes, but just dont show up on my layer when I hit OK.

TOPICS
Windows

Views

1.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Feb 18, 2022 Feb 18, 2022

I found a very easy work around. Launch ColorEfex Pro via PS and make edits as you normally would. When you return to PS, the changes are not showing as noted here. Now, simply go to the top menu bar and click FILTER and the first option will be COLOR EFEX PRO. Click on that and it applies the changes made in CEP. 

Likes

Translate

Translate
Community Expert ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Please let us know what version of Photoshop and DXO Nik collection you use.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2021 Jan 17, 2021

Copy link to clipboard

Copied

Hi.  I'm having the same problem.  I start in Photoshop, make changes with Color Efex Pro 4, but when I hit apply, I just get a new TIFF saved to Lightroom, without any of the actual changes.  No new layer in PS, just a new TIFF in Lightroom.  And if I go from Lightroom to CEP4 directly and make changes, the same thing happens -- a TIFF is created but no edits are applied.

Photoshop version is 22.1.1

Lightroom is 10.1.1

DxO ColorEfex Pro 4 says it's version  5.0.3.101 x64 (v3.3.0)

 

Thank you for your help.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2022 Feb 18, 2022

Copy link to clipboard

Copied

I found a very easy work around. Launch ColorEfex Pro via PS and make edits as you normally would. When you return to PS, the changes are not showing as noted here. Now, simply go to the top menu bar and click FILTER and the first option will be COLOR EFEX PRO. Click on that and it applies the changes made in CEP. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

I looked everywhere for a possible solution top this and your suggestion worked perfectly. I'm using the Nik Collection 5, specifically Color Efex Pro 5, and Photoshop Elements 2023. I can now use layers to adjust the filters again. Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

Glad it worked for you! 👍

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

I also use DXO HDR Efex Pro 2 and have an intermitted problem where the photo being edited developes graphic errors (square blocks appear within the photo). The above mentioned technique that works for Color Efex Pro also works.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

I don't have problems like this. Couldn't that be a graphics card issue?

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

LATEST

I initially thought so but when I upgraded to a new MacBook Pro from an older one it continued. It seems more like the software isn't working properly with the operating system. It also doesn't happen in any other program. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines