Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Color Overlay Not Working

Community Beginner ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Hi everyone,

I have followed the steps for adding an overlay color to my layer and none of the colors are working.  Here are my steps:

Select Layer > Fx > Color Overlay > Choose color e79d46 > Ok

I get no color change at all - just a white page. I have even tried opening a new document and immediately trying to add a color overlay and it still isn't working. Any suggestions?

Views

36.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Sep 05, 2017 Sep 05, 2017
HiWhen you use Shift -F5 you should get a dialogue on how to fill. Choose a solid colour (e.g. foreground color) not Content AwareDave

Likes

Translate

Translate
Adobe Community Professional ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Can you show a screenshot of your layers panel (with the layer you are adding the color overlay to selected)  and your layer style color overlay settings (as below)

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Overlay Attempt.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Hi

Your layer is empty. Fill it with pixels (any colour it doesn't matter) and the overlay will work

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Thanks Dave!

Is this where I add pixels?  If so, it isn't taking any of the numbers I put in. I have tried to make it the same size as the artboard 1366 x 768 pxl but each time, it will not save.  Very new to this and just trying to figure out what is creating the issue.

Pixel layer.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

No just select the layer in the layers panel  then Ctrl+A (Cmd+A on Mac) to select all, then Shift+F5 to fill.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Hi Dave,

Here is what I got when following your above instructions - something is not right here. Is this something I have to do each time I open a new template?

Fill Attempt.JPG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

Hi

When you use Shift -F5 you should get a dialogue on how to fill. Choose a solid colour (e.g. foreground color) not Content Aware

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

THANK YOU!  Lots of tips in just one question. Thanks for your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 05, 2017 Sep 05, 2017

Copy link to clipboard

Copied

You're very welcome

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

thank you so much for this good man 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2017 Dec 09, 2017

Copy link to clipboard

Copied

Hi Dave

I have a similar problem with colour overlay all of a sudden, and cannot work out what I might have done for this to happen.

I want to change a duplicate of a layer from grey to red, but the duplicate layer remains grey. I have never had this happen before, and it's a tool I use regularly.

I don't know if it's relevant, but I was trying to understand out how to use the rectangle tool earlier in the day, and how to stroke dashed lines without success, and I am now wondering if I have accidentally reconfigured a tool preset which is preventing the colour overlay from functioning.

Do you have any suggestions ?

Jeremy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 09, 2017 Dec 09, 2017

Copy link to clipboard

Copied

Hi

Can you show a screenshot with both your layers panel (with the layer selected) and the layer effects dialogue visible showing the color overlay settings

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Hi Dave, can you help me with a similar problem as well?

When I right-click my .png icon and add a colour overlay, it doesn't change colours (screen shots 1 and 2).

When I mask the layer and fill it as an alternative solution, it turns the icon grey versus the colour I've chosen (screen shots 3 and 4).

I've toggled the white and black foreground/background and it makes no difference.

1.PNG

2.PNG

3.PNG

4.PNGColor Overlay Not Working

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Hi

I can see in the color overlay dialogue the blending mode of the overlay is set to color. Set like that it will not change anything that is pure black or pure white. Change the blending mode to normal and you should be OK

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Thank you!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

You're welcome

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2020 Dec 05, 2020

Copy link to clipboard

Copied

I have the same problem, Color Overlay doesnt work too.

I follow the steps here but it doesnt work

pls help me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Same here and it seemed to have happened during the last upgrade.  I try to color pick in my image and the color will NOT change at all! I'm frustrated as all get out!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2018 Feb 22, 2018

Copy link to clipboard

Copied

Hi Everyone,   I'm am trying to add an overlay to a photo in Photoshop, but it turns into mosaic pixels once I transfer it in to PS.  Here is a snapshot of what I mean.   Can anyone provide guidance or tips on how to fix this?  The overlay is in my downloads as bokeh stars.

Screen Shot 2018-02-19 at 8.59.25 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2018 Feb 22, 2018

Copy link to clipboard

Copied

Hi

It looks like you are trying to embed a png file. There is a bug affecting that process on the Mac that Adobe developers have acknowledged.

In the meantime, as a temporary measure, go to Preferences > Plug Ins and uncheck "Allow extensions to Connect to the Internet" and "Load Extension Panels". That should get you working.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2018 Feb 22, 2018

Copy link to clipboard

Copied

Thank you!  That worked!  It didn't work when I unchecked both but it did when I only unchecked 'Allow extensions to Connect to the Internet'.   Really appreciate your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 22, 2018 Feb 22, 2018

Copy link to clipboard

Copied

You're welcome, and thanks for the feedback on what worked for you

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2020 May 10, 2020

Copy link to clipboard

Copied

Hi! Here's my screenshot, I've noticed that the color is not matching the chosen one, could you help?Снимок экрана 2020-05-10 в 14.15.45.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2019 May 06, 2019

Copy link to clipboard

Copied

The same problem is happening to me and I have made sure that all my setting are correct

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2