• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Colour Space Issue between Lightroom Classic and Photoshop

New Here ,
Oct 14, 2022 Oct 14, 2022

Copy link to clipboard

Copied

I have a color issue when saving my Photoshop files and going back to Lightroom Classic. My workflow is basic editing in LrC, any more detailed editing in PS by using the LrC Edit In PS function. After I have made my edits in PS and then Save / Close, when I go back to LrC the new PSD image has a green tint throughout it. This didn't happen before and I think started happening since an upgrade to PS or LrC. Looking at my Color Space in LrC Prefences / External Editing the Color Space is set to ProPhoto RGB 16bit ,which I prefer as it clearly has the most amount of data. I think that PS uses sRGB when saving which may be causing the issue?? but as I said it wasn't happening before when using this Color Space. I know I could prevent this my changing the LrC Prefences / External Editing / Color Space set to sRGB but I would prefer to keep ProPhoto RGB if possible. Any support would be most welcome.

TOPICS
Cross-app workflows , macOS

Views

77

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Oct 15, 2022 Oct 15, 2022

This is a bug corrupting Photoshop preferences, preventing Photoshop from embedding the color profile correctly. The files are untagged, and untagged files are treated as sRGB by default in Lightroom.

 

The fix is to reset Photoshop preferences. You'll also need to re-assign the color profile for the affected files.

 

I've never seen this myself, but it's been reported from time to time over the last months. My personal suspicion is that this can happen if you migrate preferences from an earlier

...

Likes

Translate

Translate
Community Expert ,
Oct 14, 2022 Oct 14, 2022

Copy link to clipboard

Copied

"I think that PS uses sRGB when saving which may be causing the issue??"

Are you saving using Save command? So Photoshop is silently converting to sRGB? To my mind comes to check Edit > Color Settings. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 14, 2022 Oct 14, 2022

Copy link to clipboard

Copied

Yes when in PS and I have completed editing I seleect CMD+S (save) and CMD+W (close). As I said I have done this before with no issue and only becoming an issue recently (maybe during an update)

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 15, 2022 Oct 15, 2022

Copy link to clipboard

Copied

This is a bug corrupting Photoshop preferences, preventing Photoshop from embedding the color profile correctly. The files are untagged, and untagged files are treated as sRGB by default in Lightroom.

 

The fix is to reset Photoshop preferences. You'll also need to re-assign the color profile for the affected files.

 

I've never seen this myself, but it's been reported from time to time over the last months. My personal suspicion is that this can happen if you migrate preferences from an earlier version, instead of rebuilding them from scratch. But that's just a theory.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 15, 2022 Oct 15, 2022

Copy link to clipboard

Copied

LATEST

Thank you, resetting Photoshop preferences fixed this issue. Appreciate your expert support.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 15, 2022 Oct 15, 2022

Copy link to clipboard

Copied

Be sure you are on the latest versions of PS and LR to avoid a bug in the last where the round trip stripped the profile from what came into Photoshop from Lightroom Classic. The newer builds should fix this issue. 

All the images you processed in the buggy version will be untagged, so simply use the Assign Profile command and select the profile you originally asked for (ProPhoto RGB). 

IF you still have issues and are on the latest version that did fix this round trip bug, and you see that the Photoshop images are indeed tagged, try disabling GPU in preferences as that might be an issue. 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines