• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
8

Dark Photoshop 32-bit images when "Use graphics processor" enabled

Community Beginner ,
Feb 01, 2024 Feb 01, 2024

Copy link to clipboard

Copied

I was trying to do some quick 32-bit compositing in photoshop (I usually work in 16 bit) and was noticing that any image (either opening an exr, starting a new 32bit image, or converting to 32bit) resulted in a darker image than should be expected. Only photoshop seems to exhibit this problem since if I opened the exr in other programs (after effects, irfanview, etc) it looked fine and also match the rendered image from 3ds max. I updated the GPU driver (clean install of 551.23) on the RTX3070 and restarted the machine, all with no change. I was eventually able to narrow it down to the "Use graphics processor" setting in the Photoshop-->Performance setting (the "advanced Settings" options don't seem make a difference). Turning this off let's opened and new 32bit files behave properly. Weirdly it's effect is only seen when the file is opened or created. If I turn the setting off and open the exr the file is fine and I can continue working with it but if I then reopen that file or create a new one the it's messed up. Below is an example. I turned off the setting, opened the exr and duplicated it on the right (the 'copy' one). I then closed the original exr, turned "on" the setting and reopened the exr which resulted in the darker image on the left (mainly some crushed shadows). I then added a gradient ramp at the top just to see what's happening and you can see how the gradient is no longer smooth, especially at the darker end where there is a noticeable 'hump' as it turns to black. See the attached screenshot for an example.


Even without restarting photoshop it's obvious that the "use graphics processor" is a enabled on the left image as guides, paths, and eyedropper targets are all nicely smoothed, and simultaneously it's disabled on the right since all of these are jagged. I'm sure this accounts for why the right image is still displays correctly. Even pasting the entire left image into the right one let's the image correct itself and they match perfectly (the pixel values are all the same).

So.... does this happen to anyone else? I don't recall this behavior before but I can't seem to find out if anyone is having a similar experience via a google search.  BTW, this is on Windows 10, Photoshop 25.4.  I can't figure out if it's something with my machine, the gpu, the driver or photoshop. Is there some setting somewhere that I'm missing or accidentally ticked?

TOPICS
Windows

Views

180

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Community Beginner ,
Feb 01, 2024 Feb 01, 2024

Copy link to clipboard

Copied

Just in case it's somethign specific with my exr (I've tried it with a few images), here is a link to the exr I used in the test images above: https://drive.google.com/file/d/1OuIP45EUd7qX0_6kB5hla_hNmflru_Jr/view?usp=sharing

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2024 Feb 05, 2024

Copy link to clipboard

Copied

So I think I figured out generally what's causing this but I'm not sure on the exact cause or fix. After a long process trying to determine what might be the problem I eventually was able to determine it’s somehow related to the color profiles created and installed from DisplayCAL.

 

I’ve calibrated my 2 Dell U2415 monitors with a Spyder 5 for many years using DisplayCAL and been very happy with it (6500k, 120  luminance). Just to make sure it wasn't just an old profile I also created a new one but it also exhibited the same issues. I also tried viewing 32 bit images on several other systems, even an i5 laptop with Iris integrated graphics, and they all exhibited the problem when "use grphics processor" is chcecked so I don’t think it’s hardware related. I did have DisplayCAL running on all of them though. Resetting the video card gamma table in DisplayCALdidn’t change the difference between the “use graphics processor” images (although they did of course look different than the normal correct gamma table ones).  I eventually was able to determine that it was related to displayCAL only after trying a clean install on a new/clean system.  Everything looked  fine but once I installed a profile the issue popped back up. Removing the profile reset everything back to normal.  I then went and calibrated just using the Spyder 5 Express software and those somewhatlimited profiles are working fine (for now).

 

So…. what could be the cause of this? Is it a problem with DisplayCAL, the sensor (the Spyder Express profile works fine though), Argyll, the icm profile, or something else?  I've posted this to the DisplayCAL forum but it's "awaiting moderation" and it seems like those can linger for a while before actually being posted. 

 

It just seems so odd that this only shows up whenever “use graphics processor” is enabled and only in Photoshop.  Any help is appreciated.  Is there any more info I can provide that might help figure this out?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 11, 2024 Feb 11, 2024

Copy link to clipboard

Copied

The problem seems to be rectified by using the "curves+matrix" profile type in DisplayCAL instead of the default "XYZ LUT+matrix" as described in the DisplayCAL forum here: https://hub.displaycal.net/forums/topic/awaiting-moderation-2/#post-140591.  I'm still not sure if it's a problem with PS or DisplayCAL or Argyll but everything is working fine with a decent enough calibration.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 11, 2024 Feb 11, 2024

Copy link to clipboard

Copied

Yes, matrix profles are much safer than LUT profiles which are bigger and more complex. Depending on what software made them, LUT profiles are much more likely to cause problems. I've tried LUT profiles from Eizo ColorNavigator, and while Photoshop and Lightroom handle them well, Firefox doesn't like them. Just as an example.

 

As a general precaution, I always stick to matrix profiles.

 

In the same way, version 4 profiles are more risky than version 2 profiles.

 

I tried DisplayCAL once many years ago, and I'm a bit wary of that software. It seems to make things unnecessarily complex. For instance, there was a default option to use a very high number of color patches. The only thing that happens then, is that all the micro-corrections introduce artifacts with twists and turns in the final curve. It's better to have fewer patches and a smoother curve.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 29, 2024 Feb 29, 2024

Copy link to clipboard

Copied

LATEST

Thank you.  Sorry for the late reply as I haven't checked this since switching the profile type.  I've since switched over both monitor profiles to matrix and am good with that.  Again, I don't need it perfect just relatively accurate and smooth, so matrix it is. Thanks again. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines