Downloading CS5 error

New Here ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

I am trying to download photoshop CS5. The link from inside my account is giving me an error message when I try to install it. The message reads as follows:
“Install” needs to be updated. The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.
 
I am currently unable to download my CS5 software on my new MAC computer. When I tried contacting customer support I was told they were unable to assist and to post in this community. I am vert upset I have not been able to use my product. 
 
Can someone please help?
TOPICS
macOS

Views

71

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Apr 15, 2022 Apr 15, 2022
@alexb2409741 wrote:   "The developer of this app needs to update it to work with this version of macOS." "I am currently unable to download my CS5 software on my new MAC computer."
You didn't say if you have an M1 Mac or which macOS, but Apple made changes to the OS and CS5 (released in 2010) will not run in Catalina or higher. You can run CS5 on an older Mac with an older macOS that supports it or you can use software that will run on your new Mac and macOS. Here are the cu...

Likes

Translate

Translate
Adobe Community Professional , Apr 15, 2022 Apr 15, 2022
@alexb2409741 wrote:   I am currently unable to download my CS5 software on my new MAC computer.
No new Mac can run Photoshop CS5. In the twelve years since Photoshop CS5 was released, Apple has made major changes to macOS that have required significant updates to applications for them to keep running.
@alexb2409741 wrote: “Install” needs to be updated. The developer of this app needs to update it to work with this version of macOS.
Yes, Adobe did the necessary up...

Likes

Translate

Translate
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied


@alexb2409741 wrote:
 
"The developer of this app needs to update it to work with this version of macOS."
"I am currently unable to download my CS5 software on my new MAC computer."

 

You didn't say if you have an M1 Mac or which macOS, but Apple made changes to the OS and CS5 (released in 2010) will not run in Catalina or higher.

 

You can run CS5 on an older Mac with an older macOS that supports it or you can use software that will run on your new Mac and macOS. Here are the current plans: https://www.adobe.com/creativecloud/plans.html

 

Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 15, 2022 Apr 15, 2022

Copy link to clipboard

Copied

LATEST

@alexb2409741 wrote:
 
I am currently unable to download my CS5 software on my new MAC computer.

 

No new Mac can run Photoshop CS5. In the twelve years since Photoshop CS5 was released, Apple has made major changes to macOS that have required significant updates to applications for them to keep running.

 

@alexb2409741 wrote:
“Install” needs to be updated. The developer of this app needs to update it to work with this version of macOS.

 

Yes, Adobe did the necessary updates to get Photoshop to run on all new Macs, but that happened long, long after Photoshop CS5 (version 12). Photoshop CS5 stopped working on macOS 10.15 (about three years ago) and later. If you use the either of the two most recent versions of Photoshop (version 22 and 23), those are built to run on the latest Macs with Apple Silicon processors.

 

The changes Apple made to macOS, which they had to do to pave the way for today’s fast, efficient Apple Silicon Macs, are so extensive that many other applications from the same era as Photoshop CS5, even some from Apple, cannot run on a new Mac.

 

To get the most out of the newest Macs, you must get current versions of all your software, from any company.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines