Entire Photoshop screen turns neon green

Community Beginner ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

Not sure what is happening but lately my photoshop window screen, which shows my artwork is now neon green.  I cannot see my art and it vibrates also. I don't know if it has something to do when I disconnect from my large monitor or something else. I have upgraded my mac system to Big Sur 11.4.  The only way I can get it to work properly is to delete photoshop from my computer and reinstall it again from Adobe again. I have to click off any saved libraries etc, and start all over again. Has anyone had this issue or know how to fix it? It's happened a few times and I'm wondering if there is a conflict somewhere.

 

Please help!

Views

2.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 03, 2021 Jul 03, 2021
@frannydog wrote: Not sure what is happening but lately my photoshop window screen, which shows my artwork is now neon green. 
Try this: go to Preferences >Technology Previews > enable Deactivate Native Canvas. Quit Photoshop and relaunch. ~ Jane

Likes

Translate

Translate
Adobe Community Professional ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

Do you have Quick Mask turned on?  Hit the Q key to toggle.

Have a look at thre Channels panel and make sure RGB is checked and only three channels are turned on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

Quick mask is not on. Channels panel is set as you mentioned.

 

I just noticed when I'm on my big monitor, it works. When I slide to my laptop, it goes green! Any ideas about that?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

I'm trying to remember what I heard, but you mentioned "something to do when I disconnect from my large monitor or something else." As I recall, it has something to do with switching monitors while PS is running, and I can't remember the details.

 

Try first connecting the "correct" monitor, then launchingPS to see if that fixes it. Or try the other answer I gave.

 

Perhaps another volunteer will know; I can't look into it further myself now due to personal obligations. 

 

~ Jane

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

Is it the sort of thing our @D Fosse would know, or is it Mac specific?  It is starting to sound like a GPU video card issue.  It's 11:20pm for Dag so he might be around.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied


@frannydog wrote:

Not sure what is happening but lately my photoshop window screen, which shows my artwork is now neon green. 

 

Try this: go to Preferences >Technology Previews > enable Deactivate Native Canvas. Quit Photoshop and relaunch.
~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 03, 2021 Jul 03, 2021

Copy link to clipboard

Copied

That worked!!! Thank you!! 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2021 Aug 09, 2021

Copy link to clipboard

Copied

Perfect solution, it works!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied

This trick from Jane-e worked but why did it suddendly happen in the first place. Photoshop for me was fine on my extra monitor but on my Imac Pro monitor it turned green... all of a sudden last week....... Thank you for the fix Jane - e

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 17, 2022 May 17, 2022

Copy link to clipboard

Copied


@shinyredguitar0 wrote:

This trick from Jane-e worked but why did it suddendly happen in the first place.

 


 

You're welcome, @shinyredguitar0 

 

Both Apple and Microsoft have changed the old Open GL in their OS, which has been deprecated or removed. Deactivate Native Canvas forces the GPU to use the older GPU functions and might not be needed after an update to your GPU driver.

 

Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 29, 2022 Jun 29, 2022

Copy link to clipboard

Copied

LATEST

Worked for me too!!! Thank you

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

I had the same issue. This worked perfectly! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines