Eraser not erasing 100%

Explorer ,
Mar 03, 2018 Mar 03, 2018

Copy link to clipboard

Copied

Hi,

Since updating to CC2017 many things have not worked as they used to at their defaults so this may be user error.

I have the eraser set to opacity 100% and Flow 100%, but the eraser does not erase 100%. In the attached screenshot, you can see that I am attempting to erase the black background. I put the green behind to see my progress/make sure nothing was missed. Here is what I have tried:

Tried using my mouse instead of wacom tablet.

Tried using block and pencil, both do the same thing as brush

Tried resetting the tool

Hardness is at 100%

Tried clicking and unclicking "pressure for opacity" next to opacity

Tried clicking and unclicking airbrush

Tried googling the answer but didn't really find anything applicable.

The background eraser does the exact same thing.

What am I doing wrong?

Screen Shot 2018-03-03 at 1.28.18 PM.JPG

Views

14.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Aug 15, 2019 Aug 15, 2019

i had the  problem that eraser tool didn't work 100 %, and with your help i figured it out what was wrong. The black color wasn't set at 000000. So thank you so much! I have been trying everything!!! Thank you so much! If i hadn't find this comment i would be stuck...

Likes

Translate

Translate
LEGEND ,
Mar 03, 2018 Mar 03, 2018

Copy link to clipboard

Copied

While the reason for the problem is not immediately apparent, I wonder why you are not using a mask rather than the Eraser tool. A mask is non-destructive and infinitely modifiable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 03, 2018 Mar 03, 2018

Copy link to clipboard

Copied

That's how I ended up making the background transparent since I got tired of fiddling and needed it to be done, however, I would like the eraser to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 03, 2018 Mar 03, 2018

Copy link to clipboard

Copied

Same incomplete erasure with each of the other two eraser tools nested there?

Is it only this file?  Do multiple strokes finally do the job or does tone always remain?

When you open a new file, fill it with black and trash the lock, does it go to transparent with the the Erase tool or does some tone remain?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

Same incomplete erasure with each of the other two eraser tools nested there?

-Yes, all tools do the same thing

Is it only this file?

-No, this happened on another file and I didnt have time to deal with it

Do multiple strokes finally do the job or does tone always remain?

-Multiple strokes do eventually do the job

When you open a new file, fill it with black and trash the lock, does it go to transparent with the the Erase tool or does some tone remain?

-It works perfectly with a new file filled with black

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 03, 2018 Mar 03, 2018

Copy link to clipboard

Copied

It looks like you are erasing within a selection. Has the selection got a feather setting ? If so the eraser will only partly erase in the feathered area.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

There is no feather on the selection, I wanted it real tight.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Mar 03, 2018 Mar 03, 2018

Copy link to clipboard

Copied

Maybe you are using Quick Mask mode? with different Opacity

Or tablet and Pen? - with wrong settings?

pawel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

Maybe you are using Quick Mask mode? with different Opacity

-Not using Quick Mask, selection was created on the Magenta channel with no additional refining as it selected it perfectly on that channel.

Or tablet and Pen? - with wrong settings?

-Happens using my tablet & pen even after futzing with the settings, also happens using my mouse and my trackpad

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

Can you show a screenshot of your brush settings panel when this happens

Does it happen with all the brush setting options, i.e. from Shape Dynamics down to Protect Texture,   unchecked?

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

About the only thing you seem not to have tried is resetting Preferences.

The fact that Erase works on the Background layer but not stacked layers may indicate a Preferences glitch.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2019 Aug 02, 2019

Copy link to clipboard

Copied

Hi, this took me forever to figure out and it may be the case for you as well. I was not getting 100% erasure on my masks, this was due to the fact that I did not have my default colors set to black and white. The white was slightly gray causing it to not erase completely. So press D to go back to default colors (black and white) then press X to switch between them depending on if your mask is inverted or not.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2019 Aug 15, 2019

Copy link to clipboard

Copied

i had the  problem that eraser tool didn't work 100 %, and with your help i figured it out what was wrong. The black color wasn't set at 000000. So thank you so much! I have been trying everything!!! Thank you so much! If i hadn't find this comment i would be stuck...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2021 Sep 21, 2021

Copy link to clipboard

Copied

THANK YOU!!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2022 May 21, 2022

Copy link to clipboard

Copied

Thank you. Thank you. Thank you. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2020 Jan 29, 2020

Copy link to clipboard

Copied

omg thank you for this! I was stumped until I found your advice!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Sep 19, 2020 Sep 19, 2020

Copy link to clipboard

Copied

Thank you! That has saved me hours of stress!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 02, 2021 Oct 02, 2021

Copy link to clipboard

Copied

i have this same problem, but i've tried this solution and it hasn't worked for me

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 02, 2021 Oct 02, 2021

Copy link to clipboard

Copied

nevermind, i was being stupid

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2022 Jun 08, 2022

Copy link to clipboard

Copied

LATEST

I'm having this issue now as well. I've tried the Wacom pen tip setting and the 100% blk and white. Any other solutions out there? It started doing this 2 days ago just out of the blue. The mask never gets to 100% of the erased area.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines