• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Error 23: ) does not have a value. Line 1

Community Beginner ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

I have written two scripts which were working totally fine until 10th of December. Even though I didn't change my JSX code, it stopped working and the attached error window is displayed when I my scripts. Does any one know what might be causing the issue? There was a version update. Perhaps there update wasn't done properly??

On the first line of my code I'm importing json2.js. The file is placed in the directory.

#include json2.js

Best,

Kaan

Snip20201212_1.png 

TOPICS
Actions and scripting

Views

1.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
Community Expert ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

Should work, can you share json2.js file that you are using. I am currently using this file in one of my projects and it's working fine. What is the version of your PS, did you try executing the script against the Extendscript engine rather than the PS engine.

-Manan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

Sure, here's the link to repo https://github.com/douglascrockford/JSON-js/blob/master/json2.js 

No I haven't executed it against the Extendscript engine as I wasn't aware of that. How can I do it? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

I tested it again in InDesign and PS(22.0) and by placing the source file and the json2 in the same folder as well as in another folder in all the cases it worked fine for me.

Can you just test with only a single line i.e. the include statement in your source file and see if it works

-Manan 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 12, 2020 Dec 12, 2020

Copy link to clipboard

Copied

Uninstalling and installing PS again solved the issue. Thanks for your help!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 04, 2024 Apr 04, 2024

Copy link to clipboard

Copied

LATEST

I have an After Effects script with the same problem. Uninstalling and Installing again didn't work, but I chose to keep my preferences. I guess I'll have to try again, and kill them off. 😞

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines