• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Error "Your graphic processor is incompatible"

Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Hi,

 

The above error message appears when starting Photoshop CC. All components are updated to their latest versions:

 

  • Windows 10 Home 64-Bit
  • NVIDIA GTX 1050 Driver version 472.39 (Studio Driver)
  • Photoshop 23.0.0

 

This used to work like without issue. Now, some functionalities and add-ins crash PS. Any idea what could solve this? I tried uninstalling the drivers, followed by a clean re-install. Adding PS and sniffer.exe in the Program Settings of the NVIDIA Control Panel. Nothing works. Here is the systen info. Thank you for any help!

Screenshot NV-PS.png

TOPICS
Windows

Views

8.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Nov 09, 2021 Nov 09, 2021

Hi

Do you have dual GPU's on your system, you may have an onboard GPU like an Intel or AMD, have you updated the driver for that as well

Take a look here, especially section 7

https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

Votes

Translate

Translate
Adobe
Community Expert ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Hi

Do you have dual GPU's on your system, you may have an onboard GPU like an Intel or AMD, have you updated the driver for that as well

Take a look here, especially section 7

https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Thank you so much Ged!

 

Indeed, my laptop has two GPUs (onboard and dedicated) and the onboard GPU drivers had been updated. In the NVIDIA Control Panel, the NVIDIA GPU had been selected as the preferred device for Photoshop as well.

 

But what solved the issue in this case is the section 8 of your link : "Disable the less power graphics card. If step 7 does not resolve issues when using more than one graphics card, consider disabling one of the graphics cards."

 

Now everything is back to normal and I can continue to use the latest PS version. Thanks again !

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

You're welcome, glad you got it sorted

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2023 Jul 22, 2023

Copy link to clipboard

Copied

yess what i do now

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 22, 2023 Jul 22, 2023

Copy link to clipboard

Copied

@nikhil31232072xg8q you need to provide more information, what exactly is your issue and what are your computer system specs

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2024 Jan 14, 2024

Copy link to clipboard

Copied

LATEST

In addition to the other troubleshooting ideas, the only thing that worked for me is to open the Microsoft Store and install the OpenCL™ and OpenGL® Compatibility Pack. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines