Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


GIFs not working

Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

so I made a gif. and it just won't move. it works fine when I open it but once I show the layers (other than the first layer), it stops moving and I can't get it to move again. it doesn't move in photoshop, nor when I save it as a gif. I need to show the layers to be able to auto tone though.. any help is appreciated because I've been stuck on this for a week.

Views

40.8K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

You must use File - Save for Web to save an animated GIF.

Use the Timeline Panel to edit the animation.

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

I know. that's not the problem.

Untitled-1.jpg

it will get stuck on whatever layer I show. when I unshow all the layers the auto tone will be gone from all the layers and sometimes the entire gif (except for the first frame) will disappear.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

Check which layers are visible in each frame (i.e., click first on the frame, then examine the layer visibility for that frame).

What may be confusing you is that some operations you do on the image could cause a new layer to be created or one of the higher layers to be made visible for multiple frames.

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

If you'd like, save a small GIF and make it available online, and I'll open it and look into it.  That might help find the specific problem quickly.

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

I'm not sure what you mean but I uploaded the gif I'm trying to make now. btw the layers tab and animation frames have the same amount of layers. none of them are visible right now except for the first.

http://img525.imageshack.us/img525/2113/blahxw.gif

here's the gif before I open it in photoshop

I didn't do anything to it except for auto tone.

http://img832.imageshack.us/img832/3876/kouyou2.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

Did you specifically use File - Save For Web to save it as I mentioned in post #1 above?  It has no frames in it.

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

yep I did! even in the file - save for web screen though, it won't move when I click preview or scroll through the frames. when I play the gif in photoshop it does scroll through the frames, but it only shows the first frame.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

Animation setups are tricky.  Each frame is essentially showing a different layer in the image in succession.  You're likely doing something that's either making the same layer visible in every frame or something that's corrupting the frame structure for use in the animation.

You can't just run Auto Tone one time on an animation and have it affect every frame.  You'll need to select each frame in the Animation panel, then select the one visible layer, then run Auto Tone on it.  Then when you've done it 32 times, you will be able to save the result as described and have it animate properly.

By the way, I wouldn't bet that Auto Tone run on each individual frame would do what you want, since it may make different decisions based on the content.  A more rational way to clean up this video would be to add one or more new adjustment layers (e.g., Hue/Sat, Curves, etc.) over the top of all the layers there now, then make one adjustment that makes the frames all look better.  That will both allow you to do the change only once and also keep the adjustment consistent across the entire video.

AdjustmentLayersOverAnimation.jpg

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

I honestly don't know what I'm doing that could corrupt the file. all I did was open it, select each frame (show it) and use auto tone and it just stops working ._.

when I use hue/saturation.. is it supposed to work on all frames or do I have to apply it on each frame individually?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

An adjustment layer added above all others will affect all frames.

-Noel

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

i'm sorry but how do i add an adjustment layer?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

Ruki-san wrote:

i'm sorry but how do i add an adjustment layer?

It might be a good idea to look at the Photoshop Help for basic instruction.

Entering "adjustment layer" in the search box will find Adobe Photoshop * Adjustment and fill layers

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 03, 2012 Sep 03, 2012

Copy link to clipboard

Copied

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 11, 2020 Feb 11, 2020

Copy link to clipboard

Copied

  1. RJ Roni 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2018 Sep 29, 2018

Copy link to clipboard

Copied

I've been having the same problem. I opened the timeline, and I found that photoshop on defaults to making gifs where each image plays for the entire length, resulting in a gif that "plays" but only shows the bottom image. (See attached photo.) The only real solution kinda sucks, but you have to manually adjust the length each image stays on the screen for. This really SHOULD be considered a bug, and the fact that it hasn't been fixed is making me reconsider my subscription. Also, Noel, this is NOT a user error. You shouldn't be BSing around accusing people of corrupting files just because you can't admit you don't have a clue what you're talking about, "Photoshop Expert."

Hopefully this solves your problem, Ruki.Timeline.PNG

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 21, 2021 Jul 21, 2021

Copy link to clipboard

Copied

Noel is a literal idiot. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 29, 2018 Sep 29, 2018

Copy link to clipboard

Copied

In case "manually adjust the length each image stays on the screen for" was vague I've included an "After" pic of the same file as posted previously, as well as the outcome.

Updated Timeline.PNG

And here's the gif, although I don't know if it will play in the forum, it works in my browser. Cheers!

synthwaveGrid2.gif

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 14, 2018 Oct 14, 2018

Copy link to clipboard

Copied

I made a tutorial that solves your problem: https://youtu.be/Szz_Y5-hp54

Hope this helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

I have the same problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

Same problem in 2021. I suspect it might be more prone to happening with large GIFs that have a lot of frames. Stephen's tutorial is fine but it's just a manual solution, it doesn't fix PS behavior. There's no way in hell I'm doing that for 400+ frames, better just convert to MP4 and import that.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 23, 2021 Nov 23, 2021

Copy link to clipboard

Copied

LATEST

I'm not sure why but I was having the same problem. Plays fine in PS and at the save for web menu. But after exporting the Gif wounldn't play. Now I've made animations before but this one wouldn't work. 

Then I exported again and the only thing different was I hit the play button just above the the "D" in DONE at the bottom of export menu (see image). Not sure if that's what did it but when I exported after that it worked wonderfully in a browser and my finder menu as well.

 

Good Luck

 

Screen Shot 2021-11-23 at 6.11.17 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines