Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


[GSYNC] Adobe programs affect refresh rate

Explorer ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

Hey lads,

I have an nvidia graphics card and a gsync screen. Adobe Photoshop CC and all other Adobe programs, for that matter, somehow trigger Gsync.

 

Whenever I launch an Adobe programme and perform a simple action like dragging an image in Photoshop, Illustrator or a video in Premiere, the refresh rate starts jumping around from 165 all the way to 17 and back. As soon as I stop the action I was performing, my refresh rate jumps back to its default (which is 165 in my case).

 

All my drivers, obviously including my graphics card's drivers, are up to date.

 

I have an Asus Gsync screen and an nvidia 2070 Super, but this problem also occurred on my previous graphics card.

 

Somehow Adobe software triggers the variable refresh rate, which should only be the case in video games.

 

Does anyone know of a fix, besides disabling Gsync every time?

 

Thanks!

TOPICS
Crash or freeze, Performance, Problem or error

Views

10.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Nov 12, 2019 Nov 12, 2019
The Problem seems to be done for me. Nvidia released driver v441.20 today, after this everything works smooth again at full 120hz withhout any drops.

Likes

Translate

Translate
Explorer , Nov 21, 2019 Nov 21, 2019
Last Adobe updates (to 2020 versions) seem to have fixed the issue.

Likes

Translate

Translate
Explorer ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

No one? Seriously?

 

Are there any Adobe customer service people available?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Hey, 

i have the same Problem since updating my GPU from GTX 980ti to RTX 2070 Super.
FPS drops low to 17, struggeling around 50ths and coming back to 120 after doing not more action in adobe creative products.

Looking for a solution, but cant find this problem at the internet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 11, 2019 Nov 11, 2019

Copy link to clipboard

Copied

Exact same problem; upgraded from a 980ti to a 2070 super as well!

 

At the moment it's impossible to use any Adobe program with gsync enabled.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Please change that updates fixed the issue, because they have not. Read my comment for details of what I'm experiencing.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

I am havig the exact same issue with Lightroom and Photoshop!

 

I have an RTX 2080 Ti with a 165hz refresh rate G-Sync monitor.

The program never ceases to drop the refresh rate to an abismol level for no reason when using certain functions within the program and sometimes the low refresh rate is continuous until I close the program.

 

i9-9900k Processor as well.

All up to date drivers.

 

This is very annoying because I am forced to use a monitor with a refresh rate of 60hz to be able to even use the program effectively.  This needs to be fixed!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

The seam issue.
You can try to reduce your refresh rate to 60 and that solve, partially the problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

The Problem seems to be done for me. 

Nvidia released driver v441.20 today, after this everything works smooth again at full 120hz withhout any drops.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Last Adobe updates (to 2020 versions) seem to have fixed the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

This is not true as of now, This issue should not be solved. Please check my comment for details. Wondering if its just my monitor at this point.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

So I found a fix to the major issue I had... Downgrading from version PS 22.5 to 22.4 and using the fixed refresh rate setting in Nvidia panel seems to be working for now. For some reason 22.5 was causing my monitor to flash black like it was off then back on everytime the refresh rate updated, or basically everytime you did anything in PS.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

I have the same problem with my 2080TI and updates don't help. 😞

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

Solved my problem by turning off G-Sync for Adobe Apps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2019 Dec 28, 2019

Copy link to clipboard

Copied

Same

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2020 Jul 07, 2020

Copy link to clipboard

Copied

Where did you turn this off? The photoshop clitching is relentless.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 07, 2020 Jul 07, 2020

Copy link to clipboard

Copied

3d-profiles in Nvidia Control Panel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

I had the exact same problem ever since installing Adobe Audition. Now with the 2020 update all my Adobe apps continually dip framerate whenever I'm performing an action. After hours of troubleshooting I have finally come across this thread and my god am I happy. As someone else mentioned, turning G-Sync to "fixed refresh rate" in the Nvidia control panel for all Adobe apps fixed my issue.

Adobe needs to fix this now. Small bugs like this waste hours of productivity.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

"Somehow Adobe software triggers the variable refresh rate, which should only be the case in video games."

 

No, no and no! Photoshop is using OpenGL and Nvidia finally implemented OpenGL windowed G-Sync! It is great. And all problems are because of Adobe devs. You can simply turn off G-sync for ONLY Photoshop in nvidia control panel. Also here I discussed it.

https://community.adobe.com/t5/photoshop/g-sync-is-now-working-in-photoshop-with-latest-nvidia-drive...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

What the heck is going on?

 

I have used Adobe products on the same hardware, using the same GSync display, for literally YEARS. GSync has been enabled since 2014 guys, and has had precizely zero problems until updating to the current Adobe product line. 

 

raised eyebrows

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

Gsync is Opengl started working only in 2019. And yes, photoshop uses Opengl.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

What?

 

I have been using the same Gsync display, with Gsync enabled, on the same hardware, since 2014. It wasn't until I updated to CC 2020 earlier this week that this has become an issue. First I've ever encountered it, but I am certain that it functioned since 2014, and I use Photoshop almost daily.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

No, OpenGL did not have VRR extensions in the driver to give it to G-sync. You updated Nvidia driver it has nothing to do with Photoshop. See my post, https://community.adobe.com/t5/photoshop/g-sync-is-now-working-in-photoshop-with-latest-nvidia-drive...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

Had this problem today as well on a fresh Windows 10 installation. In the Nvidia Control Panel, I fixed it by disabling G-Sync for WINDOWED modes, and kept G-Sync only for FULL SCREEN.

 

I discovered other programs giving me the same issue, hovering my mouse over their icons would lag the mouse like crazy. Intel Rapid Storage application - just hovering over the buttons and icons- will cause the same issue I see in Adobe apps with the mouse lag as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

No need for that. You can just turn of G-sync off only for Photoshop in 3D profiles. Anyway, on fast PC it is fixed, i.e. 1 frame drawing is now fast enough.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2020 Aug 16, 2020

Copy link to clipboard

Copied

I have had to disable the use of my Graphics Processor so that Photoshop is even usable. Below are my system requirements which I know are really good for just running photoshop. As of 8.16.2020, this is still an issue.

 

Adobe Photoshop Version: 21.2.1 20200716.r.265 2020/07/16: 2b9692040b x64
Operating System: Windows 10 64-bit
Physical processor count: 4
Logical processor count: 8
Processor speed: 4000 MHz
Built-in memory: 32671 MB
Free memory: 17951 MB
Memory available to Photoshop: 29918 MB
Memory used by Photoshop: 60 %
Scratch volume(s):
D:\, 931.5G, 682.2G free
C:\, 465.2G, 288.0G free

NVIDIA GeForce RTX 2070 Super
NVIDIA Studio Driver 451.77 : Release Date: 07/16/2020

 

Regards,

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2