How to install older version of photoshop

New Here ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

HI,

I would like to know how I can install older versions of photoshop because i have an imac which works on High Sierra and i can't upgrade the os. ADOBECLOUD says that high sierra is not compatible with the new photoshop.

 

Thank's for your help 😉

TOPICS
macOS

Views

37

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 15, 2021 Nov 15, 2021

Copy link to clipboard

Copied

LATEST

It seems CC 2019 would be required for High Sierra 

https://helpx.adobe.com/photoshop/system-requirements/2021.html

https://helpx.adobe.com/photoshop/system-requirements/2020.html

and that is not available via the CC anymore, you could try prodesigntools. 

https://prodesigntools.com/adobe-cc-2019-direct-download-links.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines