How to stop auto selecting quick mask channel when switching layers

Community Beginner ,
Jul 04, 2009 Jul 04, 2009

Copy link to clipboard

Copied

I'm having this irritating problem where everytime I select a different layer or group, the Quick Mask channel is automatically selected. This forces me to switch to the Channels tab and select the RGB channel before I can perform work on a layer. Why is Photoshop automatically selecting the Quick Mask layer when switching between layers? I can't seem to find a setting for this and I'm not sure why, all of the sudden, it started doing this. Does anyone know how to stop this madness?

Thanks!

Views

42.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 04, 2009 Jul 04, 2009

Copy link to clipboard

Copied

If "trashing your Prefs" does not rectify your problem, I'd ask how you are selecting your Layers - is it by using a keyboard shortcut, or clicking on the Layer/Layer Set?

Good luck,

Hunt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 04, 2009 Jul 04, 2009

Copy link to clipboard

Copied

Trashing my prefs did not solve the problem. I am selecting layers by left clicking them in the Layers list.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 05, 2009 Jul 05, 2009

Copy link to clipboard

Copied

The "Q" key doesn't get used all that much. It could not be sticking, could it? Though, if it was, I'd expect you to report a toggeling of QM on and off, and not what you report.

Good luck,

Hunt

PS, I'm with Mylenium that something has probably re-mapped, or hooked normal operations in PS. Any keyboard shortcut utilities installed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2009 Jul 08, 2009

Copy link to clipboard

Copied

This problem was caused by my own misunderstanding of how the quick mask "mode" works. I had hit the 'Q' button and switched into this quick mask mode, and getting out of it was as simple as just pressing 'Q' again. It was maddening for me until I understood that!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

Did my head in as well, just resolved it. Thanks for this post. 🙏🏼

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Thanks so much for this post!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

LATEST

That's what it was! the Q key

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

OMG thanks so much! I was getting SO frustrated w this. Q button was the problem!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2009 Jul 05, 2009

Copy link to clipboard

Copied

Sounds like you have a generic system configuration problem. I'm not aware of anything that would auto-trigger quick mask mode. Perhaps something with a custom mouse function/ tablet function key?

Mylenium

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 09, 2018 Aug 09, 2018

Copy link to clipboard

Copied

Just press 'Q' to activate-deactivate quick mas selection.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2019 Sep 18, 2019

Copy link to clipboard

Copied

Worked for me - thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

I'm having this problem too. Only I now it isn't the "Q" key making it quick layer, because I've changed that to a bursh size change in my keyboard shortcuts. Everytime I select a layer it makes it red and turns it into a mask. So annoying.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Nevermind I resolved it. I found an option under Select, to Edit in Quick Mask Mode, once unselected, it went back to normal. Can't for the life of me remember selecting that but happy I found it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2021 Jan 26, 2021

Copy link to clipboard

Copied

hi NHeazell, i too have the same problem. but, as you said above, it will happen only once, next time if we do selection using Q+B  the prblm will appear. does it have fix solution

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines