Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


I can't open photoshop version 4 on my MacBook pro which has Mojave as its operating system thanx P

New Here ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

Hi Community 

I have a macbook pro which has Mojave as its operating system. I can't open Photoshop Version 4 on it.

Can you help open P'shop so I can get my photo library back ?

Thans Paul 

TOPICS
macOS

Views

65

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Photoshop version 4 was released 25 years ago and cannot run on any Mac from the last 20 years. You can subscribe to the Adobe "Photographer Plan" from US$10 to get the latest app you need (Photoshop 2021).

 

Not sure about photo library though. No version of Photoshop has contained a library. Could it be you were using Photoshop Elements>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Hi
my mac is from 2012 (ancient I know) and came with photoshop 4 ? It was working with photoshop no problems.
I upgraded to Catalina, from Mojave, hated it and went back to Mojave and then had trouble with photoshop after that.
I really don’t want to have to pay ongoing fees to use photoshop
ta P

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

No, Photoshop 4 would not have run on a Mac from 2012. I have Macs of that age. No way.

Maybe you mean CS4 (Creative Suite 4).

 

The thing is, Adobe really do want you to pay ongoing fees, and it's their app... they found entirely too many people bought it once and kept using it 10 years later. That's not the model the software industry want to see.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Hi
the photo manager system that came with this Mac computer is - Photos Version 4 (3461.7.160) -
Is that photoshop ?
I notice in the acknowledgements that Adobe is actually still Apple developed.
Thanx Paul

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

Photos is Apple software and is NOT Photoshop.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

LATEST

Hi @defaultl3qjvoo3t8b4 

It sounds like you may have Photos from Apple, not Photoshop from Adobe. Photos was was changed under the hood and is not the same in Mojave and Catalina. A user at this site from Apple had the same issue as you and was offered several possible solutions. See if this helps:

https://apple.stackexchange.com/questions/372829/photo-library-wont-import-back-on-mojave-after-cata...

 

~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines