Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Lasso Tool Q - Straight Segment Issue

Engaged ,
Aug 15, 2021 Aug 15, 2021

Copy link to clipboard

Copied

G'Day. I'm wondering if others have noticed an issue I've had for a couple of versions of PS now when using the Lasso Tool. If I want to draw a curved selection out, initially the Lasso Tool delays a bit before it actually "lays down" the marching ants. Once the program "recognizes" that a selection is being drawn, the marching ants start where I first started drawing, but from that point to where the tool is recognized, is a straight segment rather than a curved one. I've noticed this happens not just on my Cintiq with the stylus, but also when using my trackpad on the iMac. The length of the straight segment depends on how far I am zoomed in. It appears as though you have to drag the tool for a certain distance relative to the movement of your tool (finger on a track pad or stylus on the tablet) rather than a given number of pixels, thus the more you are zoomed in, the less of the object you are drawing around you have to cover before the selection starts to curve. Now I have seen where others are using the Pen Tool for drawing selections and I'm thinking I may go that route myself on a regular basis as it is more precise and frankly, just as easy to use (especially when you need a lot of precision), but I'm wondering if there is a setting somewhere in the Preferences that might prevent this from happening? Any thoughts/suggestions would be welcome. Thanks.

 

Systems:

Photoshop 2021 22.4.3

Wacom Cintiq 24 Pro

iMac 27” 5K Retina Late 2015

Apple macOS Big Sur - 11.5.1

Processor:  4 GHz Quad Core Intel i7

Memory:  32 GB 1867 MHz DDR3

Graphics:  AMD Radeon R9 M395x 4 GB

Storage:  Fusion Drive 1.74 TB of 3 TB available


Glenn
TOPICS
macOS

Views

79

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Engaged , Aug 17, 2021 Aug 17, 2021
Hey Mark,Ok, that's interesting you aren't seeing it too. It must be related to something I have in there. FYI, all my software have the latest updates (I always update the day of..) and I've cleared my preferences several times. I've been seeing this behaviour for at least a year now (actually, I think since 2020). I can't conclusively rule out it's something to do with the Wacom drivers, but I get the same thing when I'm using the trackpad, as I say. That's not part of Wacom's system. Anyway, ...

Likes

Translate

Translate
Adobe Community Professional ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Hi Glenn,

 

NOt sure if I am understanding the issue exactly or if maybe the tool is just new to you. The lasso tool is one of the selection tools. I usually use it after using the magic wand or the quick selection tool to help me grab or remove a few pixels from the selection. It is a free form selection tool, and it does NOT show the selection (or marching ants) until you complete your manual selection using the mouse. And when you let go, Photohsop creates a straight line from the place you left off to the palce where you started to complete the selection.

 

Many people do use the pen tool for more precise selections since you can even move the points and path after you drop them down. Whereas the lasso tool's selection can't be edited as much (you can scale or rotate the selection, feather it, but not change its path). So the pen tool is one way to work, or using the magic wand and/or quick selection tool can also help select around objects, and then I can use select and mask to further perfect the selection. And after exporting from select and mask, using a mask layer.... I can also keep on perfecting my selection using the brush tool and using black and white to hide or reveal parts of my image.

 

Hope this helps!
mark

headTrix, Inc. | Adobe Certified Training & Consulting
Consulting | Design | Development | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 16, 2021 Aug 16, 2021

Copy link to clipboard

Copied

Hi Mark,

Many thanks for your reply. Yeah, I didn't do a great job of describing exactly the issue (I thought of enclosing a screen shot, but it's pretty hard to grab anything of the marching ants). Nevertheless, you did a very good assessment of what I was trying to say. You're right, of course, about not seeing the marching ants until after the completion of the selection. What I should have said was the "line" that follows as you draw out your selection with the Lasso tool, until you complete the selection process. What I see is initially it starts off as a straight segment instead of exactly following my every turn as I start to draw, either using the stylus or the trackpad. The distance is quite short that it does this but once I've completed the selection drawing, there is always this short bit at the start that is straight, even when I complete the selection back to the origin point. I have made an illustration (see attached) to try and show what I mean, which might help. Pretend that the line I drew is the line that follows the lasso as one draws out the selection with the tool (I've not completed the "selection" simulation for clarity purposes). Note in the top drawing is how I'm trying to actually draw out the selection with the Lasso (again - a simulation - one wouldn't actually draw a selection of this shape), where the drawn line is curved from the start. The bottom drawing is what I actually get once the line following the Lasso tool actually starts drawing. There is a short delay from when I start pulling the tool to when that selection line actually shows up, and that's where the straight segment appears. Once the Lasso tool line actually starts to appear, it will start from where I actually started drawing, but the interval between there and where the line actually started appearing, is straight, not curved, as I drew it. I'm not sure I'm making myself any clearer here unfortunately.

 

Like you, I do use those other techniques you mentioned as well. Where I run into the most trouble with this issue when digital painting and I want to draw out a detailed shape to paint within, as opposed to selecting an object that is already there. In this case there is nothing to select as I could even be working with a blank canvas at that point. Often times it's a quick and dirty selection I need to make, and I can allow for this "straight segment" after the fact by simply removing it from the selection, but I was wondering if there was something I could do to prevent it from happening in the first place. It's quite possible I can't, but I thought I'd mention it here in case there was a setting of some kind that would stop this from happening.

 

Anyway, that's the scoop. As I say, I'm not sure I made it any clearer, but hopefully I did. Thanks again Mark. Hopefully after trying to decipher this, you don't require a mental health day 😄 !


Glenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

HI Glenn,

 

so I understand what you are saying. This sounds like some sort of bug. Mine is NOT working like that. I have no issues over hear. I wonder if you should try updating your software to the latest version, or remove the preferences (which could sometimes get corrupt) and press and hold Shift+Ctrl+Alt (Win) / Shift+Command+Option (Mac) on your keyboard and relaunch Photoshop and keep holding the keys down until you see the prompt.

 

Hope that helps!

mark

headTrix, Inc. | Adobe Certified Training & Consulting
Consulting | Design | Development | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

Hey Mark,

Ok, that's interesting you aren't seeing it too. It must be related to something I have in there. FYI, all my software have the latest updates (I always update the day of..) and I've cleared my preferences several times. I've been seeing this behaviour for at least a year now (actually, I think since 2020). I can't conclusively rule out it's something to do with the Wacom drivers, but I get the same thing when I'm using the trackpad, as I say. That's not part of Wacom's system. Anyway, it is something I can work around so I'm not overly worried about it, but I was hoping that someone might be able to say, "Oh yeah, change this and you're set!" 🙂 . Not to be I guess.

 

Thanks again for your time Mark. Really appreciate your help. Have a good one 🙂 .


Glenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

hi Glenn,

 

Yes it does sound like a bug, and it could be from your other software. You could try calling Adobe Support and they might have you share your screen and they might be able to help figure it out. 800-443-8158

 

Lets hope!

best,

mark

headTrix, Inc. | Adobe Certified Training & Consulting
Consulting | Design | Development | Training

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

LATEST

Thanks for this Mark. I may well do that. Right now it's not a big enough worry to mess with too much, and to be honest, I'm afraid if they/I mess with too many settings, I'll end up with more problems than I start with. Yes, that's happened before 😉 . Anyway, I'll give it some thought and we'll see what happens. Appreciate your time as always.


Glenn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines