• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Last Version (12.0) of Ps and Lr not compatible with Mac OS Catalina?

New Here ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

Hello,

 

I have downloaded and installed the last versions (12.0) of Ps and Lr.

They are working perfectly on my Mac OS Ventura on on my iMac  but are annouced as "Not compatible" with my Mac OS Catalina on my Macbook Pro.

 

Any solution coming?

Thx for your answer

KR

TOPICS
macOS

Views

59

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 27, 2022 Oct 27, 2022

No. Unfortunately, Catalina is no longer supported. Apple and Adobe only the 3 most current releases of macOS.

 

Likes

Translate

Translate
Adobe Employee ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

No. Unfortunately, Catalina is no longer supported. Apple and Adobe only the 3 most current releases of macOS.

 


Senior Product Manager - Customer Advocacy - Digital Imaging

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Thx for your answer,So, i understood I have to buy a new laptop because mine is too old!!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

The previous versions of the software you have currently installed are still working.

But unless you use a hack to force the installation of a more recent OS (not really something I would recommend on a production machine) you would not be able to install the newer versions that might requires routines, code and APIs only present in the most recent versions of the Operating System.

 

The good thing is that the current Apple hardware is way more powerful and at the same time more power conscious than what you had, after years of stagnation, even at the low end of the range, and the cost are reasonable. Their main drawback is that you cannot upgrade the memory or the internal storage anymore.

10 years is a long time, nowadays, for professional hardware. I remember upgrading my PCs every 4/5 years... But I have a Late 2013 MacBook Pro that will be stopped at Big Sur, so I'll have to upgrade soon as well...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

quote

Any solution coming?

 

You'll have to upgrade your MacBook Pro to Big Sur, Monterey or Ventura.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

Thx for your answer, but I forgot to precise that my Macbook cannot upgrade to a further version of Os because of its "antiquity" 10 years old.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

LATEST

I have had to roll over my machines to newer ones, since they keep running out of support. I now have an M1 mini I got for $759 as a refurb with 16GB of RAM, works great even with 50MP files from my 5Dsr.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines