Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


M1 mac patch tool delay and liquify load mouse drag lag in Photoshop 22.5.1 on macOS 11.5.2

Explorer ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

M1 Mac mini (CTO, 16GB RAM / 512GB SSD)

MacOS 11.5.2

PS 22.5.1

Wacom 6.3.44-1

 

Selecting patch tool (any selection) is back to normal, selections are made in an instant.

 

But when I drag the patch tool and let go, there's a bit of delay.

 

Things work fine with patch tool, IF I turn off the GPU support despite the choppy graphics when zooming in/out, loading liquify, and whatnot.

 

liquify load mouse drag lag is somewhat sporatic but it's more often than I'd like (say, 9 out of 10)

 

I can't comfirm if the GPU support is culprit or part of the problem here since a photo loads in a sequnced tile from top-left to bottom-right without GPU support and that I have to wait for liquify to finish loading a photo.

 

but I think there's a strong correlation on how GPU support is affecting (or not affecting) since the duration of mouse drag lag is about the same time it takes a photo to load on liquify window without GPU support.

 

if I resize the photo enough there's no drag lag whatsoever.

 

I've reset preferences numerous times, tried every possible combinations on GPU support + rossetta2, and I'm all out of ideas.

 

-PS-

I have a late 2013 15" MBPr with PS v21.2.2 (which I found to be functioning perfectly without any hiccups and never bothered to upgrade since), copied the app, ran it on my M1 Mac mini, found out to be running just fine on M1 as well on both aforementioned issues, albeit the fact that it's not native M1 support.

 

 

{Thread title edited by moderator}

TOPICS
macOS

Views

108

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Photoshop 22.5.1 on your M1 Mac. Please try enabling the option to Deactivate Native Canvas in Photoshop by going to Preferences, then Technology Previews. Once done, quit & relaunch Photoshop to check if that helps.

 

If the issue persists, you can try to reset the preferences of Photoshop using the steps mentioned here: https://adobe.ly/2Qzc0K3

Please backup your settings prior to resetting the preferences. You can check: https://adobe.ly/2vNz6FG

 

Let us know how it goes!

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

LATEST

Hi, Nikunj

 

The lag regarding patchtool is gone with the "Deactivate Native Canvas" checked.

(for the sake of posting I'm just gonna abbreviate it to DNC)

 

But this seem to bring out the issue regarding the "ruler"

 

Now with the "DNC" option checked and "ruler" visible,

moving opened image(canvas) around in PS with hand tool is choppy.

 

If the ruler is off, then it's bothersome but tolerable enough but with ruler on it's irritating to say the least.

 

Let's say,

GPU support on + the "DNC" unchecked +/- "ruler" = 60fps /

GPU support on + the "DNC"checked - "ruler" = 20-25 fps

GPU support on + the "DNC"checked + "ruler" = 10-15 fps

 

This reminds me of the issue of magnification on Windows UI conflicting with PS

when user sets UI magnification anything but 100% on Windows

which it took me a long time to figure out about a year or so ago.

I was having a lag with Stamp tool with "ruler" on when I set Windows UI to be 150% on my QHD 27" monitor.

It was different problem, but seems like there's a bit of overlap to the untrained eyes.

 

The lag I experience while moving around canvas

is far less important then the smooth opertion of "patch tool"

so if it's something Adobe needs to work under PS's hood

then I can live with what you're offering me as workaround until Adobe fixes the issue.

 

Liquify is still lagging with all DNC checked preferences reset and rebooted and what not.

 

https://community.adobe.com/t5/photoshop-ecosystem-discussions/m1-mac-mini-weird-lag-on-start-of-liq...

 

this is my previous post about the liquify issue,

and seeng as I put it under "discussion" is maybe the reason why there's no Adobe rep response.

None the less, there's another person who said he/she was experiencing the same thing on Intel Macs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines