Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Masks changing by themselves!

Community Beginner ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

I've been having problems with 'blocks' appearing out of nowhere in layer masks that I am not even working on. I have to then select the mask and edit out these unwanted areas effecting the mask which is an absolute pain. For example, I've just been working on a hue/saturation layer, when suddenly blocks appeared in a mask on another layer. They appear without warning. They are always flat edged and random in shape and size. If left, they will change shape as I work on other layers. They are a total pain!

The screen grab below shows what the mask looked like in the layers palette before the blocks appeared. It's a very small area, thus you can't actually see the active area of the mask.

orrignial mask.jpg

Then whilst working on another layer, the 'blocks' appeared on the mask for the tv layer as below.

mask with blocks.jpg

The effect on the image being edited was large areas of the layer were now visible - area shown by red arrows.

effect on image.jpg

Can anyone tell me what may be causing this to happen?

In addition to being very frustrating, I'd prefer to edit photographs without random inputs to layer masks!!

Any help will be much appreciated.

Regards,

Phil

Views

336

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Hi

What exact version of Photoshop do you have, if it's CC2019 try enabling this option in preferences and restarting PS to see if it helps

enable legacy comp.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Hi Ged,

Thanks for the information. Sorry, should have said I'm working with PS CC2019 running on OS 10.14.2

I will give it a go, see how I get on and report back!

Regards,

Phil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Hello again Ged,

I'm afraid it is still happening. I selected the legacy setting as you suggested, restarted PS and after adding a few curves layers with masks the blocks appeared on two other layer masks that I hadn't even touched since reopening PS.

You can see the rectangular blocks on the masks in the layer palette ...

curves layer masks.jpg

..... and the effect on the image itself.

blocks on screen.jpg

Regards,

Phil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Try resetting Photoshop preferences, you may need to backup your setting first

Migrate presets, actions, and settings

Reset Pref.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

I've heard about this from time to time. If you do a google search you'll find some similar cases.

Some of it may be down to GPU issues. These days the GPU does a lot of number-crunching, and then passes the result back to Photoshop. The problem with that, of course, is that it can corrupt the file data, not just the display of them.

I'd strongly recommend posting this on the feedback forum, which is the official channel to the engineers. If you don't get an immediate reaction, bump your post. This is obviously a serious issue if it happens unpredictably and repeatedly. Mind you - it may not be Photoshop causing this, but it's something one wants to get to the bottom of.

Photoshop | Photoshop Family Customer Community

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2019 Feb 27, 2019

Copy link to clipboard

Copied

Thanks again Ged. I've reset preferences and will try again this morning. I don't know if it is all part of the same problem, but when reopening PS after resetting the preferences it crashed the first 3 time and I had to force close. It's open now and I'll see if this solves the problem

Thanks also D Fosse. I have posted on the feedback forum. I did searches before posting but couldn't find anything. Just looked again this morning and found a posting describing simiarish problems, but dating back 5 - 7 years. As you say, they may be GPU related.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 27, 2019 Feb 27, 2019

Copy link to clipboard

Copied

Hi

You could try changing the drawing mode in Preferences - Performance - GPU settings - Advanced to Basic which will put more functionality to the CPU.

You could even turn the GPU off temporarily to test , although that would restrict some functionality.

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 27, 2019 Feb 27, 2019

Copy link to clipboard

Copied

Hi Dave & Ged,

I've tried both resetting the preferences and turning off the GPU altogether  today, and neither have solved the problem - the blocks appear on layer masks all the same. Additionally, the blocks on the layer masks will change simply by zooming in or out. For example, the image below shows the result of a 'block' that has appeared on a curves layer mask.

01.jpg

When I zoom in to 66%, the mask is not applied at all, as below.

02.jpg

Then when I zoomed back out, the black changed altogether and the image looked like this. The lighter area is where the curves layer is in effect and the rest of the image is masked out.

03.jpg

All in all, it make editing an image a complete pain. Any further suggestions will be most welcome.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Hi

I am running out of suggestions. It definitely looks GPU related. When you turned off the GPU in Preferences did you restart Photoshop for it to take effect?

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Hi Dave,


Yep, restarted PS. Tried again and did a reboot too but always the same. I think that it may be GPU related too, but due to the Apple Nvidia spat, the card (NVIDIA GeForce GTX 680 2048 MB) is using the OS X default graphics driver so there is no way to even update the drivers. Having said this, the problem was the same when I was running CC2018 and previous versions under El Capitan and using the Nvidia drivers.


I've had the problem on and off over the past couple of years, with various combinations of OS X and PS, but it seems to be getting steadily worse. In the past I sort of lived with it but it is now bad enough to make editing a real pain. 


Cheers, 


Phil

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

Hi

There is a workaround mentioning crop in post 7 on teh thread linked below,  which might be worth a try to see if it is a similar issue. If nothing else, if it works for you, it will give you more info to add to your feedback forum post where the developers can see it.

zooming in and out disables layer masks. Why?

Dave

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

LATEST

Phil, the same exact problem has frustrated me for about three or four years.   During this time I have changed computers (from an older Mac Pro to a 2020 Mac Pro) and of course I have upgraded Photoshop regularly.   And the exact same problem still persists.   I have found (and you probably have by now) that saving the file, then closing it and reopening it, restores my masks.   I usually find this easier than redoing the mask, depending on the complexity of the mask.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines