Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


OBJ import displaying everything as white

New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Trying to add textures to a 3D model in photoshop, for importing into Lens Studio. However when I import the .obj file, the light is displaying as a white rectangle in the bottom half of the image (see attached image). Turning the light off, or setting it's opacity to 0% shows the model, but then I'm unable to add any textures to the object. It remains white, no matter what I do.

 

I've downloaded a few different models, to make sure it's not something wrong in my export from Blender. So far all files are doing the same thing.

 

I'm running Photoshop v22.4.1 on an iMac Late 2015, 3.2 GHz Quad-Core Intel Core i5, running macOS Big Sur V11.1. Graphics card is an AMD Radeon R9 M380 2GB.

TOPICS
Import and export, Mac, Problem or error

Views

367

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Have you read Adobe's list of issues in Photoshop 2021? Adobe includes several Work Around Set you can try for dealing with its 3D issues.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Thanks for the tip. But none of their solutions have fixed the issue.

 

It seems as though it's importing the light as a ground plane, rather than a light I can move around. Adding any new lights to the scene does the same - places a white rectangular plane in the image. I have no control over movement or rotation for these lights.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

LATEST

The only solution I've been able to work out is that there were some errors in the UV mapping. Redoing the UV mapping on my model imported into Photoshop as it should.

 

Haven't checked the models I downloaded to see if that would be the case with them as well though.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines