Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Error at loading of IPPcv library Photoshop 22.0 Windows 10

Community Beginner ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

I have updated photoshop to version 2021 but it won't open I get this message.
Can anyone help me with this?

Where can I find this missing file?

 

{Moderator Note: Edited the thread title, PS-57173}

TOPICS
Performance, Windows

Views

76.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Employee , Oct 20, 2020 Oct 20, 2020
Hi there, We're sorry for the trouble. Could you please check the minimum system requirements for Photoshop 22.0 here: https://helpx.adobe.com/photoshop/system-requirements.html Also, check the available workarounds to fix this issue for now: https://helpx.adobe.com/photoshop/kb/known-issues.html#ErroratloadingofippCVlibrary Let us know if that helps. Thanks, Mohit

Likes

Translate

Translate
Adobe Employee , Oct 20, 2020 Oct 20, 2020
Hi there, Looks like your CPU version isn't compatible with Photoshop 22.0. You should roll back to the previous version of Photoshop 21.2.4 and let us know if that helps. Here's how you roll back to the previous version: https://helpx.adobe.com/download-install/using/install-previous-version.html Thanks, Mohit

Likes

Translate

Translate
Feb 24, 2021 Feb 24, 2021
Hi there, Sorry that you're getting an error "Error at loading of ippCV library" while loading Photoshop. Photoshop 2021 (v22.x) requires a CPU that supports SSE 4.2 or later. See: https://helpx.adobe.com/photoshop/kb/known-issues.html#ErroratloadingofippCVlibrary To determine if your CPU meets this SSE version support requirement, see Photoshop's Help > System Info dialog and look in or near the 4th line. Adobe Photoshop Version: 22.0.0 20200921.m.1053 2020/09/21: 0fb66349f4  x64 Number o...

Likes

Translate

Translate
replies 159 Replies 159
Community Beginner ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

I have the same problem... Does that mean that I have to buy a new computer if I want to continue with new versions of PS? My computer works very well and I do not want to change..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

use this fix as have been mention above.

 

Here is the fix.

 

Despite what Adobe is saying officially, Photoshop 2021 does NOT require the support of SSE4.2 to run.
The real problem is that:
- IPP libraries optimized for SSE3 are missing from distribution (they are available from Intel)
- OpenCV library was build with SSE4.2 requirement
To fix this download this pack of libs from any source below (it's the same):
https://www113.zippyshare.com/v/cqtznzt2/file.html
https://www.sendspace.com/file/vh0wjm
Unpack archive and copy libs to Photoshop 2021 installation directory (overwrite opencv_world440.dll when requested).

This fixes the problem an PS runs just fine.
But disclaimer as usual - all this at your own risk.

 

Please note that this is not a hack or something like this - this is official libraries from official sources.
Intel IPP libraries was taken from Intel Parallels Studio XE 2020.1.0 and contains valid signature from Intel.
OpenCV library was taken from official release of OpenCV 4.4.0 on GitHUB (https://github.com/opencv/opencv, build by VC15).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2020 Nov 08, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2020 Nov 08, 2020

Copy link to clipboard

Copied

The fix for MACOS can be downloaded from here:

https://www.sendspace.com/file/meab5g


Unzip the file and copy the resulting libopencv_world.4.4.0.dylib file to replace the same file in the Photoshop 2021 installation directory (/Applications/Adobe\ Photoshop\ 2021/Adobe\ Photoshop\ 2021.app/Contents/Frameworks/libopencv_world.4.4.0.dylib).

 

This fixes the problem an PS runs just fine.
But disclaimer as usual - all this at your own risk.

 

OpenCV library was taken from official release of OpenCV 4.4.0 on GitHUB (https://github.com/opencv/opencv)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2020 Nov 08, 2020

Copy link to clipboard

Copied

Additionally, you also need libopenjp2.7.dylib to be installed in /usr/local/opt/openjpeg/lib/ folder
the file can be downloaded from here: https://www.sendspace.com/file/p2i2le

Once you download the file and unzip it, you do the following steps in Terminal:
sudo mkdir -p /usr/local/opt/openjpeg/lib/
mv libopenjp2.7.dylib /usr/local/opt/openjpeg/lib/

Enjoy

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2020 Nov 08, 2020

Copy link to clipboard

Copied

correction..

the file is here: https://www.sendspace.com/file/59abvl

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 08, 2020 Nov 08, 2020

Copy link to clipboard

Copied

Hallo,

Please use the new file downloadable from: https://www.sendspace.com/file/jwxnni

Unzip the file and copy all resulting files to PS2021 install directory (/Applications/Adobe\ Photoshop\ 2021/Adobe\ Photoshop\ 2021.app/Contents/Frameworks/)

Hope it works now

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

Can you please detail how to proceed for someone who is not a PS and Win guru?

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2020 Nov 03, 2020

Copy link to clipboard

Copied

I'm glad to find out there's a fix. I haven't planned to shop for PC hardware just to keep up with the PS. As a paying customer, I can only hope Adobe brings back official support for my AMD Phenom II X4 905e CPU.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2020 Nov 03, 2020

Copy link to clipboard

Copied

Unfortunately as I have found out the fix didn't work for me and simply threw up another error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 09, 2020 Nov 09, 2020

Copy link to clipboard

Copied

Does this mean I pay for the latest version but now I have to buy a new PC first? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2020 Nov 14, 2020

Copy link to clipboard

Copied

I am really discussed with this and very annoyed. I have just subscribed for the first time (done it for 12 months period) and find that I can't run Photoshop. I have been using Photoshop CS6 & Lightroom 6 until yesterday, finally taking the plunge as I realised that I am missing out on so many improvements. (I am now still missing out on lots after upgrading). I have had to install the previous version v21.2.4

 

Surly this can be fixed by offering the option in settings to not use SSE4.2 and let us manage with slower processing. At least we can then still continue to use Photoshop.

 

Please PLEASE, can this be fixed? There could be possibly be hundreds of thousands of users this will affect.

 

In the mean time I can't even open an image from Lightroom Classic as it is expecting v22.0 and I can't find a way of changing that in Preferences.

 

Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 20, 2020 Nov 20, 2020

Copy link to clipboard

Copied

Same issue here and I'm furious that the fix is to downgrade or buy a new computer for a few thousand dollars and spend a hundred hours or so transferring over all the files and programs and source files.

 

Adobe - you really messed up with this one. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2020 Nov 17, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

Ive been having the same problem... I folloewd the steps in this you tube vid... works perfectly 🙂   https://www.youtube.com/watch?v=wCOwEnJkZb4
The fact that we all pay adobe arounf $10 a month, and the couldent even get this sorted is rubbish.

Dose anyone know, will I have to go through this with every P.S update ?

Link:- http://www.mediafire.com/file/qod2ohoj0lgaur1/ps2021_ipp_cv.zip/fileIn This Video We Will See How To Fix Error At Loading Of ippCV Library Photoshop 2...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 03, 2020 Dec 03, 2020

Copy link to clipboard

Copied

Danke für den Tipp mit dem Youtube Video ,habe es mir angeschaut und habe die Dateien nach Anleitung installiert .
Photoshop 2021 funktioniert jetzt einwandfrei. Warum schafft es Adobe nicht mit all seinen Programmierern ein
Update zu bringen,damit PS 2021 auf den meisten Rechnern läuft.

Grüsse und Dank an alle in der Community die ander Lösung des Problems gearbeitet haben.

Chris alpha 99

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

 "Dose anyone know, will I have to go through this with every P.S update ? Dose anyone know, will I have to go through this with every P.S update ?"

 

Yes you will, at least until Adobe refuses to install on your machine at all.  Then we are all out of luck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Yes you have to go trough this ,i have updated to version 22.1 and had again  the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

I have followed the suggections and updated to ippCV library. However I get the following error on trying to load PS:

ippiCanny_32f8u_C1R_L  - the specied procedure could not be found. I then get bombed out.

I have checked my CPU spec and it says:

Umvubusnaps_0-1607270047717.png

Any suggestions now......

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

You have SSE4 so do my follow issues in this thread.  You have another problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

When old version of photoshop is installed. Its showing error pop up just like photoshop 2021. Now what do we do? I am not buying a new computer, therefore, please tell us how to get the old version to work. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

"When old version of photoshop is installed. Its showing error pop up just like photoshop 2021. Now what do we do? I am not buying a new computer, therefore, please tell us how to get the old version to work. "

 

Downgrading worked for me when I tried it.  Are you sure you installed the older version?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

I think i did. I followed the instructions on the link. The old version is 22.01 right? I have been trying for days. Altenating between the 2. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Photoshopr 2021 is ver 22.  You need to go back to Photoshop 2020, which is version 21.  Could that be more confusing?  Click on the ... dropdown to the right of the app in CC desktop and then to Other Versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

Thank you so much. I was confused indeed. Before, I just clicked on the version showing at the top of older versions list. I have now gone back to ver 21.2.4. 

Hopefully Adobe will sort out this error issue when updating to the latest version. They should not have this power to just decide that their customers should buy new computers. Just like what happened to Apple and some of these big companies, this is an Anti Trust issue and they are opening themselves to lawsuits. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines