Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Error at loading of IPPcv library Photoshop 22.0 Windows 10

Community Beginner ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

I have updated photoshop to version 2021 but it won't open I get this message.
Can anyone help me with this?

Where can I find this missing file?

 

{Moderator Note: Edited the thread title, PS-57173}

TOPICS
Performance, Windows

Views

77.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Adobe Employee , Oct 20, 2020 Oct 20, 2020
Hi there, We're sorry for the trouble. Could you please check the minimum system requirements for Photoshop 22.0 here: https://helpx.adobe.com/photoshop/system-requirements.html Also, check the available workarounds to fix this issue for now: https://helpx.adobe.com/photoshop/kb/known-issues.html#ErroratloadingofippCVlibrary Let us know if that helps. Thanks, Mohit

Likes

Translate

Translate
Adobe Employee , Oct 20, 2020 Oct 20, 2020
Hi there, Looks like your CPU version isn't compatible with Photoshop 22.0. You should roll back to the previous version of Photoshop 21.2.4 and let us know if that helps. Here's how you roll back to the previous version: https://helpx.adobe.com/download-install/using/install-previous-version.html Thanks, Mohit

Likes

Translate

Translate
Feb 24, 2021 Feb 24, 2021
Hi there, Sorry that you're getting an error "Error at loading of ippCV library" while loading Photoshop. Photoshop 2021 (v22.x) requires a CPU that supports SSE 4.2 or later. See: https://helpx.adobe.com/photoshop/kb/known-issues.html#ErroratloadingofippCVlibrary To determine if your CPU meets this SSE version support requirement, see Photoshop's Help > System Info dialog and look in or near the 4th line. Adobe Photoshop Version: 22.0.0 20200921.m.1053 2020/09/21: 0fb66349f4  x64 Number o...

Likes

Translate

Translate
replies 159 Replies 159
Adobe Community Professional ,
Oct 24, 2020 Oct 24, 2020

Copy link to clipboard

Copied

It’s encouraging that a software fix may have been discovered that does not involve the hardware… This could have been an oversight or inadvertent omission by Adobe, as errors sometimes happen especially in initial .0 releases of any product.

 

However, any solution that involves modifying the Adobe program itself – especially using third-party files – is absolutely against Adobe’s Terms of Service, and so is not allowed:

 

17. No Modifications: Except as expressly permitted in the Terms, you may not modify, port, adapt, or translate any portion of the Services or Software.

 

In other words, customers currently unable to run Photoshop 22.0 are strongly advised not to try this (which would violate their TOS), but rather continue using the previous major release of Photoshop until more details are forthcoming.

 

If a software solution is possible for customers, then the company could move forward with addressing it officially, and all that would be needed is patience. Surely, they did not intend to intentionally inconvenience any customers if they realized they could have avoided it.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

Really?
Users have already got official response from Adobe which is "use previous version or upgrade CPU".
Yes, sure - one will need to upgrade 6 core @ 3GHz AMD CPU just because Adobe wants some fancy extensions to CPU instruction set.
As for using previous version - Adobe always stated that by paying subscription you are paying for constant development and addition of new features.
What's the point to pay subscription then if users will have to use previous version?
Also go ahead and explain why Premiere Pro 2021, After Effects 2021 and Media Encoder 2021 can run just fine on CPU without SSE4.2, but Photoshop 2021 can't?
Why dropped support for Windows 7 was clearly stated weeks before Photoshop 2021 release, and raised requirements for CPU was not there at the release date (and is still stated only in the system requirements on the page in english, not present for other languages) and was added after tons of complaints from users?
And now you are saying that fixing something that should not be broken on the first place is illegal?
Come on, this is not how things should be going for paid product...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 25, 2020 Oct 25, 2020

Copy link to clipboard

Copied

This needs clarification from Adobe. The fix does not involve using any hacked/cracked version of the dll but the original source's legitimate one, i.e., Intel and OpenCV. This, to me, would be akin to updating/reinstalling VC redistributable package that is often done to resolve issues. Also, on the original post where this fix was posted, this question was posted to a Senior Adobe employee who did not bring up the license violation issue but responded that he would contact the technical team about their views on the fix. The technical team surely would not comment on the license violations, if any. I would appreciate if some employee could come and clarify the official stand on this.

-Manan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

The difference compared to a standard Microsoft Visual C++ distribution library is that those are shared central system resources and don't get installed into Photoshop's own software directory, overwriting files that Adobe has shipped.

 

But absolutely agree that Adobe needs to sort this out and provide more answers – and hopefully an official software resolution as well, if possible.

 

However in the meantime, it's not recommended that users intentionally break the Terms of Service and violate their licensing agreement for the software.

 

Patience... and continue using the prior version, for the moment.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

The overwriting in PS directory

This was something that I was also thinking about after I wrote my comment. This might be a point of contention, its a deadlock now 🙂 Let's hope the people with official news come forward sooner than later.

-Manan

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

Hmmm? Just wondering Just what does this dll do? What amazing new feature that I will probably never use does this support? Will I really be missing out on something wonderful if I don't upgrade? ;-/

Already have plenty of "alternate programs" to use that have most of the features I do use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

God day, It is March 9, 2021. I have just tried to  update to the new PS version (I live in the bush and only have 3G - updating is an "exercise" and expensive for me). I still get the same message. How long is patience needed? (of which I have very little to start off with). And no, no worries, I will not follow the solution given above, simply because I have no idea what the person is talkling about. I "use" my computer and have no intention to lean how it's inside works.

Is there an update on when this problem will be fixed by Adobe?

And please don't bother asing me what stuff is inside my PC - I have no idea. Suffice to say the old PS worked just fine - if we have to remain on the old version beause of programming glitches, do we get a discount?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 09, 2021 Mar 09, 2021

Copy link to clipboard

Copied

@defaultv7hk4q491vff –

 

It's older computers (circa 10+ years old) which are affected, and this situation is not expected to change.

 

However, as noted by Adobe Staff elsewhere in this thread, you can continue using the prior major release of Photoshop. No discounts have been offered AFAIK.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 27, 2020 Oct 27, 2020

Copy link to clipboard

Copied

Thanks alott bro dbur971  

you made my day God bless you....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

Here is the fix.

 

Despite what Adobe is saying officially, Photoshop 2021 does NOT require the support of SSE4.2 to run.
The real problem is that:
- IPP libraries optimized for SSE3 are missing from distribution (they are available from Intel)
- OpenCV library was built with SSE4.2 requirement
To fix this download this pack of libs from any source below (it's the same):
https://www113.zippyshare.com/v/cqtznzt2/file.html
https://www.sendspace.com/file/vh0wjm
Unpack the archive and copy libs to Photoshop 2021 installation directory (overwrite opencv_world440.dll when requested).

This fixes the problem and PS runs just fine.
But disclaimer as usual - all this at your own risk.

 

Please note that this is not a hack or something like this - this is official libraries from official sources.
Intel IPP libraries were taken from Intel Parallels Studio XE 2020.1.0 and contain a valid signature from Intel.
OpenCV library was taken from the official release of OpenCV 4.4.0 on GitHub (https://github.com/opencv/opencv, build by VC15).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

Thanks for the answer. At the moment I went back to the previous version of photoshop, but I will reinstall the new one and try what suggested

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 30, 2020 Oct 30, 2020

Copy link to clipboard

Copied

Here is the response posted yesterday from Jeff Tranberry, Sr. Product Manager, Customer Advocacy - Adobe Digital Imaging:

 

"Engineering says this is not a supported configuration – and that testing showed that there were other issues (crashing, program errors, unexpected behaviors, etc) if you tried to run those libraries on a non-SSE 4.2 compliant machine. Hence, why they were removed and not officially supported.

 

Old hardware gets deprecated as new features rely on new API and hardware. This isn't something that will be fixed – other than in the future, the Creative Cloud desktop app will not allow you to install Photoshop 22.x on system hardware that isn't supported."

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Oct 30, 2020 Oct 30, 2020

Copy link to clipboard

Copied

This is just a general non technical statements which have only one thought under the hood - Adobe is just too stubborn to acknowledge an issue and fix it.

Instead they are trying to convince everyone that SSE4.2 support is absolutely needed, which is not true - this is just a matter of compiler options used when Photoshop binaries were build.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

Almost after a year, Shame on you, ADOBE. 
Shame on you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

This solution works as the only one. After updating to Adobe Photoshop: 22.0.1, the problem reappeared and replacing these files worked.

Adobe workers, be ashamed that you cannot find the problem solution, only Internet users have to solve it! What are we paying for ?!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 20, 2021 Feb 20, 2021

Copy link to clipboard

Copied

photoshop 22.2 not opening at

I downloaded the 22.2 update today (it worked fine before this and up until I did the update). Once the update completed, it has not worked.  I am receiving an error message that says the following:

 

"Error at loading of ippCV library" 

"Your application is dynamically linked with Intel(R) IPP libraries version 2020.0.1 {r0x35c5ec66) No DLL from the list below is found on the system search path: ippcvm7.dll {the most suitable for your CPU) Please provide a path to atleast one of them"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Feb 20, 2021 Feb 20, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry that you're getting an error "Error at loading of ippCV library" while loading Photoshop 22.2

 

Photoshop 2021 (v22.x) requires a CPU that supports SSE 4.2 or later.

 

https://helpx.adobe.com/photoshop/kb/known-issues.html#ErroratloadingofippCVlibrary

 

To determine if your CPU meets this SSE version support requirement, see Photoshop's Help > System Info dialog and look in or near the 4th line.

  1. Adobe Photoshop Version: 22.0.0 20200921.m.1053 2020/09/21: 0fb66349f4  x64
  2. Number of Launches: 6
  3. Operating System: Mac OS 10.15.5
  4. ystem architecture: Intel CPU Family:6, Model:14, Stepping:3 with MMX, SSE Integer, SSE FP, SSE2, SSE3,SSE4.1, SSE4.2, AVX, AVX2, HyperThreading

 

If after reviewing the above information, your CPU version isn't compatible with Photoshop 22.x. You should roll back to the previous version of Photoshop 21.2.4 and let us know if that helps.   Here's how you roll back to the previous version: https://helpx.adobe.com/download-install/using/install-previous-version.html

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

Doesn't work. Photoshop still won't open.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

It works fine with version 22.0, but after updating to 22.2 it stops working. I tried copying the DLLs again, but with no success. Does anyone know if there's a solution?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Hello,

 

I tried that, and then I got another error:

Johnny5F8F_0-1615581104699.png

The message says: Could not find an entry point to the procedure ?applyBorder...@IPP_TBB_GaussianBlur... at dynamic link library C:\Program Files\Adobe\Adobe Photoshop 2021\AdbePM.dll

 

Any clue?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Mine worked with 22.1.1, but now don't dare update to 22.2 unless someone can confirm it works.  Can you go back to 22.1.1 if it doesn't work, or is the only option to go all the way back to 21.2.6?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Confirmed your result for AdbePM.dll in 22.2.  Was able to roll back to 22.1.1 and still works.  I guess that's the last version we can use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2020 Oct 24, 2020

Copy link to clipboard

Copied

It works!!!

 

But it is really disappointing. According to Adobe, the two possible solutions were upgrading the system or going back to the previous PS version. Someone should be fired ...

 

Good luck to all, and happy editing.

 

Sebi

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2020 Oct 28, 2020

Copy link to clipboard

Copied

Here is the fix.

 

Despite what Adobe is saying officially, Photoshop 2021 does NOT require the support of SSE4.2 to run.
The real problem is that:
- IPP libraries optimized for SSE3 are missing from distribution (they are available from Intel)
- OpenCV library was build with SSE4.2 requirement
To fix this download this pack of libs from any source below (it's the same):
https://www113.zippyshare.com/v/cqtznzt2/file.html
https://www.sendspace.com/file/vh0wjm
Unpack archive and copy libs to Photoshop 2021 installation directory (overwrite opencv_world440.dll when requested).

This fixes the problem an PS runs just fine.
But disclaimer as usual - all this at your own risk.

 

Please note that this is not a hack or something like this - this is official libraries from official sources.
Intel IPP libraries was taken from Intel Parallels Studio XE 2020.1.0 and contains valid signature from Intel.
OpenCV library was taken from official release of OpenCV 4.4.0 on GitHUB (https://github.com/opencv/opencv, build by VC15).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 01, 2020 Nov 01, 2020

Copy link to clipboard

Copied

Thank you Shiju5EE9... even a 67 years old understood that... Everything works just fine now... 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines