Pen tool - when drawing a point that you curve on contact, pen often loses contact

New Here ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

I have a persistent issue since updating to 23.5 . I'll try and explain. When using the pen tool to draw bézier curves, the type that you drop the point and drag to curve on contact, the pen tool seems to lose contact draw a small curve and then abandon that task and drops another anchor point. It's not every time. But maybe as much as 10-20% of the time. So I then have to toggle the last 2 states to delete the points, and then hope it works as it should next time. It's getting a bit frustrating. Definitely seems to be since the update. Neither restarting Photoshop nor restarting my Mac fixes it.

 

My machine is MacBook Pro (14-inch, 2021) Apple M1 Pro. OS Monterey 12.5.1

I'm using a wireless mouse. 

TOPICS
macOS

Views

66

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Sep 06, 2022 Sep 06, 2022

Hi @cathb63865705 sorry to hear this.

 

Let's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder back. 

 

 

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply. 

...

Likes

Translate

Translate
Community Expert ,
Sep 05, 2022 Sep 05, 2022

Copy link to clipboard

Copied

I can not reproduce problem on Windows. Everything works fine for me. Wait for someone with Mac to check or try with preference reset what can solve strange problems sometimes Preferences in Photoshop (adobe.com)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 06, 2022 Sep 06, 2022

Copy link to clipboard

Copied

Hi @cathb63865705 sorry to hear this.

 

Let's make sure we're in a default state and there are no stale settings somewhere: 

Restore your preferences using this manual method:  

https://helpx.adobe.com/photoshop/using/preferences.html#Manually 

Does it work correctly? 

If that doesn't solve it, you can quit Photoshop and put the Settings folder back. 

 

 

It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply.  

 

Thank you,

-- Cory

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

OK thanks for responding Bojan.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

Thanks for responding @CoryShubert . I will try your Restore preferences tip. If that doesn't work I'll post my system info. 
Just to point out - today I noticed that when using the Rectangular Marquee tool, if I hesitate to release it for longer than a moment, it releases itself. (i.e. if I'm still holding the left mouse click down for longer than a moment, just while I decide if my selection is correct or not, it releases itself, causing me to have to make the selections again)
I have been monitoring if similar things happen in other apps. But they don't. If they did I would look into whether it's my mouse that's at fault. But all other Creative Cloud apps that I use and every other app, seem to work smoothly.

Anyway, just going to try restoring prefs and will let you know.

 

Thanks again for your help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

Thank you @cathb63865705 for that update

Curious if you have tried changing the springboard keyboard shortcuts time? By default it is set to 200ms which is what it has been for years so if that doesn't work for your workflow, increase the timing or uncheck that option so that spring-loaded keyboard shortcuts are disabled if that fits your workflow.

 

Thank you,

-- Cory

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

LATEST

Hi @CoryShubert 

I reset my preferences and that seemed to work. So thanks for that. I should have thought of that myself. But actually wondered if it was a bug with the latest update.

I haven't changed my springboard keyboard shortcuts time. I wasn't even aware of it and wouldn't know how to! Been using Creative Cloud apps (and Creative Suite and before) professionally for 25 years. I haven't needed to ditch my preference for a long time. But so  far seems to have worked. Now to rebuild my personalised workspace again. Unless you know of a way I can import my workspace. I still have the past 2 versions of Photoshop installed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines