Photoshop 2018 can't be set as default "open with" for any file type

Community Beginner ,
Nov 21, 2017 Nov 21, 2017

Copy link to clipboard

Copied

I installed CC 2018 yesterday. When I try to set Photoshop as default program to open JPG, PNG, etc., the program is not listed under Recommended Programs. When I choose Other Programs > Browse and navigate to PS 2018, select and hit open, nothing happens -- it's not added to the list of other programs.

If I go to Control Panel > Set Default Programs, NONE of the Adobe CC 2018 programs are available to select as default programs.

Please help!

Views

25.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 20, 2017 Dec 20, 2017

This issue might have resolved itself: after dragging the problem file types into Photoshop to open them, eventually Windows learned to associate Photoshop 2018. For example after dragging JPGs into Photoshop a few times, all of a sudden Photoshop appeared as a possible default program for JPGs. I guess this issue is resolved for me, sort of? Do you get the same results if you drag files in a few times?

Likes

Translate

Translate
Community Beginner ,
Oct 21, 2018 Oct 21, 2018

Copy link to clipboard

Copied

Yeah, this is the first time I've encountered this, and it's very aggravating. I don't think uninstalling the old versions would have helped in my case, since this is a freshly formatted OS install. Shame they haven't been able to iron this one out yet.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

I want to add my voice to this issue. Right now I can't associate PSD files with Photoshop 2019. Currently PS 2015 is the default program and clicking on Adobe Photoshop CC 2019 does nothing. I haven't yet tried altering the registry. I'll have to look into that later.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

When I updated to Photoshop 2019, the Creative Cloud app did not uninstall version 2018, so I was left with two versions of the program and no way to set Photoshop as a default program in Bridge or via Windows Explorer. I opened up the Creative Cloud app and uninstalled both versions of Photoshop. After re-installing Photoshop 2019, I was once again able to set it as my default program for image files. It would appear that the important thing is to uninstall all versions of the program before upgrading to a new version.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 23, 2018 Oct 23, 2018

Copy link to clipboard

Copied

This is being investigated by Adobe engineers now. In the meantime, try this: https://helpx.adobe.com/photoshop/kb/file-association-broken-psd-after-photoshop-cc-2015-on-windows....

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

Can also confirm that updating REG key - HKEY_CURRENT_USER\Software\Classes\.psd to "Photoshop.Image.20" worked for me finally. Original value was something like "Photoshop After Effects.16".. which was odd to have After Effects in there?!! Works now, another sucky fix!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 25, 2018 Oct 25, 2018

Copy link to clipboard

Copied

Unfortunately the solution given by the adobe document shown in the D Fosse post above didn't work. That registry key may have existed at that time, but it does not exist at this time (10/26/18).

However, the solution from chunkysteveo above did work. The entry was "Photoshop.Image.19". I simply changed it to "Photoshop.Image.20", then went back to settings | Apps |Default apps|Choose Default Apps By File Type .

I then scrolled down to .psd, and it then allowed me to select Adobe Photoshop 2019.

The user should not have to resort to registry editing at all in order to have the psd extension just work - in fact, for someone not familiar with the registry, there is a chance for a misstep. D Fosse said that this is being investigated by Adobe engineers now. Do we have to file a bug report in the feedback/family forum? From forum postings it seems that this problem has been going on for some time. In fact, I've used Win 10 for several years now - this is the first time I've had to resort to this to get a default file extension for a program to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

jeffreyh96105683  wrote

D Fosse said that this is being investigated by Adobe engineers now. Do we have to file a bug report in the feedback/family forum?

I got in touch with the Photoshop product manager through the back channel ACP section of the forum, so they know about the problem. That's how we got the updated help document.

What they may not know - if they haven't kept watching this and other threads subsequently - is that the registry edit doesn't work for everybody. That should definitely be brought to their attention, and the feedback site is the place to do it. I'd encourage everyone still affected to post there, and keep posting.

I'm not affected by this myself (at this time), so there are limits to my usefulness in the bug reports. It has much more weight coming from people who can report first hand experiences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

I'll add my .02c to this thread as well. Other than drinking heavily, here is my take as the IT guy for several adobe licenses.

The solution to this issue can be different for different users... because people use different products, and install/uninstall different apps, which ultimately create different registrations.

For example, if you use XD, you might find that .psd gets mapped to XD... or if you have older products, you might find that certain extensions get mapped to those older products. Here is what I think, and here is the best solution I can offer until Adobe and MicroSloth get their !@#$ together:  (use below with caution and see disclaimer at bottom)

First use Adobe Create Cloud to 'manage' (to right of product, click upside down carrot) your products keeping in mind that the last action taken usually takes precedence over the prior. So, for example, instead of simply updating photoshop. Uninstall the existing photoshop first, then install the new one (yes, you can keep your prefs). You may find that you will have to uninstall already upgraded products to get the order of installation right. For example, I had to uninstall XD 2019, then uninstall Photoshop 2019, then install XD again, and then PS again to get some mappings corrected.

This management using Creative Cloud won't always get it perfect.. and at this point, you need to get into regedit to fix remaining issues. The best thing I can tell you about this is to 2 things:

1.) Use the 'Find' feature in the Registry Editor

    With 'Computer' selected in the left pain, go to: 'Edit' > 'Find..'

2.) Use common sense.

For example, if you are looking at a file in Explorer and it says 'Photoshop.Image.19'.. you know that Explorer is trying to map that file to an older photoshop.. and you know that it should be .20 instead. In this case, use the find feature in regedit to find 'Photoshop.Image.19' and use some common sense to either change those instances, or add new ones to point to .20.

Same for other mappings.. note the 'Type' column in Explorer.

Disclaimer: I only mention these thoughts because it is a fix for this problem that Adobe needs to resolve. You can damage your system functionality in regedit.. so don't say I didn't warn you. Use regedit with caution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 26, 2018 Oct 26, 2018

Copy link to clipboard

Copied

I agree! We should definitely NOT have to go into the registry and edit to fix this problem especially when Dfosse mentioned it is an age old issue! C'mon Adobe!

But I could not disrupt my workflow any longer dealing with the problem and wanted any solution possible, just glad I was able to do it right, had people here that knew what they were talking about and it fixed the issue for me.

It should be something Adobe is looking to resolve for the next update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2018 Nov 21, 2018

Copy link to clipboard

Copied

Great thread, worked a treat!

As a new windows user, the following as previously mentioned was very helpful.

• Click windows key +R

• Enter- regedit

• Choose- HKEY_CURRENT_USER\Software\Classes\.psd

• Double click Default, change Photoshop.Image.19 to Photoshop.Image.20

• Go to settings | Apps |Default apps|Choose Default Apps By File Type .

• Scroll down to .psd, then select Adobe Photoshop 2019.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 29, 2018 Oct 29, 2018

Copy link to clipboard

Copied

For Photoshop CC 2019, my fix has been:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jpg\OpenWithProgids

Adding a binary value with "Photoshop.Image.20" as the name and leaving zero length data. I had to do this for each extension that didn't work and it works. TOTALLY [computer] GHETTO. Fix this, Adobe so that you can clean up our registry hacks to make this work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 30, 2018 Oct 30, 2018

Copy link to clipboard

Copied

Thanks!  All of the other regedit solutions I have tried didn't work...this one did.  Fantastic.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2018 Nov 03, 2018

Copy link to clipboard

Copied

Finally a solution. Also worked with the extension .png.

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 19, 2018 Nov 19, 2018

Copy link to clipboard

Copied

This advice from Nicolas works for me as well:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jp g\OpenWithProgids

Adding a binary value with "Photoshop.Image.20" as the name and leaving zero length data. I had to do this for each extension that didn't work and it works. TOTALLY [computer] GHETTO. Fix this, Adobe so that you can clean up our registry hacks to make this work.

--

I'm a developer but not in Windows and frankly I don't want to be my own tech support for Adobe or Windows products. I just want them to work so I can get on using the application I purchased instead of wasting time troubleshooting.

Thank you Nicholas. This makes sense as it's telling Windows Explorer itself what application to use for a given file type.

Really this is easily fixed by a couple of lines of code, I'm sure. Not sure where the blame lies.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2018 Nov 21, 2018

Copy link to clipboard

Copied

There are ways to go even deeper. For instance, if you're like me, the "Type" that was listed in detail view of a folder may show "Photoshop.Image.20." If that is what it shows for JPG and another type like PSD or PNG, when you try to sort by type it will lump them all together. Please note that big downside to editing the registry, besides possibly corrupting it, is that any future updates to Windows or Photoshop may not know to resolve the issue because you could be making changes to stuff it doesn't know to look for because it'll be custom.

If that's scary, and I can completely understand why, remember you can always backup your registry, which you should always do before making changes. Here is a simple way to sort by "Type" in this situation. Include "File extension" detail in your folder. Then you can sort by that. It adds another column, but it's at least registry independent and looks at the extension of the file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2018 Nov 21, 2018

Copy link to clipboard

Copied

I do not want to edit the registry I EXPECT Adobe to fix the problem at least between Bridge and Photoshop 2019. I pay for this I expect it to work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2018 Nov 21, 2018

Copy link to clipboard

Copied

Do you have Photo Mechanic by chance? It should let you choose the application and ignore Windows' default application(s).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 05, 2018 Dec 05, 2018

Copy link to clipboard

Copied

This worked for me!!!!!! Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 05, 2018 Dec 05, 2018

Copy link to clipboard

Copied

nicholash64048431  wrote

For Photoshop CC 2019, my fix has been:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jp g\OpenWithProgids

Adding a binary value with "Photoshop.Image.20" as the name and leaving zero length data. I had to do this for each extension that didn't work and it works. TOTALLY [computer] GHETTO. Fix this, Adobe so that you can clean up our registry hacks to make this work.

THANK YOU!!!!!!!!!!!!!!!!!!!

Literally everything else in this thread before your post did nothing for me. Windows 10 continually opened jpegs with Paint 3D and would not allow Photoshop as the default app.

My blood pressure is getting back to normal.

Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

Here is what worked for me. Go to a folder that has a PSD AND a jpg file. Mine show the PSD file as associated with PS and the JPG associated with windows Photos. Now, Right Click on the PSD file and go to the bottom and click the "Always use this App to open psd file" box. Then find the Photoshop CC version you use and select it. Photoshop will open the file. NEXT go the the JPG file and right click on it, Go to the bottom and check the "always use this app to open jpg file" box, Now go to Photoshop CC version you want and select it. The jpg file will open in photoshop.

NOW.....go to the Windows>Settings>APPS>Default Apps menu. You will now notice that the default app for photos is gray with a plus sign Says "Choose a Default" LEAVE IT ALONE,,,,you are done. Now test and let me know if this worked for anyone else. Good Luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2018 Dec 18, 2018

Copy link to clipboard

Copied

YES! In my case, I right clicked, chose "Open with" and then chose "Choose another app."

PS was in the list below the Microsoft default. The "Always open with box" was already checked. Rather than click "Okay", I just double clicked on "Adobe Photoshop".

It worked for JPGs an PNGs, The file icons had all changed to the PS icon!

Thank you, Mteetank!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

mteetank  wrote

Here is what worked for me. Go to a folder that has a PSD AND a jpg file. Mine show the PSD file as associated with PS and the JPG associated with windows Photos. Now, Right Click on the PSD file and go to the bottom and click the "Always use this App to open psd file" box. Then find the Photoshop CC version you use and select it. Photoshop will open the file. NEXT go the the JPG file and right click on it, Go to the bottom and check the "always use this app to open jpg file" box, Now go to Photoshop CC version you want and select it. The jpg file will open in photoshop.

NOW.....go to the Windows>Settings>APPS>Default Apps menu. You will now notice that the default app for photos is gray with a plus sign Says "Choose a Default" LEAVE IT ALONE,,,,you are done. Now test and let me know if this worked for anyone else. Good Luck!


As I mentioned, I tried every normal way of editing the default application (given earlier in this thread) that is available in Windows 10. I even tried the other fixes from this thread including Adobe's reinstallation and registry modification tips. Nothing worked.

For whatever reason Windows 10 simply wasn't allowing the use of PS 2019, even though it was available as an option in all of the various "change default application" locations.

When I attempted to change the association, in any of the usual ways that the OS allows (and following Adobe's registry editing steps), it simply would not take. It would continue to show as if no program was assigned to jpegs, pngs and a couple others. It would also continue to open Paint 3D instead of any version of Photoshop.

Adding the new binary to the registry is what finally worked for my system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2018 Dec 28, 2018

Copy link to clipboard

Copied

I can't find computer/hkey_current user  etc.  How do I get there?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2018 Nov 16, 2018

Copy link to clipboard

Copied

This was happening to me after updating to 2019. I right clicked a jpg, went to properties, and selected the .exe that way but it wouldn't change and it said "unknown application" was the default. But I also noticed that the window would freeze after doing this, so I used task manager to end the task. After that File Explorer went "not responding" so I restarted the app. As soon as it was finished, the image I had clicked opened in photoshop and it was now the default application. So, I guess try restarting File Explorer!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2018 Nov 17, 2018

Copy link to clipboard

Copied

I am having the same problem. CR2 files can be changed to default with Photoshop CC 2019 but JPGs, PNGs, etc can't.

I uninstalled Photoshop CC, Lightroom, and Creative Cloud all together and ran CCleaner to clean up everything. Shut down, restarted, reinstalled. Still gives me the same problems.

I don't have enough confidence in editing the registry so that's not an option, I had to reinstall Windows after the last time I tried that.

Any new answers?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines