Photoshop 23.4.1 switching tools randomly doesn’t work [Mac 12.4]

Participant ,
Jul 07, 2022 Jul 07, 2022

Copy link to clipboard

Copied

Since updating to 23.4.1 this morning now my tools will randomly not switch using the keyboard shortcut. Like if I have the Marque tool active, and then press S for the Clone tool it will switch, then immediately switch back to the Marque tool. Sometimes it will happen 30+ times in a row, sometimes just once, sometimes not at all, and happens with any tool combo. Manually selecting the tool in the tool bar with the mouse cursor still works normally.

 

Things I’ve tried:
-A fresh computer restart and opening just Photoshop
-Turning off Use Graphics Processor
-Turning off Multithreaded compositing

 

Photoshop 23.4.1
macOS 12.4
Mac Pro 6.1

TOPICS
macOS

Views

49

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Jul 15, 2022 Jul 15, 2022

After doing more research here it turns out it was the spring-loaded tool feature that was causing it. Turning that off and everything is back to normal. It never happened before 23.4.1 which is lucky I guess but at least it can be disabled, which is what the default should be in my opinion.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 08, 2022 Jul 08, 2022

Copy link to clipboard

Copied

You might try resetting Photoshop's preferences:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 15, 2022 Jul 15, 2022

Copy link to clipboard

Copied

LATEST

After doing more research here it turns out it was the spring-loaded tool feature that was causing it. Turning that off and everything is back to normal. It never happened before 23.4.1 which is lucky I guess but at least it can be disabled, which is what the default should be in my opinion.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines