• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Photoshop causing monitor to switch on/off

New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Whenever I perform an action within photoshop (scrolling, clicking etc.) it is causing my monitor to quickly turn off and on (as if the display is switching when you apply physical settings).

 

It has never done this before.

 

Has anyone encountered this before?

TOPICS
Windows

Views

1.4K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Sep 30, 2021 Sep 30, 2021

I am having the exact same problem. Is your main monitor a g-sync monitor? I have heard Adobe software doesn't behave well with g-sync. I tried disabling it in the nvidia control panel but now my monitor screen turns off everytime I click or use the brush tool like you described.

Votes

Translate

Translate
Community Expert ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Hi

What exact version of Photoshop and operating system are you using, sounds like it could be an issue with your GPU driver.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

Version 22.5

I also thought this, but all my drivers are up to date - this is not occuring with any other Adobe product.

 

Graphics card: nVidia 3080

CPU: AMD Ryzen 5900x

Ram: 32GB 3600mhz

Monitor: Dell S2721DGF

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I will also add this seem to only occur on my Main Monitor (listed in my other reply).

 

If I move the program to my second monitor this doesn't occur (however it is older, hence why it is not the main monitor)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

I have dual monitors connected to a RTX2060 super and I'm not experiencing issues with Photoshop on either monitor, are both you monitors connected to the RTX3080 GPU, do you have an onboard Intel GPU as well.

Do you use the Game Ready or Studio driver from Nvidia, Adobe recommend the Studio.

Try going through the GPU troubleshooting steps here

https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 01, 2021 Sep 01, 2021

Copy link to clipboard

Copied

https://helpx.adobe.com/photoshop/kb/troubleshoot-gpu-graphics-card.html

 

See step 7 in the link above for "Configuring computers with multiple graphics cards."

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 30, 2021 Sep 30, 2021

Copy link to clipboard

Copied

I am having the exact same problem. Is your main monitor a g-sync monitor? I have heard Adobe software doesn't behave well with g-sync. I tried disabling it in the nvidia control panel but now my monitor screen turns off everytime I click or use the brush tool like you described.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 24, 2023 Jan 24, 2023

Copy link to clipboard

Copied

same thing happend with 2 time while working with artificial intelegene depth blur option.  monitor will go off suddnely.  than i could't able to shut down my pc cause i cant able to see my  monitor. so forcefully i shut down through power button . so this was the issue. i had face 

 

 

graphic card was 1060ti nvidea g force  and minitor was benq 28 inch .

 

 

please anybody help with this...................

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2023 Jan 25, 2023

Copy link to clipboard

Copied

I did eventually find a 'temporary' fix for this issue. On the monitor I had to physically turn of G-SYNC/Freesync. I tried changing setting for it only to turn off when using Adobe programs, but this never worked, I always had use the physical monitor settings and turn it off. This stopped all issues.

 

Not ideal, but I have found no other way to fix this on a permenant basis.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 25, 2023 Jan 25, 2023

Copy link to clipboard

Copied

Thank you , @RonnieH1990 for the advice!  indeed, freesync does not play nice with photoshop, it's a good path to investigate.

Also, some report that the December release of the nVidia drivers caused issues, the 528.24 studio version just release lists a fix. Others recommend a rollback to the November drivers.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 25, 2023 Jan 25, 2023

Copy link to clipboard

Copied

I had the same issue. Disabling G-sync completely fixed the issue. Rolling back drivers did nothing.
Something to note is that this didn't happen in my other G-sync monitor. My main monitor here this occurred is a Samsung Odyssey Neo G7 witch has AMD Freesync and is not G-sync verified. My other monitor is an HP 25mx witch has AMD Freesync but is listed as G-sync compatible.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 08, 2023 Feb 08, 2023

Copy link to clipboard

Copied

LATEST

THANK YOU

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines