Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop CC 2020 extremly slow - no solution in sight

Community Beginner ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

I am browisng and applying all solutions since few days and trying to adjust the system but this is beyond "settings" and since "Legacy compositing" has been disabled we are all sitting ducs now.  Please provide an actual solution since this is the most ridiclous subscription I have ever signed up for. On same machine C6 blows 2020 out of the water in startup and reacton time.  CC should be able to handle anything with the assigned RAM and GPU power:

 

themezly_2-1607394572112.png

 

I see many users asking for 2020 fix where others keep on refering to 2019 issues for exmaple https://community.adobe.com/t5/photoshop/photoshop-cc-2020-slow-loading-layers/td-p/10735032?page=1

 

With this system CC 2020 should fly:

 

themezly_1-1607394540816.png

 

By simply trying to move a layer up by holding shift + arrow or drawing a shape takes forever to render. 

Here is real time video, note that mouse movemant is real but the system reaction makes you think is slowmotion.


Moving layer:
https://monosnap.com/file/g2FBuXoOA7aj8cMirWKBFTWbEPFrks

Creating simple shape: 

https://monosnap.com/file/7bLKt4vdeUuG2hwjKi09ihbD1v9rY7 

 

TOPICS
Crash or freeze, Performance

Views

582

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

Had same issues. Turned out its becouse of G-SYNC problems with Adobe software. If you are using any freesync or gsync feature try to disable it. Not sure if its related with your problem but I have to share this here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2021 Mar 25, 2021

Copy link to clipboard

Copied

I'm having the same problem and a lot of brush lag. It's unbearable, I havn't been able to get any work done all week and have tried updating and uninstalling several versions of photoshop with no improvement. Might have to go back to CS6! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Yeah, same here, every simple action in photoshop takes way too much time.

 

Changing tab 5-50sec

Clicking on another layer - same

Scaling - same

Importing some small jpgs into another document sometimes causes system crash or black screen

 

I'm moving to previous version for now, this is unusable.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

@Tomasz5E36 if you are using Photoshop 22.x, I might split this thread as it might not be related to the problems of the previous version. Can you please post a txt file with the contents of Photoshop's Help>System Info... menu, so that we get to know your OS, its version, the exact version of Photoshop you are running, the date of the GPU driver, etc.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Sure, here are my specs.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

Have you tried running with default preferences? There's a few non-standard settings in there. Try restoring your preferences using this manual method so you can put them back if it's not the problem:

https://helpx.adobe.com/photoshop/using/preferences.html#Manually

 

Do you have any anti-virus, or cloud back up software running in the background?


Senior Product Manager - Customer Advocacy - Digital Imaging

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

I already tried all known methods to try to fix it. Nothing works.

 

This is something with buffering or not clearing caches in photoshop.

 

Example:

My work is mainly creating online banners.

When I create new document everything runs smoothly.

When reusing some of the templates I created before it is like above.

I can't create new template with 6 new set of banners every time, I got about 40 banners daily to do.

Reusing recent set with specific sizes into new set helps to save time, but now it is the opposite.

Today I tried to do my work - 2 documents with 6 small mockups (resizing web banners into different sizes), every banner has maximum 10 layers. Moving layers, scaling, saving, switching between 2 tabs takes ridiculously long time. It should be done in one hour, now takes 3. 

 

Like almost every action I make takes a minute or even more.

Older versions of photoshop didn't have these problems.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

quote

When reusing some of the templates I created before it is like above.

I can't create new template with 6 new set of banners every time, I got about 40 banners daily to do.

Reusing recent set with specific sizes into new set helps to save time, but now it is the opposite.


By @Tomasz5E36

Do you have an issue only with templates created in an older version of Ps?

Do they use linked smart objects?

Did you try recreating one template in the current version, then to reuse it? (even if I do not remember changes in the Psd format...)

Did you already try to work with stock preferences, as asked?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Yes, I reset the preferences. 

No linked smarts. Embedded objects/bitmap - doesn't matter, same behaviour.

New template is fast only when it's empty, but even then it can be 250Mb (1920x1080px 8bit 72ppi, no layers). Compression of Psd files is enabled, when disabled it takes twice as much (new empty document).

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Jeff, I also noticed that Ps is installed in a different drive than the OS, just in case it might be why others do not see the same issue. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

I reinstalled Photoshop, Illustrator and Indesign on a faster M.2 ssd just yesterday to check if it will change anything. Behaviours still occur. Only on Photoshop, other Adobe and non Adobe software works great on OS and nonOS drive. OS drive is standard SSD.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Sorry for the hassle, I'm trying to cover all bases.

Where do you see a size of 250MB, when saved on disk? it is well px and not in?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

No worries, just needs a way to fix it.

 

Yes, file saved on disk. We are working only on online banners, so always pixels.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

Little update: 

When new template is created and new objects are copied inside, everything is blazing fast, but if any object (rasterized or not) is dragged/copied from another/older template problem with giga lag occur and new template gets "infected" by it 🙂

Maybe something with the clipboard or excessive information copied from older layers? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

Hello, I found this thread that deals about bloated files due to ancestor metadata...

I think you should try the suggestions: https://community.adobe.com/t5/photoshop-ecosystem-discussions/inflated-jpg-file-size-photoshop-docu...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 17, 2021 Sep 17, 2021

Copy link to clipboard

Copied

I've seen this before but didn't have time to check if it works yet.

 

To be honest, shouln't this happen automaticaly when starting new project (or option inside the photoshop)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2021 Oct 23, 2021

Copy link to clipboard

Copied

LATEST

I'm new to Photoshop (just 10h work on it) and I noticed how inconsistent the performance between different machines is (despite somewhat similar hardware). Importing layers from lightroom to Fotoshop is insanely slow, I can understand that is obvious for my 6y old dual core ultrabook to take 7s per layer, but I can't understand how also a new ultrabook (i7 4/8 16gb ram) and my desktop i7 7700k 16gb ram and gtx 1070 both take the same time. It does not matter the storage because the difference between internal SSD and slow external HDD NAS is non existent! 

I tried to load 10 layers but does not help. I'm now waiting for my 900 layers to load and I hope it won't crash again once I align them (like the last 2 times)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines