• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Photoshop CC keeps changing Scratch Disks when closed

New Here ,
Mar 17, 2020 Mar 17, 2020

Copy link to clipboard

Copied

Basically, I have a C Drive and a D Drive, I'd prefer if PS uses the D Drive; I boot it up in Admin mode, disable the C Drive Disk and Enable the D Drive Disk (moved it to the top as well,) but when I close and reopen the app later, the C Drive is the active Disk once more, resulting in constant Scratch Disk Full errors.

 

Thanks for any help in advance!

Views

336

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 17, 2020 Mar 17, 2020

Copy link to clipboard

Copied

Is the D drive a external drive?

 

I personally have never had PS change the scratch disk unless the drive I assigned went missing somehow. IE got disconnected.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2020 Mar 19, 2020

Copy link to clipboard

Copied

Nope, both my drives are internal. The C Drive is where my OS is stored so I know why it's defaulting there on startup but changing drives would be ideal. The D Drive's is a supported format so it should work, and I can select it after startup, in Admin Mode but constantly changing it every time is an ordeal.

I should also note that I'm on Windows 10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2020 Mar 19, 2020

Copy link to clipboard

Copied

I should also add that when launched regularly (no Admin,) the D Drive isn't even listed and the C Drive is disabled, and when I launch in Admin, the D Drive is correctly set.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2020 Mar 25, 2020

Copy link to clipboard

Copied

Bump, still not fixed and support hasn't been much help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 25, 2020 Mar 25, 2020

Copy link to clipboard

Copied

The only time I have sen the scratch disk change is when the select drive becomes Not Available.

 

So IMHO your problem is being caused by PS not seeing the drive you have selected as the main scratch disk.

Why that is happening I have no idea. That is why I asked if your D drive was an External drive.

 

There also might be a setting in Windows to put drives to sleep to save energy, power. IIRC that setting is in the Power options.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2022 Dec 28, 2022

Copy link to clipboard

Copied

Happens to me regularly as well. Been happening for years across different versions of the software. Mine is pretty random though, and doesn't just happen every shutdown.

 

Wish I could help you, but chalk it up to  "it's just another weird Adobe glitch".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 28, 2022 Dec 28, 2022

Copy link to clipboard

Copied

LATEST

Its most likely due to making the change while in Admin mode then reopening the software not in Admin mode. Permissions to the specific location may be restricted forcing PS to change the Scratch Disk.

Go to:

Photoshop.exe > Properties > Compatibility > Change Settings for all users > Check 'Run this program as an administrator' and then set your scratch disk. Quit and reopen and see if it holds.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines