• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Photoshop Changing Colors On Export (NOT a color profile issue)

Community Beginner ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Greetings,

I'm using Photoshop CC 2019 to create a digital painting. Everytime I go to export (as JPEG), the color of the pixels on one of my layers changes to a bright yellow-ish color (I can see this in the preview, AND in the exported JPEG file). I did some experimenting, and hid the problematic layer, but the problem shifted to the layer below it upon export.

Possibly noteworthy info:

1. The layer in question was originally created using the pen tool, rasterized, command clicked (to select all pixels on that layer), then colored an alternate shade of blue.

2. The file is using CMYK color profile, and I'm exporting to sRGB color space...but I've never had an issue like this in the past...especially not the DRASTIC change in color display.

 

Here is what's going on, below:

Image 1: Original (as seen in PS).

Image 2: Export preview with "wave edge" layer turning yellow-ish.

Image 3: Hidden "wave edge" layer causes layer below (bubble outlines) to produce the same issue on THAT layer.

ORIGINAL IMAGE IN PSORIGINAL IMAGE IN PSEXPORT PREVIEW W/ YELLOW-ISH LINE ON WAVE EDGEEXPORT PREVIEW W/ YELLOW-ISH LINE ON WAVE EDGEHIDDEN WAVE EDGE LAYER CAUSES BUBBLE OUTLINES TO THEN CHANGE COLORS (this layer is below previous layer)HIDDEN WAVE EDGE LAYER CAUSES BUBBLE OUTLINES TO THEN CHANGE COLORS (this layer is below previous layer)

Any help would be greatly appreciated. Thanks in advance!

Views

3.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

This is weird. I would create a copy, convert to sRGB before you try and export. Try a Save as instead of export - why are you using export instead of save as?


Melissa Piccone | Adobe Trainer | Pluralsight Author | Fine Artist

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2020 May 14, 2020

Copy link to clipboard

Copied

Hi Melissa,

Converting to sRGB would flatten the image. This would certainly fix the issue, but I wouldn't be able to continue work on the progect with all the layers merged. I can create a copy to get around the issue, but that would take up space on my HD.
I'm not using the "save as" function, because I want to be able to use the controls within the export dialog window when creating the file.

It's worth noting that I'm using CMYK in the event that I create prints

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

Try to check "Legacy Compositing" in Preferences. This is apparently something with the layer compositing.

 

Another thing is that you should check "Embed Color Profile" in the Export dialog. That's why Exort and Photoshop doesn't match in overall appearance, note the blue color change.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 14, 2020 May 14, 2020

Copy link to clipboard

Copied

Hiya,

 

Thanks for the tips/s. I wasn't able to locate the "Legacy Compositing" check in the preferences panel...what sub-menu is it located in?

When checking the "Embed Color Profile", the issue remains.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 15, 2020 May 15, 2020

Copy link to clipboard

Copied

It's under Preferences > Performance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 15, 2020 May 15, 2020

Copy link to clipboard

Copied

Thanks for the direction. It looks like this still didn't fix the issue.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 07, 2020 May 07, 2020

Copy link to clipboard

Copied

Hi

are you flattening the image before exporting?

 

why 'export' when you can take more control this way 1: convert to sRGB 2: save as?

 

and yes, always embed the ICC profile when save or export. otherwise it will be an ICC profile issue.

 

I hope this helps

if so, please "like" my reply and if you're OK now, please mark it as "correct", so that others who have similar issues can see the solution

thanks

neil barstow, colourmanagement.net :: adobe forum volunteer

[please do not use the reply button on a message in the thread, only use the one at the top of the page, to maintain chronological order]

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 07, 2020 May 07, 2020

Copy link to clipboard

Copied

Flattening before Export shouldn't be necessary; if it is, there's a problem in layer compositing. That's why Legacy Compositing might be a way to get around it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 14, 2022 Nov 14, 2022

Copy link to clipboard

Copied

LATEST

Propably you already found a solution by now, but if you had some effect layer above the others without a clipping mask. you need to had the clipping mask.

Even if you have a layer with all the background filled, any effect layer (with the visibility active) above that one that isn't with a clipping mask will affect all layers beneath, on the Export As function.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines