Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop color picker suddenly isn't working

New Here ,
Jun 18, 2016 Jun 18, 2016

Copy link to clipboard

Copied

Hi,

I never had this problem before. I've been working on a project in Photoshop and for some reason, it is now only working in grayscale. When I used the color picker to change color, it doesn't work.  I know remember doing anything different to cause it to work only in grayscale, but I can't seem to figure out how to switch it back to color mode and I'm in the middle of an important project. Does anyone know how to solve this problem?

Penny Jones

pbjart2@gmail.com

TOPICS
How to

Views

42.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 18, 2016 Jun 18, 2016
Look at the Document tab at the top. RGB/8 should be the norm.  If you somehow tapped "q" on your keyboard, then it would read"Quickmask/8" and the color picker would not select a color. Tap q again to get it back to RGB.Always check the Document tab, it will clue you into what you have selected. It would read "Layer 0, Layer Mask/8" if you selected a layer mask.Finally you may have selected a Color Channel and it would read Layer 0,Blue/8.  Cmd/Ctrl 2 can get you back to RGB.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 18, 2016 Jun 18, 2016

Copy link to clipboard

Copied

Check the your Editing in a Color mode like RGB and you are targeting a layer not a grayscale layer mask.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2016 Jun 18, 2016

Copy link to clipboard

Copied

Sounds like a layer mask is active in the Layers panel. Click the image thumbnail to shift focus from the mask thumbnail.

Or are you in Quick mask mode? Press Q to exit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2016 Jun 18, 2016

Copy link to clipboard

Copied

Look at the Document tab at the top. RGB/8 should be the norm.  If you somehow tapped "q" on your keyboard, then it would read

"Quickmask/8" and the color picker would not select a color. Tap q again to get it back to RGB.

Always check the Document tab, it will clue you into what you have selected. It would read "Layer 0, Layer Mask/8" if you selected a layer mask.

Finally you may have selected a Color Channel and it would read Layer 0,Blue/8.  Cmd/Ctrl 2 can get you back to RGB.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2020 Feb 02, 2020

Copy link to clipboard

Copied

No such comands in Version 2020

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 06, 2020 Jul 06, 2020

Copy link to clipboard

Copied

why it becomes basic like the paint that comes with windows ??

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 08, 2020 Jul 08, 2020

Copy link to clipboard

Copied

Under Edit > Preferences > General, choose the Adobe Color Picker instead of the Microsoft color picker. Sorry, I'm using a Mac, but same idea.

Screen Shot 2020-07-08 at 12.51.48 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

I just now, really just now, experienced the same problem on my Windows laptop. Never happened before. So when I checked th Preferences > General,vit was set to Adobe. Okay, I changed it to Windows and . . . and it now is working. Go figure, if it breaks again I follow the advice and not be the bull in the china shop. Good Luck! 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

Let me please add to what I wrote above, it worked one time and now is broken. I need the Good Luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

I'm having this issue as well.  It's also affecting the Hardness/Softness indicator on the brush tool and anything else that would have the indicator.  2020-12-09_0-00-25.jpg2020-12-09_0-00-25_2.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 16, 2020 Dec 16, 2020

Copy link to clipboard

Copied

maybe you can check your layer point sample, make sure that sample is "All Layers". i can resolve it with this

endro0D45_1-1608171134091.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 19, 2021 Mar 19, 2021

Copy link to clipboard

Copied

I just had a similar issue and the problem was indeed the sample size that changed from point sample (the color picker will take the color of the single targetted pixel) to 31x31 average, making the picked color an average of the targetted 31x31 pixels area. Changing it back to point sample solved the problem, however I don't know why it suddenly changed, I guess I must have hit the wrong keyboard shortcut

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2021 May 21, 2021

Copy link to clipboard

Copied

This was my issue. I was losing my mind trying to figure out the issue. Not sure how I changed the sample size, but so thankful for your response being the answer! 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 13, 2021 Aug 13, 2021

Copy link to clipboard

Copied

LATEST

Thank you somuch, this worked!!!!!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 04, 2021 Jul 04, 2021

Copy link to clipboard

Copied

Please select the colour code to RGB while opening a new document,  I had the same issue and then tried opening a new document and found that The colour code was in Greyscale. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines