Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop Lighting Effects not working on many small selections, like text. macOS

New Here ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

In the latest version of Adobe Photoshop on macOS, I've noticed that I cannot use Lighting Effects on small selections, like rasterized layers with text. This is obviously a little more than just a minor annoyance, as lighting effects on text is so commonly used for 3D like styles and effects. After selecting a few words with magic wand, or however you prefer to select, opening the Lighting Tools will cause the application to essentially crash, though zooming in and out make the slider bars resize, so it seems like it's partially responding? I have no idea. Anyways, the only way to fix this is to use hot keys to save your work, exit, and hope nothing got lost. 


On layers with only one large object, or just selecting All, there is no problem.

 

Here are my deatils:

22.5.1 Release

macOS Big Sur - 11.6

32GB RAM, i9, Plenty fast enough for this operation. 

 

TOPICS
macOS

Views

17

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 09, 2021 Oct 09, 2021

Copy link to clipboard

Copied

As I've read more threads with this similar issue, it appears like Adobe's answer is to just stop making 3D functions which is really pretty funny!

Customers: "You have a problem with your code."

Engineers: "We have a problem with our code."

Management: "Let's get rid of the code."

GIMP Team: "lol"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

LATEST

Go to preferences > Technology Previews... and check "Disable Native Canvas" - then restart Photoshop. Does the problem still occur?


Senior Product Manager - Customer Advocacy - Digital Imaging

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines