Photoshop (regardless of version) lags only when more than 1 tab is open.

Community Beginner ,
Aug 08, 2022 Aug 08, 2022

Copy link to clipboard

Copied

Hello,

I am having the below problem in both Photoshop 2020 (v 21.2.12) and Photoshop 2022 (v 23.4.2). I am working on a 1440p monitor with a high refresh rate.

I often need more than 1 tab open in Photoshop as part of my workflow. When I have just 1 tab open, there is no lag. However, when I have 2 or more tabs open, Photoshop lags substantially. The documents I am working on are not huge; they're only 2000 pixels by 2000 pixels or so. Sometimes, the lag will subside entirely, and I can work smoothly again, without the need to close any tabs, but this is quite rare. Sometimes, the lag will persist for a while even after closing one of the two tabs.

Here is what I have already attempted in order to solve the problem:

  • Brush smoothing has been reduced to 0%.
  • I have tried resetting my preferences on exit.
  • I have deleted all of my custom brushes.
  • I am allowing Photoshop to use 69% of my RAM. Cache Levels are at 4 and Cache tile size is 1028K.
  • I have Use Graphics Processor checked.
  • Under Advanced Graphics Processor Settings, I have tried having drawing mode set to both Basic and Advanced. I have Use Graphics Processor to Accelerate Computation, Use OpenCL, and 30 Bit Display all checked, but I have also tried having these all unchecked. I have Anti-Alias Guides and Paths unchecked, but I've also tried having this checked.

I suspect this lag issue might have something to do with my Edit > Color Settings, but I'm not sure what they should be.

I have an 11th Gen Intel Processor, an RTX 3090 and 64GB of RAM. When Photoshop is lagging, my CPU and RAM consumption is barely affected, so my PC is not the bottleneck here.

Can anyone offer any advice?

TOPICS
Windows

Views

83

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Sep 16, 2022 Sep 16, 2022

I have at last found a solution. After some googling for similar (but not identical) issues, I found that it was caused by NVIDIA G-Sync. Go to the NVIDIA Control Panel > Manage 3D Settings and ensure that G-Sync is set to FULL SCREEN applications ONLY. If G-Sync is permitted for use with windowed applications, it absolutely destroys Photoshop's performance. Note that I have not noticed G-Sync cause an issue with any other windowed application.

Likes

Translate

Translate
Community Expert ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

Can you go to Photoshop Help menu/System Info and copy/paste the details here?

Kevin Stohlmeyer
Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

(System information removed as requested)

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

Hi Kevin, unfortunately, my response keeps getting erased somehow. So, I can't post it here. I could post a link to a notepad document or something that contains the information you need. Perhaps the message is also too long? Do you have any suggestions as to how I can share this information?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

Save the information as a text file and attach it to your response.

Kevin Stohlmeyer
Adobe Community Professional/Adobe Certified Instructor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

Oh I overlooked that we can attach files. It is now attached to this response. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 09, 2022 Aug 09, 2022

Copy link to clipboard

Copied

It seems similar to issue that I have experienced on 1440 monitor when opening 4 or more files https://community.adobe.com/t5/photoshop-ecosystem-bugs/crashes-when-opening-webp-format/idi-p/13111...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

I am using a 1440p monitor too, yeah. However, I didn't used to have this problem; I've been using 1440p monitors for about 4 years now and I've only recently started to have this issue I think? 

Does anyone have any ideas for this?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2022 Aug 23, 2022

Copy link to clipboard

Copied

This issue is still present. It's debatably even worse than before; the first document Photoshop 2022 opens takes about 25-30 seconds to open, even if it's a completely new canvas.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 16, 2022 Sep 16, 2022

Copy link to clipboard

Copied

LATEST

I have at last found a solution. After some googling for similar (but not identical) issues, I found that it was caused by NVIDIA G-Sync. Go to the NVIDIA Control Panel > Manage 3D Settings and ensure that G-Sync is set to FULL SCREEN applications ONLY. If G-Sync is permitted for use with windowed applications, it absolutely destroys Photoshop's performance. Note that I have not noticed G-Sync cause an issue with any other windowed application.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines