Photoshop Select Subject not working with M1 Pro Chip

New Here ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

Recently, I changed computers to the Mac M1 with Monterey,

Normally when I click select subject, it is nearly perfect, The I hit the button for select and mask, the red mask. shows up and I hit enter and I have a layer mask ready to work.

 

Now today the select subject is not even close and when I hit select and mask there is no Layer Mask.

Is this a Photoshop / Monetrey issue?   How ever it was working properly yesterday.

 

Can anyone help

 

 

 

 

{Title edited by Moderator}

TOPICS
macOS

Views

27

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

LATEST

Hi there,

 

Thanks for reaching out.

What is your Photoshop version? What happens when you try to use the 'select subject' option? Do you see any error messages? 

Please try disabling OpenCL but leave GPU preference on. If this doesn't help, try running Photoshop with  Rosetta emulation mode. Have you tried that option? If not, please try using Rosetta.

To learn how to run Photoshop in Rosetta, see About Rosetta.

 

 

NOTE: When you upgraded, did you do a fresh installation of Photoshop, or did you use Migration Assistant to bring over Photoshop from your old Intel-based Mac? I ask because if Migration Assistant was used, Photoshop might not contain the right code for Apple Silicon. If unsure, try uninstalling and reinstalling Photoshop to ensure that your new M1 Pro has the right code for Apple Silicon.

 

Let us know if that makes any difference.

Regards,

Ranjisha

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines