Photoshop Tools Glitches/ flickers/ fights each other

Explorer ,
Jul 23, 2022 Jul 23, 2022

Copy link to clipboard

Copied

Hi,

 

Reporting a Bug in Adobe Photoshop CC 23.

 

No clue if anyone has experience this. When working on a file. The tools in Photoshop gets stuck. Example Hand tool, Move Tool, brush tool, Zoom tool etc... all tools. When working on a file switching between tools, after awhile. Photoshop tool gets locked. You press the shortcuts for your tool you need, and the tool will not release/ change to the correct tool. It glitches/ flickers to the tool, and goes back to the tool you had: example. I have my Ziom Tool or Hand Tool selected, and want to my brush. I press the shortcuts "B". The tool starts fighting/ software glitch, and goes back to the previous tool I am using. I have to manually move my curse to select the tool I need. This does not allow the program to fix it self. I have to exit Photoshop click on the desktop all the time, or quit out Photoshop. Photoshop CC 22 does not do this. Does anyone have a fox for this? I am on a MAC Pro desktop computer running the Latest OS! I heard this issue even happens to PC users as well.

TOPICS
macOS , Windows

Views

103

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Aug 25, 2022 Aug 25, 2022

Hello,

 

Thank you for that fix. Mine was Checked. I unchecked the Spring-Loaded Tool Shortcuts. It seems to be working better now. But I also, had a talented I.T. friend that told me to also adjust my System Preferences: which has help with other Apps on my Mac as well.  

  1. Open Accessibility settings. Open System Preferences and click on Accessibility.
  2. Access Cursor settings. Select Display in the sidebar and then select the Cursor tab. ... 
  3. Disable the giant cursor. Uncheck the Shake mouse pointer t
...

Likes

Translate

Translate
Adobe Employee ,
Jul 25, 2022 Jul 25, 2022

Copy link to clipboard

Copied

Hi @Joe Casillas, curious if you have tried changing the springboard keyboard shortcuts time? By default it is set to 200ms which is what it has been for years so if that doesn't work for your workflow, increase the timing or uncheck that option so that spring-loaded keyboard shortcuts are disabled if that fits your workflow.

 

Thank you,

-- Cory

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Hi Cory,

 

That did not help. It is still doing the same glitches/ flickers between tools. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 26, 2022 Jul 26, 2022

Copy link to clipboard

Copied

Sorry that didn't fix it @Joe Casillas It may help if we could see your Photoshop System Info. Launch Photoshop, and select Help >System Info...and copy/paste the text in a reply.  

 

Thank you,

-- Cory

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

Go to preferences, tools and uncheck spring-loaded tool shortcuts.Screen Shot 2022-08-25 at 1.33.57 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 25, 2022 Aug 25, 2022

Copy link to clipboard

Copied

LATEST

Hello,

 

Thank you for that fix. Mine was Checked. I unchecked the Spring-Loaded Tool Shortcuts. It seems to be working better now. But I also, had a talented I.T. friend that told me to also adjust my System Preferences: which has help with other Apps on my Mac as well.  

  1. Open Accessibility settings. Open System Preferences and click on Accessibility.
  2. Access Cursor settings. Select Display in the sidebar and then select the Cursor tab. ... 
  3. Disable the giant cursor. Uncheck the Shake mouse pointer to locate checkbox to prevent the cursor from getting bigger when you shake your mouse.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines