Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Photoshop v21 does not save in Original location when using actions

Community Beginner ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

If I open an image in PS v21 and resave it as a different file format ie. Tiff or PSD Photoshop will remember the location of the original file so I can quickly save a copy to the same folder but when I process a lot of images using an action with a SAVE AS menu item it does not remember the files original location instead it tries to save to the last location I last saved a file to. PSv20 and all the others before worked fine, has anyone else experienced the same issue? 

TOPICS
Actions and scripting, Bug, Mac, Performance, Problem or error

Views

385

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

Can you expand Save step in action and post screenshot? 

How you have recorded Save step, using Insert Menu Item or by clicking on Save As and navigating to location then saving during record process? If you used later then you have problem because saving location is hard coded.

Do you have Preferences > File Handling > Save As to Original Folder turned on?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

Hi Bojan, 

I have added the Save step in the action as 'Insert Menu Item', this same action worked as intended in previous versions of Photoshop. 

I do have Save As to Original Folder turned on the Preferences, that was my first check when I upgraded and discovered the annoying issue. 

 

Screenshot 2020-02-04 at 16.53.12.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

I have tested using File > Automate > Batch and everything works fine. Which script you are using to batch process images?
Have you tried to reset preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

I dont use the Automate function, I just run the action on each image that is open by pressing the play button. Resetting the preferences has made no difference. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

Everything works fine with open files on my side. I am on Win running latest Photoshop 21.0.3.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2020 Feb 05, 2020

Copy link to clipboard

Copied

I am running 21.0.3 too, I will reinstalling it and see if that resolves the problem. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2020 Feb 05, 2020

Copy link to clipboard

Copied

I have reinstalled Photoshop and can confirm it still does not remember the original location of a file when I use an action with a menu item to resave it, it just trys to save to the last saved location. I have tried creating a new action to see if there was a problem with the original action and the new action does exactly the same. 

 

I can confirm if I open a JPEG and do a manual Save As, this remembers the original location of the file, so why does this not work when running an action? Any ideas would be welcome.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

I have this problem in the latest version of photoshop (I recently updated for the first time in a couple of years). Did you ever find a solution? It's very annoying, files keep getting saved in the wrong location and I don't realize it until after the fact and have to move them back to the correct folder.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Hi Tim, 

 

Unfortunately I haven't been able to resolve this, I've learnt to live with it which is very annoying and slows down my workflow considerably. 

 

I've just tried Kukurykus's suggestion and that doesn't work, as what he is suggesting will always save the files to that particular folder, this needs to be done with a Menu Item. 

 

Inserting SAVE AS as a Menu Item within an action Photoshop now does not remember the original image location, it remembers the last place I saved another image too. Wonder if anyone else has any suggestions????

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

Create document, start recording, save the file without assigning name, stop recording, close document.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Hi Kukurykus, 

I've just tried your suggestion and that doesn't work, what you are suggesting will always save the files to that particular folder, what we are looking for is the images to be saved to their original location, not a new folder somewhere else. Hence why its done using a menu item within the action. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

I misread your issue. Maybe try the solution from: SaveAs script not working after update 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

Thank you for another suggestion, I was hopeful this would be the answer, but unfortunately its hasn't worked. 

Looks like I'm just going to have to live with it. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

LATEST

Maybe there's something we don't see. Record short video of your doings...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Please watch this video and sorry for sound quality https://youtu.be/V1JczM4ONqU

Above is proof that everything works just fine using Photoshop 23.0.1.

Video reply to Adobe Forums thread https://community.adobe.com/t5/photoshop-ecosystem-discussions/photoshop-v21-does-not-save-in-original-location-when-using...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

Hi Bojan, 

 

Thank you for looking into this again, I have just replicated this on my machine and it doesn't work the same unfortunately, I wonder if it is an issue with Mac OSX. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

It should work identically but... There are some differences between two operating systems which may result in different behavior. Wait for someone to check again on Mac. If everything works fone then its only your machine and will be more difficult to solve problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines