• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Photoshop v24 not compatible with Catalina

New Here ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

Hi, today I tried to install the newest version of photoshop v24 and it´s not compatible with my OS Catalina. Catalina is only 3 years old. Install the newest OS for my mac is a problem for me, I have a lot of necessary small apps that will not work with the newest OS. I can´t believe psd 24 is not compatible with a 3 years old OS.

TOPICS
macOS

Views

523

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

Hi, It's been Adobe policy for years to support the current and the previous version of the Operating systems.

See for 2022, it was up to catalina: https://helpx.adobe.com/download-install/kb/operating-system-guidelines.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

While this is typically true, surprisingly both Illustrator 2023 & InDesign 2023 are still compatible with macOS Catalina. It's kind of odd to be able to only update 2/3 of the apps you rely on. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

 


@leighr wrote:

surprisingly both Illustrator 2023 & InDesign 2023 are still compatible with macOS Catalina. 


 

 

Each app has it's own system requirements, so you need to check each separately.

 

https://helpx.adobe.com/illustrator/system-requirements.html

Operating System

  • macOS version 12.0 (Monterey)
  • macOS version 11 (Big Sur)
  • macOS version 10.15 (Catalina)

 

https://helpx.adobe.com/indesign/system-requirements.html

Operating System

  • macOS version 12.0 (Monterey)
  • macOS version 11 (Big Sur)
  • macOS version 10.15 (Catalina)

 

 

You probably won't want to do what I did when faced with your situation in 2017. I had a computer that wouldn't run the newest Creative Cloud and apps that wouldn't run in the newest macOS. I resolved it by buying another computer and using both until the apps caught up a couple of years later.

 

Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Maybe doesn't Illustrator or Indesign rely on certain technologies/frameworks that Photoshop does?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

One reason I don't use a Mac nor change my OS unless absolutely necessary. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

Well, Win 10 needs to be at least 20H2, so there's a treshold as well...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

You'll either have to update to Big Sur or roll back Photoshop.

https://helpx.adobe.com/photoshop/system-requirements.html

If you wish to roll back to an older version, use the Creative Cloud application, click on the three dots (...) and select “Other Versions”.

 

Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 19, 2022 Oct 19, 2022

Copy link to clipboard

Copied

@PABLO249344744yd6 

 

Here are the system requirements for Photoshop 2023 (v. 24.0):

https://helpx.adobe.com/photoshop/system-requirements.html

Scroll down past Windows OS to see macOS.

 

Operating system macOS Big Sur (version 11.0) or later  macOS Big Sur (version 11)
Installation is blocked on v10.15.x

 

Operating system Windows 10 64-bit (version 1909) or later; LTSC versions are not supported

 

Although Catalina is only three years old, Apple has been releasing a new macOS every year since 2013. After Catalina came macOS11 Big Sur and macOS12 Monterey. Next week macOS13 Ventura is due to be released.

 

You can continue using the Photoshop version that works with your system until you are ready to upgrade.

 

Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 20, 2022 Oct 20, 2022

Copy link to clipboard

Copied

Anytime you are updating to a newer version using the Creative Cloud Desktop app

and you see this:

Screen Shot 2022-10-20 at 1.05.10 PM.png

It's a button.

Click on it and it will give you a pop-up with details, and the "Learn More" is a link to the current requirements

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

LATEST

Thank you for your comments. Maybe this is not a big problem with photoshop because you can open latest photoshop v.24 files with older v.23 version. The problem would be a big problem with indesign, which does not let you open later versions that are not saved as idml.

 

I work in a company with a lot of freelance people passing files from one to another on the cloud. If someone switches to the latest version of indesign, we all have to switch to that latest version because if we don't, indesign won't let us open their indd files made with latest version. So if one day, Catalina (my OS) does not support the latest version of indesign, obviously I will be forced to upgrade the OS to continue working and I will lose a lot of small applications that will stop working because of the new operating system.

 

Illustrator and photoshop do not have this drawback. Why Indesign does?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines