Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


PS new versions compatibility with OS 10.13?

New Here ,
Dec 17, 2020 Dec 17, 2020

Copy link to clipboard

Copied

I see that both the new versions of PS and LR Classic require Mac OS 10.14 at minimum.  Apparently this stops any updates for versions that will run on 10.13.   Are there any alternatives for owners of older Macs that can't be upgraded to 10.14?

Thanks,

Bob Gall

TOPICS
Mac

Views

57

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Nov 01, 2021 Nov 01, 2021
I have an imac 2017 and not sure if I can update my OS any higher than that - or if in fact it is worth it?
That's a question for Apple. Compatible Macs are listed here: https://support.apple.com/en-au/HT212551 Easiest way to check on your Mac is to click Apple logo (top LHS corner of the screen) > About This Mac > Software Update Then follow the prompts. Systems requirements for your apps: Photoshop https://helpx.adobe.com/photoshop/system-requirements.html Lightroom Classic https://helpx.adobe.com/lightroom-classic/system-requirements.html...

Likes

Translate

Translate
New Here ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

I presently have macOS High Sierra version 10:13:6 on my imac. Have the PS 2020 and LR Classic paln and want to udate to the newer versions released last week. Please advise if macOS  Catalina will spport the newest versions? I have an imac 2017 and not sure if I can update my OS any higher than that - or if in fact it is worth it?

Thanks,

Maddy Nielsen

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

quote

I have an imac 2017 and not sure if I can update my OS any higher than that - or if in fact it is worth it?

 

That's a question for Apple. Compatible Macs are listed here:

https://support.apple.com/en-au/HT212551

 

Easiest way to check on your Mac is to click

  • Apple logo (top LHS corner of the screen) > About This Mac > Software Update
  • Then follow the prompts.

 

Systems requirements for your apps:

Photoshop https://helpx.adobe.com/photoshop/system-requirements.html

Lightroom Classic https://helpx.adobe.com/lightroom-classic/system-requirements.html

 

In short, both require either Catalina, Big Sur or Monterey.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

A 2017 iMac will run the current macOS Monterey.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

LATEST

The cutoff for Mojave is roughly 2011, so maybe its time to consider upgrading to a newer machine?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines