PSD preview (quick-look on Mac) is not accurate at all and buggy

Engaged ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

I'm noticing that some of my files are acting weird when I use the quick-look (Mac) to preview them. Even inside the Preview app, they are way different from when I open them with Photoshop.

Look at the colors, how different they are. Also note how the "dirt" layer that's on top is way more subtle inside Photoshop, but then when I preview them, it's this big mess, super obvious.

On one experience I don't even have that layer visible and it's still showing up...

Can someone tell me what could be happening?

 

Screen Shot 2022-01-29 at 6.09.05 PM.pngScreen Shot 2022-01-29 at 6.15.19 PM.pngScreen Shot 2022-01-29 at 6.27.14 PM.pngScreen Shot 2022-01-29 at 6.27.27 PM.png

TOPICS
macOS

Views

389

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 29, 2022 Jan 29, 2022
You could save your psd files with Maximize PSD and PSB File Capatibility under Photoshop>Preferences>File Handling. The downside is your files will be twice as big in terms of size on disk.

Likes

Translate

Translate
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

First of all, the preview in Photoshop is correct.

As to why the Finder or others may not could be based on if you have layers, what kind of layers and possible blend modes etc. Also what kind of documents are saved (TIFF, PSD etc).

The only accurate way to view such data is also at 1:1 (100%) or greater which isn't happening in the Finder and may not by default in say Preview. If you subsample down (zoom out), the previews are not accurate, especially with respect to sharpness, moiré etc which may be what is happening with the 'dirt'.

Bottom line, ignore anything but what you see in Photoshop with such documents.


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Thanks for the reply! 🙂

 

Yes, I rely on what I see inside Photoshop, because ultimately when I export the flatten version, it shows as it should. Still, I would like to being able to preview the files using quick-look without opening the files. I can't confirm this 100%, but I'm 99.9% sure that this is the first time I'm experiencing such a weird thing. 

 

For example I was just testing the file "SOUNDS" and I removed every single layer and only kept the backgorund with the blue texture and then a layer above it that's all black with 20% opacity. All I get on my preview/quick look, is a black preview. Not normal, right? There are no blend modes, no weird effects, anything. Just 2 layers, one of them with 20% opacity.

 

I also tried resizing the "ARGENTINA" file to 500px so I would be able to see it 1:1 when using quick look. Same thing. Also opened with Preview, same issue. So apparently, something's happening and I can't figure out what...

 

I'm attaching 2 of those files, let me know if you experience the same thing?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

The thumbnails in the Finder and the actual images appear very close visually, under OS 12.2.  Big difference in size, hence the use of "close".

This is a screen capture of the two images previewing in Photoshop with the thumbnails to the right.

PSvsFinder.jpg


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

But please note that my issue is not with the thumbnails. Those are good on my end. The issue is with the quick-look feature and then inside the Preview app. Can you check those as well, please? 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

QuickLook doesn't match. It is 'broken', don't use it.

Preview is wrong, don't use it.

Photoshop is correct.

Maybe a bug needs to be filed over at Apple with respect to Quick Look and Preview but the Adobe product is fine.


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Also, if the issue was blending modes, etc, wouldn't it make sense that when I disable the layer with the texture, it would also remove it from the preview? It sounds like some kind of bug. What do you think?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

I would like to examine one of your files and see how it displays on my Macbook Pro Catalina system. Can you make the one with the "dirty sky" available?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Hey!

 

I use Catalina as well. 10.15.7

Please check my reply to @thedigitaldog above where I share 2 files.

Let me know if you experience the same thing.

Thank you 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Yes, indeed.

Screen Shot 2022-01-29 at 5.29.49 PM.png

Screen Shot 2022-01-29 at 5.30.26 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

I'd suggest downloading and using Adobe Bridge. It will render your psd previews properly. It's free to download and use.

Screen Shot 2022-01-29 at 5.37.31 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

Enabling "Maximize PSD and PSB File Compatibility" did the trick. 🙂

I think I've used Bridge once or twice. I didn't really see any advantages of using it.

I'm not a graphic designer, at least not as my daily job, so maybe Bridge would be more useful for people who work with PS every day and have hundreds of files that need to be organized and all that? Can you highlight something I may be missing, considering I work on a file here and there? Thanks 🙂

 

And I appreciate your time testing my files and checking if there were solutions to the problem! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

You might want to check the Thumbnail option in PS's File handling preferences. That way Quicklook doesn't to try and create one; Let PS do the work... it know what the file should look like!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Apple's "Preview" doesn't show the image data correctly so I don't see how this has anything to do with how PS or anything else generates a thumbnail.

What the OP may wish to do is save this as a TIFF rather than a PSD (which has no advantages and some disadvantages outside the Adobe ecosystem).

When I open his PSD in Photoshop and save as a TIFF, Apple Preview does show the image correctly. Clearly the Mac is having 'issues' with PSDs.

Again, TIFF is a far better format to be saving images as.


Author “Color Management for Photographers" & "Photoshop CC Color Management/pluralsight"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

Converting the PSD to Tiff does work here.  It's the best idea if Preview can't process the psd.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

Thanks for the suggestion. 

I rather keep all my files as PSD (maybe an "OCD-ish" kind of thing? haha).

And @Jeff Arola 's suggestion of enabling "Maximize PSD and PSB File Compatibility" works like a charm. I don't mind having files that are slightly bigger than the version with that option enabled. I rather have accurate previews when using quick look 🙂

 

I appreciate your time and help! 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

Thanks Brad!

Enabling "Maximize PSD and PSB File Compatibility" did the trick for me 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 29, 2022 Jan 29, 2022

Copy link to clipboard

Copied

You could save your psd files with Maximize PSD and PSB File Capatibility under Photoshop>Preferences>File Handling.

 

The downside is your files will be twice as big in terms of size on disk.

 

mx1a.png

 

 

mx2.png

 

 

mx3.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

I have maximize compatability set to "Always", but this time I used "Save a Copy" to overwrite the file I downloaded and now it works. I was using a "non-destructive change" (i.e. turning a layer visibility off and on) and resaving, but that didn't work.

 

Nice catch, Jeff. You got me to try again and now it works with Quicklook and Preview.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jan 30, 2022 Jan 30, 2022

Copy link to clipboard

Copied

Jeff, you're the savior!

That worked like a charm! And the files are not double in size. They are bigger, but this one went from 80MB to 110MB so it's not that bad. I have plenty of space on my disk anyway and to be honest I rather have a good preview of the file so I don't have to open Photoshop all the time, and sacrific a little bit more of space 😉 

 

Really appreciate your help!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

For me quicklook is only showing small thumbnails when I try to preview images when pressing spacebar. I recently upgraded to an M1 and using Monterey? Annoying, as I use quiklook all the time and need to see a bigger image. Is this something I can set elsewhere?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 17, 2022 Jun 17, 2022

Copy link to clipboard

Copied

LATEST

Def a bug with the OS. It happens every now and then, but fine after a restart. This is not what I expect from apple.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines