Slow Photoshop on Dell XPS 9560 4K

Community Beginner ,
Aug 16, 2017 Aug 16, 2017

Copy link to clipboard

Copied

Hi, I bought a new Dell XPS powerhouse with 4K display for work with Ps and Ai. It is an amazing machine, however these two software works very slow on my notebook.

It is very annoying and I can't do anyting with this. I also have high CPU usage, and warming. I tried this hack, but doesn't work. Both of them are GPU (gtx 1050) accelerated.
I did the same tests with Affinity Designer and it works fine. Please give me some advice about this, because it drives me crazy...

Views

5.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Aug 28, 2017 Aug 28, 2017
Hi! I had to (clean) reinstall windows 10. The problem solved. Ps is working.

Likes

Translate

Translate
Adobe Community Professional ,
Aug 16, 2017 Aug 16, 2017

Copy link to clipboard

Copied

That hack is for display scaling on legacy PS/Ai versions that didn't support 4K / UHD. It has no relevance for speed issues.

It's most likely a video driver issue. While you wait for a driver update that may or may not fix it, try to turn GPU off entirely in both apps' Preferences. It's not essential for basic functionality. If that helps, turn it back on in Photoshop and try the basic > normal > advanced settings respectively.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2017 Aug 16, 2017

Copy link to clipboard

Copied

Hi! Thanks for the answers!
@D Fosse

I turned off the GPU, but the interface lag is the same. The Layer Style window late about 4-5 sec after the double click. Right now it doesn't kick on the fan.

@davidc1815

Do you have the 1080p or the 4K panel? I have the latest driver from the nVidia and the Intel too.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 17, 2017 Aug 17, 2017

Copy link to clipboard

Copied

Yeah, I should have remembered: Dual video cards do not work well with Adobe applications. Adobe warns aginst it:

"Photoshop currently doesn't take advantage of more than one graphics processor. Using two graphics cards does not enhance Photoshop's performance.

Multiple graphics cards with conflicting drivers can cause problems with graphics processor accelerated features in Photoshop. For best results, connect two (or more) monitors into one graphics card.

If you have to use more than one graphics card, make sure that they are the same make and model. Otherwise, crashes and other problems can occur in Photoshop".

https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2017 Aug 17, 2017

Copy link to clipboard

Copied

My old desktop (i3)  also had IGP and a GTX 950 and there was no problem with the Ps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 17, 2017 Aug 17, 2017

Copy link to clipboard

Copied

I have the 4K screen. It might be worth telling the software to use the Nvidia card in Photoshop. Do this by right clicking on the Desktop and choose Nvidia Control Panel, and then Manage 3D settings.  Then go to Programme Settings and set Photoshop.exe and Sniffer.exe to use the Nvidia card. See if that helps your speed.

David

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Aug 16, 2017 Aug 16, 2017

Copy link to clipboard

Copied

I have the 9550 which works fine with CC 2017.  Do you have an Intel and Nvidia gpu in your laptop?  Is Photoshop detecting your Nvidia card?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 17, 2017 Aug 17, 2017

Copy link to clipboard

Copied

You should check your performance preferences, as you might need to tweak them, see more on Optimize performance Photoshop CC

Check if basic options for GPU acceleration is enough, and be sure that you're plugging in your laptop in order to use high performance and the discrete GPU.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2017 Aug 18, 2017

Copy link to clipboard

Copied

Hi, I set up everything, what you advised but nothing happend. Thanks guys.
Maybe I should reinstall windows.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 28, 2017 Aug 28, 2017

Copy link to clipboard

Copied

Hi!
I had to (clean) reinstall windows 10. The problem solved. Ps is working.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 28, 2018 Mar 28, 2018

Copy link to clipboard

Copied

hi i seem to have the same problem on a lenovo yoga which is brandnew... i already exchanged the comoputer i resetted windows i did everything to enhance the perfomrnce nothing really helped

affinity is super fast

i´m only on a normal ps behavior if i scale down and disable the gtx 1050

do you have any idea what it could be

as i´m a bit sick of installing all the time

did you go back to windows as it was

or download the insatlable windows

sorry am as well jut going back from mac to pc

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

I had the same problem.

XPS 9560 with 4K screen and 16GB of RAM. Slow as hell with LR 6.12. Windows 10 was factory installed (fresh).

Here's what I found out: this laptop is simply not optimized for "heavy lifting".

Basically:

- Cooling is marginal. On my laptop, it meant that it would run at full speed (3.4Ghz, all 4 cores) for only about 20 seconds before it throtted back to 1.6Ghz due to overheating (Cpu reached 97C, then speed dropped). Had to wait a long while before temperature would go down and reach levels at which the Cpu could give me full speed again. Then only for about 15 seconds.

Here's how I fixed it:

Installed ThrottleStop (google it up).

Then offset the Cpu and Cache voltage by -125mv. Save settings.

That solved it: Cpu would no longer throttle and kept running at 3.4Ghz on all 4 cores, indefinitely without ever reaching over 87C (in a room at about 26C ambient temperature).

System is stable and this has no risk of damaging hardware.

Hope this helps other PS and LR users out there who are frustrated with the performance of their XPS 9560 laptop.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 23, 2018 Apr 23, 2018

Copy link to clipboard

Copied

LATEST

Hi! I have similar issues and installed ThrottleStop but I'm a little overwhelmed by the settings - can you maybe provide a screenshot which options I have to tweak regarding "Then offset the Cpu and Cache voltage by -125mv." --> Thanks!!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines