• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Slow PS performance when opening photo from Lightroom

Explorer ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Hey all, ever since Photoshop v.20 or so performance has dropped off of a cliff when used in conjunction with Lightroom. 

I used to be able to open a photo I'm working on in Lightroom via "Edit in Photoshop" without issue but for the past month or so when I do so performance becomes erratic - slow hand/moving tool, slow zoom, slow wonky pen tool actions (when I set a a straight line/anchor point it automatically adds a curve to it) when using a tablet (XP-Pen), and a myriad of other issues including "alt+click" not registering without multiple repeated clicks while using the clone/heal tools. Pretty much everything at the minimum has a second or two delay before registering. 

 

The only solution I've found is to open the Edit in PS through Lightroom as usual, saving the file in Photoshop, closing Photoshop, closing Lightroom, then reopening the saved file in Photoshop to work on only to eventually open back in Lightroom for final edits and export. 

 

This additional action takes time and adds frustration which is the enemy of creation. I'm hoping that instead of constantly adding new features Adobe starts fixing current problems, I'll gladly take a smoothly running piece of expensive software vs any other non-sense updates that usually add more problems than solve. Hell, I'll glady take ZERO feature updates for the next year or so in exchange for stability and bug fixes.  I am confident that many/majority of people would support that proposition. 

 

My System -

AMD 3900X

Windows 10

Nvidia 1070 ti

Samsung M.2 SSDs + Sabrent PCIE 4.0 M.2 SSD (which all Adobe apps are installed). 

Corsair 64GB DDR4 2666 Ram

 

Running latest Adobe updates.

TOPICS
Windows

Views

973

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

It is a nightmare now! I am professional wedding photographer and pretty ofteen ned to open raw files in Photoshop for quick edit. After recent updates it is extremely SLOW! It was pretty fast before so hardware is not the issue! When opening processor running at 12%, so ADOBE - PLEASE FIX IT!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Hi there.

Same issue here. As soon as I close LRC, PS start running fast again, but while open it's impossible to work with. Running latest Adobe updates too. 

 

AMD Ryzen Threadripper 1950X

64 Gb of RAM

NVIDIA GeForce GTX 970

Win 10 Pro and Adobe APPs installed on a M.2 SDD
Pictures and LGC catalog on a separated SSD Samsung 860

Cache files on another SSD Samsung 860

 

Any help welcome.

Thanks in advance.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2023 Feb 04, 2023

Copy link to clipboard

Copied

 

I'm experiencing the exact same problem. Photoshop is running very slow when I open an image from Lightroom but works fast when I open Photoshop without passing through Lightroom.  I'm running PS 2023 24.1.1.

 

This thread is two years old and I can't see any response posted. Did you guys find a solution?

 

Thanks

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2023 Mar 22, 2023

Copy link to clipboard

Copied

The same issue has just started happening for me - takes several minutes to get a file open in Photoshop using the "Edit in Photoshop" command in Lightroom. Also equally slow time saving back. Wondering if the recent LR update did something.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2023 Mar 22, 2023

Copy link to clipboard

Copied

LATEST

Nevermind on my issue - was a user error as in most cases :). Had the external drive that had my images temporarily connected via a port on the keyboard and not direct into computer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines